Corsiar HX620 and vid card problem?

Enclosures, modding, blowholes, and the power needed to run it all.

Moderators: Nemesis, SpotTheCat

Corsiar HX620 and vid card problem?

Postposted on Thu Jan 01, 2009 8:11 pm

Anyone running a HX620 and a newer Nvidia 200 series card?

http://www.asktheramguy.com/v3/showthread.php?t=74923

I was 100% ready to buy a HX620 for my new build until I read this. I was planning on picking up 260 card too. Any thoughts?
crimsonjax
Gerbil
 
Posts: 54
Joined: Mon Dec 24, 2007 9:40 pm

Re: Corsiar HX620 and vid card problem?

Postposted on Thu Jan 01, 2009 9:24 pm

I've had that buzzing noise problem for a while now. It only starts when a 3D application is running and it somehow varies in pitch depending on the GPU's load. I'm still not sure where the source of the noise is, but it was worse when I still had my X1950XT.
n00b1e
Gerbil
 
Posts: 41
Joined: Sun Jan 28, 2007 1:30 am

Re: Corsiar HX620 and vid card problem?

Postposted on Thu Jan 01, 2009 10:18 pm

Hey noob1e, did some digging and found a guy that solved his buzzing problem. Might help?

http://www.asktheramguy.com/v3/showthread.php?t=75330
Hello,

First of all, sorry for my english I'm french.

A buzzing electrical noise (not a fan noise) was comming from my power supply.(new PC : I7 920, DDR3, HD4870, Gigabyte X58-UD5,.. Corsair TX650).
I've made some test with another new power supply(not a corsair one) and the noise was still there .. so I've started to search why...

It seems that the problem was comming from the 'powersaving' systems use by Intel processors. Something seems to be wrong when they are activated in the bios ( a kind of incompatibility between MB-CPU-Graphic-Power working together).

Before the RMA procedure I suggest you to try to set the 2 parameters :

C1E and EIST (Enhanced Intel Speedstep Technology) to disable in the MB BIOS.

It seems this solution is working fine specially for new PC (Core 2 duo or better).
Hope it will help some of people reporting buzzing noise to avoid unnecessary RMA.

My TX650 works fine and I'm happy of it.

Regards.

TBW
crimsonjax
Gerbil
 
Posts: 54
Joined: Mon Dec 24, 2007 9:40 pm

Re: Corsiar HX620 and vid card problem?

Postposted on Thu Jan 01, 2009 10:22 pm

I'm betting it's coil noise rather than anything fan related. It shouldn't really effect the performance of the unit, but if anyone has problems like that Corsair has a good RMA process and warranty on their units.
MaxTheLimit
Gerbil Jedi
 
Posts: 1808
Joined: Wed Jan 17, 2007 10:00 pm
Location: Ontario, Canada

Re: Corsiar HX620 and vid card problem?

Postposted on Fri Jan 02, 2009 12:15 am

I'm not really that concerned, to be honest. I've had the problem for about 2 years now and yet the PC is still running perfectly OK (touch wood). Besides, now that I've got the 260 the buzzing noise is a lot fainter than before.
n00b1e
Gerbil
 
Posts: 41
Joined: Sun Jan 28, 2007 1:30 am


Return to Cases and Power Supplies

Who is online

Users browsing this forum: No registered users and 1 guest

cron