PSU clicking when powered down

For small-form factor PCs and the (extremely small) people who love them.

Moderators: mac_h8r1, Nelliesboo

PSU clicking when powered down

Postposted on Fri Oct 24, 2003 3:23 am

Noticed last night that my PSU is making a clicking noise, when the system is powered down, but with the mains cable connected. Has anyone experienced anything like this ?
It's the default PSU that comes with the shuttle SN45G.
fatamos
Gerbil In Training
 
Posts: 6
Joined: Thu Oct 23, 2003 4:20 am

Postposted on Fri Oct 24, 2003 4:07 am

You mean it just keeps clicking even after it's been off?

Or just clicks for a few seconds right after you kill the power? If that's the case it COULD just be the fan slowing down.

That's a pretty big COULD though.
pez-king
Gerbil Jedi
 
Posts: 1558
Joined: Sat Aug 31, 2002 9:45 pm
Location: Pennsylvania

.... after a few hours

Postposted on Fri Oct 24, 2003 5:43 am

..... re-connected the power cable this morning.... after 7hrs of cooling.... and the clicking started straight away.... without firing the pc up.

All external peripherals where disconnected.
Just to make sure that it wasn't an electrical short.... I turned all the lights off, and had a look at it in the dark.... nothing. Although a light does come on the motherboard, which I didn't expect.

The noise only disappears when the system is fired-up, only to return once powered down.
fatamos
Gerbil In Training
 
Posts: 6
Joined: Thu Oct 23, 2003 4:20 am


Return to SFF Station

Who is online

Users browsing this forum: No registered users and 1 guest