Logitech USB mic always on with windows 7? Help please

The place to sound off on all things related to audio, from sound cards to speakers.

Moderator: Captain Ned

Logitech USB mic always on with windows 7? Help please

Postposted on Thu Nov 19, 2009 9:00 am

Using my USB logitech mic plugged into case with windows 7 and HT striker sound card I had a hard time getting the mic to work. When I did get it working it's always on and b/c of this I can't use the mic for gaming due to it picking up all the game noise coming from my speakers sending it back to my teamates I'm trying to communicate with. I want this to work like it should and the mic to be active when I press the assigned key to activate during the game. Anyone know what I'm doing wrong or is this just a bad setup. I know there's a setting that says something like hear playback through speakers. When I tick this the mic works but it's always on withought pressing any keyes or even being in a game. When I un check this the mic won't work at all. I'm not sure if it's just a setting somewhere I'm missing or I have wrong, if this is a windows 7 bug, or if the mic isn't a good setup for my sound card and maybe need a mic that plugs right into the sound card and not a usb mic. Any help would be greatly appreciated. The links below are of the microphone and sound card I have.


Logitech usb microphone http://www.logitech.com/index.cfm/webca ... 1&cl=us,en

HT Omega Striker 7.1 sound card
http://www.htomega.com/striker.html
Cooler MAster HAF case
Corsair 850w powersuply
MSI 790FX-GD70
AMD Phenon x4 695 Black Edition 3.4 GHZ
GSkill 6 GB DDR3 1600
Danger
Gerbil Team Leader
 
Posts: 278
Joined: Sat Sep 28, 2002 5:12 pm
Location: Upstate, NY area

Re: Logitech USB mic always on with windows 7? Help please

Postposted on Thu Nov 19, 2009 9:11 am

Well, I have the same microphone, on the system below- I'm using the onboard Realtek codec. Using Windows 7 Pro (ordered from MS).

I've had trouble getting microphones working right; particularly, if I go into Counter-Strike, I had to run Ventrillo as Administrator, or it would not respond to the PTT key- that's while the in-game voice works fine. I know that this issue isn't the same as yours, however, while 7 has been mostly bulletproof, these issues have been popping up.
Canon 6D|24-105/4L IS USM|70-300/4-5.6 IS USM|40/2.8 STM|50/1.4 USM|85/1.8 USM|Samyang/Bower 14/2.8 Full-Manual Rectilinear Wide-angle|24/2.8 IS USM|
Canon EOS-M|11-22/4-5.6 IS STM|22/2 STM|EF-M 18-55/3.5-5.6 IS STM|
Airmantharp
Gerbil Elder
Gold subscriber
 
 
Posts: 5130
Joined: Fri Oct 15, 2004 10:41 pm

Re: Logitech USB mic always on with windows 7? Help please

Postposted on Thu Nov 19, 2009 9:49 am

I'm thinking it has to do with the mic being USB not liking my sound card. I'll try and find a diff mic with the jack and plug it directly into the mic port on the sound card and see if it solves this. Kinda frustrated. I want to be able to play the games and not spend hours trying to get this new mic to work :evil:
Danger
Gerbil Team Leader
 
Posts: 278
Joined: Sat Sep 28, 2002 5:12 pm
Location: Upstate, NY area

Re: Logitech USB mic always on with windows 7? Help please

Postposted on Thu Nov 19, 2009 11:05 am

Is there such a thing as a USB to audio converter that has a jack that goes into the audio port then the end is a female usb port that I can plug my usb mic into? I've seen this but it was reversed and the end of the converter was a male usb to a female audio jack :-(
Cooler MAster HAF case
Corsair 850w powersuply
MSI 790FX-GD70
AMD Phenon x4 695 Black Edition 3.4 GHZ
GSkill 6 GB DDR3 1600
Danger
Gerbil Team Leader
 
Posts: 278
Joined: Sat Sep 28, 2002 5:12 pm
Location: Upstate, NY area

Re: Logitech USB mic always on with windows 7? Help please

Postposted on Thu Nov 19, 2009 1:54 pm

You now have two "soundcards": your HT Omega, and your Logitech USB mic, which at the very least, presents itself as a different device to Windows. Keep that in mind.

You have to select your Logitech microphone device as your main voice communication device and/or recording input. Do not confuse this with the mic input on the HT Omega. That's the first step. Second step, is to make sure that the RECORDING volume is set to max. You might also have to enable the "microphone +10dB boost", if it still ends up too quiet. Third, you have to mute the PLAYBACK for the microphone. Then keep it at a sufficient distance from the speakers. You'll be golden.
There is a fixed amount of intelligence on the planet, and the population keeps growing :(
morphine
Grand Admiral Gerbil
Silver subscriber
 
 
Posts: 10091
Joined: Fri Dec 27, 2002 8:51 pm
Location: Portugal (that's next to Spain)


Return to Echo Vale

Who is online

Users browsing this forum: No registered users and 3 guests