Creative X-Fi XtremeMusic Screech/Static Problem

The place to sound off on all things related to audio, from sound cards to speakers.

Moderator: Captain Ned

Creative X-Fi XtremeMusic Screech/Static Problem

Postposted on Sat Sep 03, 2011 7:41 am

My system is the following:

Core 2 Duo e6420 @2.9Ghz lightly overclocked
Abit IP35-e
2x2GB DDR2-1066 RAM
Sapphire Radeon HD5850 Xtreme
2x 1TB Samsung F3
1x 640GB Western Digital Caviar
Creative X-Fi XtremeMusic PCI
Audio-Technica ATH-AD700
Windows 7 Ultimate 64bit

I am having significant issues with my sound card. These started about 6 months ago and have happened occasionally since.

When I turn my computer occasionally the only sound I can hear through my headphones is a very loud static or screeching sound, with the original sound which should be playing very faintly audible in the background.
No matter what volume level I have set, this screeching sound is almost deafening.
Apart from this, however, I haven't had any problems with the soundcard.

I have the my motherboard's realtek HD audio disabled in the BIOS and uninstalled in windows. I have tried various Creative X-Fi drivers, none have completely fixed this issue. Uninstalling and reinstalling the Creative drivers fixes the issue on the next reboot but the screech will come back within a week or two.
I did not have this issue on my previous Creative Audigy 2 ZS sound card.

According to Device Manager the X-Fi is using IRQ 23, along with the ICH9 USB controller hub.

I have tried moving the X-Fi to the only other PCI slot which isn't in the way of my graphics card, but that results in the system hanging on the windows loading screen.

Any advice on how to fix this issue would be greatly appreciated.
kalelovil
Gerbil In Training
 
Posts: 6
Joined: Tue May 24, 2011 12:43 am

Re: Creative X-Fi XtremeMusic Screech/Static Problem

Postposted on Sat Sep 03, 2011 8:16 am

Sounds like the mic input is in the output mix, and picking up feedback.
There is a fixed amount of intelligence on the planet, and the population keeps growing :(
morphine
Gerbil Khan
Silver subscriber
 
 
Posts: 9932
Joined: Fri Dec 27, 2002 8:51 pm
Location: Portugal (that's next to Spain)

Re: Creative X-Fi XtremeMusic Screech/Static Problem

Postposted on Sat Sep 03, 2011 10:11 am

morphine wrote:Sounds like the mic input is in the output mix, and picking up feedback.

I don't see how it could be.
I have disabled all the recording devices and the same issue still exists.
kalelovil
Gerbil In Training
 
Posts: 6
Joined: Tue May 24, 2011 12:43 am

Re: Creative X-Fi XtremeMusic Screech/Static Problem

Postposted on Sat Sep 03, 2011 10:25 am

Can you test the card in another system?
(this space intentionally left blank)
just brew it!
Administrator
Gold subscriber
 
 
Posts: 37493
Joined: Tue Aug 20, 2002 10:51 pm
Location: Somewhere, having a beer


Return to Echo Vale

Who is online

Users browsing this forum: No registered users and 1 guest