Logitech Z-5500 Dead?

The place to sound off on all things related to audio, from sound cards to speakers.

Moderator: Captain Ned

Logitech Z-5500 Dead?

Postposted on Mon Sep 23, 2013 7:53 pm

My Logitech Z-5500 have not been able to start. When you press the power button the pod turns on but will only stay on while you hold down the power button while displaying "Input: Direct 96-24, Effect: Detecting...". The second that you release the power button it returns to the idle red ring on the power button. I have tried different power outlets, changing inputs, and putting in new fuses. Any idea what to try?
Antec P180 Mini | CPU:X4 955 BE | MB:Asus 785G | HD:SSD 64GB, Seagate 3TB | RAM:8GB | VGA:AMD 7950 | Sound:Z-5500 & Via Envy24 | Mouse:MX510 | LCD:Asus 27", LG 23" | OS:Win 7
JoJoBoy
Gerbil
Silver subscriber
 
 
Posts: 54
Joined: Tue Jan 27, 2009 2:47 am
Location: San Jose

Re: Logitech Z-5500 Dead?

Postposted on Mon Sep 23, 2013 10:12 pm

If it only stays on while holding the power button... maybe the power button is broken?

Contact Logitech. You might be surprised what they might do for you...

P.S. I'm still running with my Z-680, the predecessor to the 5500. And loving it.
JdL
286DX > Pentium Pro 200 > Athlon 1000 @ 1.4 GHz > Athlon 64 2.2 GHz > Athlon XP 3200+ > Core 2 Duo 3300 @ 4.0 GHz > Core 2 Quad 6600 G0 @ 3.2 > Core i7 3770 @ stock
JdL
Gerbil Elite
 
Posts: 999
Joined: Thu Aug 29, 2002 11:45 am
Location: United States of America

Re: Logitech Z-5500 Dead?

Postposted on Tue Sep 24, 2013 1:00 pm

As others said, try contacting Logitech. IME, their build quality's gone down since the early 2000s.

A friend of mine had a set of Z-5500s that had to be fixed due some power circuitry shorting out. The guy that fixed it said that it was not a matter of if it was going to break, just when, since the wiring and capacitors weren't up to par :roll:
There is a fixed amount of intelligence on the planet, and the population keeps growing :(
morphine
Gerbil Khan
Silver subscriber
 
 
Posts: 9987
Joined: Fri Dec 27, 2002 8:51 pm
Location: Portugal (that's next to Spain)

Re: Logitech Z-5500 Dead?

Postposted on Tue Sep 24, 2013 8:07 pm

Called customer support this afternoon to no relief. They were able to get in into diagnostic mode but then it never displayed the firmware edition that it should have. They have no parts available to fix this system.
Antec P180 Mini | CPU:X4 955 BE | MB:Asus 785G | HD:SSD 64GB, Seagate 3TB | RAM:8GB | VGA:AMD 7950 | Sound:Z-5500 & Via Envy24 | Mouse:MX510 | LCD:Asus 27", LG 23" | OS:Win 7
JoJoBoy
Gerbil
Silver subscriber
 
 
Posts: 54
Joined: Tue Jan 27, 2009 2:47 am
Location: San Jose

Re: Logitech Z-5500 Dead?

Postposted on Wed Sep 25, 2013 12:34 am

Looks like the cheapest fix will be a replacement second-hand control pod bud. They're running around the $140 mark on eBay here in Australia, which seems a bit pricey - but then I guess you can't find Z-5500s much anymore. You should be able to find them a bit cheaper Stateside :)
3770, 16GB, QUO AOS, GTX 690, 512GB 840 Pro, Xonar DSX - Watercooled DS Cube
juzz86
Gerbil
 
Posts: 44
Joined: Thu Mar 28, 2013 5:37 am
Location: Australia

Re: Logitech Z-5500 Dead?

Postposted on Wed Sep 25, 2013 2:16 am

Anything I see with power issues gets the usual blown cap check...
WAIT, any electronic stuff with issues gets the blown cap check!
Crack open the PSU and see if you can spot any bloaters.
If we cannot be free, at least we can be cheap! FZ.
satchmobob
Gerbil Team Leader
 
Posts: 212
Joined: Tue Oct 15, 2002 2:42 pm
Location: Worcester, UK


Return to Echo Vale

Who is online

Users browsing this forum: No registered users and 1 guest