Asus P8Z77-V LK / SSD / Raid

Discuss the core components that make up the heart and soul of any good computer.

Moderators: Flying Fox, Thresher

Asus P8Z77-V LK / SSD / Raid

Postposted on Sun Apr 21, 2013 7:21 pm

New build with Asus P8Z77-V-lk. Was intending to use Samsung 840 series SSD as boot drive with (2) WD Red drives in raid 1 array. SSD controller needs to be set to AHCI mode while raid array needs to be set to Raid.

Does this motherboard have one controller thus unable to use both SSD and (1) raid array? When I change it to Raid setting - it will not boot into windows. When I leave the setting to ACHI - boots fine but single WD Red drives are discovered and not RAID array.

Any help would be appreciated.

Thank you,
garycooper
Gerbil
 
Posts: 46
Joined: Tue Jul 10, 2007 7:48 pm

Re: Asus P8Z77-V LK / SSD / Raid

Postposted on Sun Apr 21, 2013 8:53 pm

garycooper wrote:New build with Asus P8Z77-V-lk. Was intending to use Samsung 840 series SSD as boot drive with (2) WD Red drives in raid 1 array. SSD controller needs to be set to AHCI mode while raid array needs to be set to Raid.

Does this motherboard have one controller thus unable to use both SSD and (1) raid array? When I change it to Raid setting - it will not boot into windows. When I leave the setting to ACHI - boots fine but single WD Red drives are discovered and not RAID array.
I'm not really the very best person to help, but I might have some insight. I've used Intel fakeraid a fair bit.

Basically, what you need to do -- what I normally do -- is set the drive controller to RAID mode, then use whatever hotkey (usually like Ctrl+R or Ctrl+J) to enter the RAID setup utility when booting. Set up your RAID array(s), then reboot and install Windows. You definitely can have drives that are not part of an array; I've done that plenty of times.

I don't know if you can change from AHCI to RAID mode on an already-setup Windows install without confusing the heck out of the bootloader.
i5-3570K @ 4.4 (NH-C14), 4x8GB DDR3-1866, GA-Z68MA-D3H-B2, ASUS GTXTITAN-6GD5, 128GB Vertex 4 / 2x60GB Vertex Plus R2 / 2x2TB Barracuda 7200.14 RAID0 / ANS-9010 (4x4GB), SST-DA1000 (PSU), 2x VS229H-P, 1x VG248QE, 1x MIMO 720F, Corsair Vengeance K90+M95
auxy
Gerbil Elite
 
Posts: 781
Joined: Sat Jan 19, 2013 4:25 pm
Location: the armpit of Texas

Re: Asus P8Z77-V LK / SSD / Raid

Postposted on Sun Apr 21, 2013 9:20 pm

I sounds like you've already got windows installed in AHCI mode, so what you need to have happen is for the Intel RAID driver to be installed so you can set the mode to RAID and then be able to use the SSD in AHCI (RAID mode includes AHCI for non-raided drives) and the use the others in RAID. The problem, as you've found, is that Windows doesn't have them loaded yet. You can reinstall windows with the controller set to RAID mode as auxy suggests, but maybe easier would be to follow what is suggested here: http://www.geek-republic.com/2009/03/fo ... ows-vista/

It's a bit older, but the guts of Vista and W7 (and a lot of W8) are essentially the same, so I think it should work. I did that back in the day and it worked just fine for me. It's just a matter of getting windows to recognize the controller and install the driver for it so it can boot from the volumes attached to it.
i7-3770K | Asus P8Z77-V LK | 8GB DDR3-1600 | HD5850 | 128GB 840 Pro | Samsung F3 1TB | U2412M | Define R4 | Seasonic 520W M12II | Win7 Pro x64.
frumper15
Gerbil Team Leader
Silver subscriber
 
 
Posts: 236
Joined: Mon Jan 18, 2010 3:25 pm


Return to Motherboards, Chipsets, & RAM

Who is online

Users browsing this forum: No registered users and 2 guests