How do I enable DMA on my HD, CDRW and DVD+RW drives?

All things storage here: hard drives, DVD RW drives, little wicker baskets.

Moderators: morphine, Steel

How do I enable DMA on my HD, CDRW and DVD+RW drives?

Postposted on Wed Dec 11, 2002 6:51 pm

k7s5a motherboard (uses SiS 730 chipset). ATI 8500 DV video card complains that DMA is not enabled and that it MIGHT not be enabled on my IBM 18GB U2W SCSI drive connected to Tekram DC390U2W controller.

I can't find a DMA checkbox anyplace.
Petz
Gerbil
 
Posts: 10
Joined: Wed Dec 11, 2002 6:12 pm
Location: CA

Postposted on Thu Dec 12, 2002 1:30 am

SCSI doesn't use DMA. What operating system are you using?
Blahpony
Gerbil XP
 
Posts: 350
Joined: Mon Oct 14, 2002 11:39 pm

Depends

Postposted on Thu Dec 12, 2002 3:12 am

Hi. If your running either Win98SE/ME, then simply right click on "My Computer" and select "Properties". Once in there, click on the "Device Manager" tab. About 2 or 3 down from the top of list you will see "Hard Disk drives", simply click on that to bring up a window, and you'll see a little tick box that says "DMA" next to it, simply tick it, "Apply" and restart the computer. It's slightly different using WinXP/2000 though. You use the same process, but instead of clicking on a "Device Manager" tab, you have to click the "Hardware" tab, then you'll see an option to click that says "Device Manager". Clicking this will bring up a separate device manager window. Now then, here's the big difference, instead of clicking on "Hard Disk Drives", you have to click on "IDE ATA/ATAPI controllers". Clicking this will bring down a small list to chose from, here you have to click either "Primary" or "Secondary" IDE Channel, depending on what one your HDD is fitted to (it's usually the Primary IDE Controller). After choseing from the menu, a windows will appear and here you have to select the "Advanced Settings" tab, and in here there will be a little drop down menu labelled "Transfer Mode", which is second from the top, here you then select "DMA if avaliable". Apply and restart the computer. Hope I've helped.
pattouk2001
Minister of Gerbil Affairs
 
Posts: 2097
Joined: Thu May 30, 2002 10:44 am
Location: Birmingham, UK.

Postposted on Thu Dec 12, 2002 7:16 am

To add to what pattouk2001 just said:

This (I just found out) is also dependent on if you use MS IDE drivers or a third parties. For example:

On my Intel D845PESV mobo-- after I installed the Intel chipset drivers (called "Intel Application Accelerator") my Advanced Settings tab in Device Manager was REMOVED. :o

Instead if I wanna check DMA status I have to bring up the "Intel Application Accelerator" applet off of my programs menu. It is possible other chipset makers may use a similar scheme.
WebHobbit
Gerbil Team Leader
 
Posts: 280
Joined: Tue Jul 09, 2002 5:07 pm
Location: Indiana - USA

IDE solved! SCSI?

Postposted on Thu Dec 12, 2002 1:25 pm

:oops: Silly me - I have Win2K and I was looking for "enable DMA" under the drives, rather than the primary and secondary controller. Once I selected "use DMA if available" and rebooted, it started using DMA.

But I'm still confused by the response above about SCSI. How could a SCSI controller achieve 80 (or 160) MB/sec without using DMA? I think the ATI PC-check program is just unable to check SCSI controllers, so it says that SCSI drives "may" not have DMA enabled, while, in reality, it does.
Petz
Gerbil
 
Posts: 10
Joined: Wed Dec 11, 2002 6:12 pm
Location: CA

Postposted on Thu Dec 12, 2002 2:32 pm

The SCSI card will use a DMA channel. But the drives wont. DMA refering to hard drives doesnt apply to SCSI. DMA in a system does apply. Alot of motherboards dont accept that the IDE controllers are turned off. So it may need it enabled even if nothing is hooked up.
Blahpony
Gerbil XP
 
Posts: 350
Joined: Mon Oct 14, 2002 11:39 pm


Return to Storage

Who is online

Users browsing this forum: No registered users and 5 guests