Windows 7 64 bit network problem.

Monopoly money comes in many flavors: 7, Vista, XP, 2K, ME, 98, etc.

Moderators: Flying Fox, Ryu Connor

Windows 7 64 bit network problem.

Postposted on Tue Apr 03, 2012 5:54 pm

Have a network with 30 plus computers. Two file servers running Windows 2003 small business. All of the workstations are running Windows XP. I convinced them that they need to start upgrading to Windows 7 pro. So put in a new Intel based motherboard (DH61BE) with i5, 8 GB of ram, Windows 7 64 bit, Intel 82579v Gigabit Ethernet with latest drivers. Installed the software they use (Office 2007, Word Perfect 14, Symantec Endpoint protection, Amicus). All seems fine. They called and wanted me to come back because system was running extremely slow. I got on remotely, changed the nic to 100mb full duplex and problem disappeared. Went on site and discovered if I keep it at 100mb and reboot, it comes up slow. I change it back to 1000mb and runs fine – until I reboot. I then reverse the process and it’s good again. I tried putting in a Netgear 1000mb card but got the same result. I moved the computer upstairs next to the switches, made sure I had cat 5e and still had the problem. 1) any ideas why this is happening? 2) is there a command switch that I could use to write a batch file to change the network card speed after it boots?
bigjohn888jb
Gerbil First Class
 
Posts: 101
Joined: Wed Aug 31, 2011 9:41 am

Re: Windows 7 64 bit network problem.

Postposted on Tue Apr 03, 2012 7:50 pm

You shouldn't have to be changing the network card speed every time it reboots. It sounds like this is either a jumbo frames issue or switch issue.
Have you tried running in 100 half duplex?
-Playing shooters on a console is like doing brain surgery with an ice-cream scoop-
Jon
Gerbil Elite
 
Posts: 968
Joined: Sat Feb 14, 2004 7:44 pm
Location: -Canada-

Re: Windows 7 64 bit network problem.

Postposted on Tue Apr 03, 2012 9:04 pm

I'm going to side with Jon -- Sounds like a bad switch to me.
mnecaise
Gerbil First Class
 
Posts: 118
Joined: Thu Oct 30, 2008 1:17 pm
Location: Hampton Roads, Virginia

Re: Windows 7 64 bit network problem.

Postposted on Thu Apr 05, 2012 1:48 am

I had a similar problem on a small office network (with Windows Server 2003) file transfer to/from the PC was extremely slow. I spent nearly a week reading hundreds of posts on the subject and trying all sorts of configurations with no success.
A couple of people were suggesting the switch was to blame but it worked fine with an XP virtual machine running within Win7 Pro, just really slow from Win7 itself so I didn't think it could be the switch.
Anyway, I had a 100Mb switch plugged into a 1000Mb port on my notebook and the 100Mb switch was connected to a 1000Mb switch elsewhere. When I got rid of the 100Mb switch, my network file read/write speeds went back to what I expected (I was only getting a few kbytes per second).
Something else I found useful was ... TCPOptimizer from Speed Guide Inc.

Craig
clawrie
Gerbil In Training
 
Posts: 1
Joined: Thu Apr 05, 2012 1:02 am

Re: Windows 7 64 bit network problem.

Postposted on Thu Apr 05, 2012 10:19 am

So this only happens on one system, and you tried patching it directly into the switch, with two different NICs and different cables, and it's still happening? Have you tried different ports on the switch? What kind of switch is it? If it's something cheap (which is what I normally find in small offices), and it turns out to be the culprit, you may want to consider replacing it with something a little higher quality. I've found auto-negotiate problems to usually lie with the switch, and it's usually just because it's a cheap one.

Try swapping the switch at a convenient time and see what you find.
absurdity
Gerbil Elite
 
Posts: 874
Joined: Sat Mar 02, 2002 7:00 pm
Location: VT

Re: Windows 7 64 bit network problem.

Postposted on Fri Apr 06, 2012 5:09 pm

The switch is a Netgear GS724T 24 port Gigabit Switch. I got the computer running at 1000mb, did not turn it off, and for two days it was great. The third day it was sluggish. Went into the device manager and switched it to 100mb, waited 30 seconds and switched it back to 1000mb and it was fast again. There are three of these switches and when I took the computer to the server room where the switches are, I plugged into a different port and different switch.
bigjohn888jb
Gerbil First Class
 
Posts: 101
Joined: Wed Aug 31, 2011 9:41 am

Re: Windows 7 64 bit network problem.

Postposted on Sat Apr 07, 2012 4:54 pm

maybe that computer has a virus/trojan on it? and it's serving up:

1. a topsite ftp for all the 0 day warez/music/movies?
2. a hidden torrent in the background doing the same
3. an irc bot that is set up to ddos any given ip.

... i would scan that sucker.
thegleek
Darth Gerbil
Gold subscriber
 
 
Posts: 7367
Joined: Tue Jun 10, 2003 11:06 am
Location: Detroit, MI


Return to Windows

Who is online

Users browsing this forum: FightingScallion, Majestic-12 [Bot] and 2 guests