Missing drive in Windows 8

Monopoly money comes in many flavors: 7, Vista, XP, 2K, ME, 98, etc.

Moderators: Flying Fox, Ryu Connor

Missing drive in Windows 8

Postposted on Wed Jan 23, 2013 4:58 pm

I just did an upgrade from Windows XP to Windows 8 and it seems it won't show me one drive. I have three SATA drives plus a DVD burner. Two of the HDs are showing up (Win8 boot plus data partition, WinXP boot plus data partition) and the DVD burner show up fine. However the third HD which is just a data drive isn't showing up in the list of available drive in Win 8. It shows up in the BIOS during boot, and it shows up if I boot into XP but the HD won't show when I boot in Windows 8.

Any ideas as to why a data drive that works fine (SMART tests pass) won't show in Win8 but will show in WinXP? Any suggestions on how to fix this issue?
nanoflower
Gerbil Team Leader
Silver subscriber
 
 
Posts: 225
Joined: Wed Mar 04, 2009 1:10 pm

Re: Missing drive in Windows 8

Postposted on Wed Jan 23, 2013 5:01 pm

Check diskmgmt.msc first to see if it is just not assigned a drive letter.
Image
The Model M is not for the faint of heart. You either like them or hate them.

Gerbils unite! Fold for UnitedGerbilNation, team 2630.
Flying Fox
Gerbil God
 
Posts: 24841
Joined: Mon May 24, 2004 2:19 am

Re: Missing drive in Windows 8

Postposted on Wed Jan 23, 2013 5:07 pm

Thanks Flying Fox. The drive was there but for some reason the partition hadn't been assigned a drive letter. Not sure why that would happen. Certainly not the expected behavior.
nanoflower
Gerbil Team Leader
Silver subscriber
 
 
Posts: 225
Joined: Wed Mar 04, 2009 1:10 pm

Re: Missing drive in Windows 8

Postposted on Thu Jan 01, 2015 2:39 pm

Hi,

I understand the issue, that the CD\DVD drive is not recognized in windows explorer and also CD\DVD drive is detected in BIOS.

Method 1:
I would suggest you to follow these steps and check if it helps.

a) Right click on the Left Bottom Corner (Start Menu).

b) Run Command Prompt as an Administrator.
c) Type cmd in Windows 8 Metro UI and press cltr+shift+enter.

d) Type following and say enter

reg.exe add "HKLM\System\CurrentControlSet\Services\atapi\Controller0" /f /v EnumDevice1 /t REG_DWORD /d 0x00000001

e) Reboot the system.

f) Verify if the problem has been resolved.

Method 2:

If the issue persists run hardware and troubleshooter and check.

a) Press “Windows Key + R”, type Control Panel.

b) Then type “Troubleshooter” in the Search box and hit enter.

c) Select “Hardware and Sound” from the Troubleshooter Window.

d) Select “Hardware and Devices”.

Method 3:

If the issue persists I would suggest you to follow these steps, uninstall and re-install the CD/DVD ROM drivers in compatibility mode and check if it helps.

Note: Download the drivers from the Manufacturer’s website and install it.

a) Press Windows Key + R, type devmgmt.msc.

b) Expand the CD/DVD ROM drivers, click on the drivers.

c) Click on properties, click on uninstall tab.

d) Click OK.

e) Right-click on the driver executable/installer file.

f) Click on Properties and select the Compatibility tab.

g) Click the checkbox before Run this program in Compatibility mode for option and select Windows 7.

h) In the list-down box; then try installing the device driver via Run as administrator.

Hope this helps.. !!!
vembutech
Gerbil
 
Posts: 43
Joined: Fri Nov 21, 2014 10:29 am


Return to Windows

Who is online

Users browsing this forum: BobbinThreadbare, MarkG509 and 7 guests