Windows 8.1 won't sleep automatically

Monopoly money comes in many flavors: 7, Vista, XP, 2K, ME, 98, etc.

Moderators: Flying Fox, Ryu Connor

Re: Windows 8.1 won't sleep automatically

Postposted on Tue Nov 19, 2013 12:38 am

spennce wrote:Stopped google hangouts from auto running and now my computer sleeps as it should. I had allowed google hangouts to run automatically when I start chrome after upgrading to windows 8.1 and apparently hangouts and 8.1 don't get along. I right click hangouts in lower right corner off desktop and chose options and unchecked start hangouts when I start chrome and now sleep is fine. This might just be coincidence but sleep is working.


So is Chrome always running on your PC otherwise? I wonder if maybe having Chrome closed will allow sleep, or if the Hangouts process is always running in the background after Chrome has been started and closed.

(Conspiracy theory - Google trying to undermine Microsoft :))
MadManOriginal
Graphmaster Gerbil
 
Posts: 1464
Joined: Wed Jan 30, 2002 7:00 pm
Location: In my head...

Re: Windows 8.1 won't sleep automatically

Postposted on Thu Nov 21, 2013 6:18 pm

Hi All,

I have four desktop PC with varying hardware configurations, all between two and three years old, all running Windows 8.1 with Media Center. They were upgraded from Windows 7 to Windows 8 when it was released, then to Windows 8.1. I am a mad updater - so all BIOS, driver and Windows updates are checked for and applied on a regular basis. I would have only occasional sleep problems with Windows 7 and 8 - but I have found this to be not uncommon with Windows of all versions. Mostly the sleep functions worked fine.

After upgrading to Windows 8.1, ALL of the PCs would not automatically sleep. Actually, three of them would sleep automatically if I restarted the PC but did not use it. That is, do nothing on the PC after a restart - not even touch the keyboard or mouse. In this case the PC would then automatically sleep after the sleep timeout period - but not exactly useful. A restart on the fourth PC didn't have the same result - it would not automatically sleep.

Putting the PCs to sleep manually worked fine. And I am not experiencing any other problems with the PCs. Windows 8.1 works perfectly otherwise and I like it.

I now seem to have solved the sleep problem by following two of Ryu Connor's instructions in this thread.

1. Manually start maintenance under Action Center - WinKey+X > Control Panel (Small or Large Icon View) > Action Center > Maintenance > Start Maintenace. Let it complete - this may take quite some time.

2. Under Power Options, select Change plan settings for the active power plan, then select Restore default settings for this plan. Now set the sleep timeout to your desired setting and set any other power plan options you require. I am using the High performance plan and only change the display off timeout, the sleep timeout and set the Require password on wake-up to No. I have left all other plan options at their default settings. Also, my sleep timeouts are generally quite short - 3 minutes on two of the PCs, 5 minutes and 10 minutes on the other two.

3. Restart the PC. Sleep now works perfectly on all my PCs.

I did not make any changes with powercfg or make any other relevant changes. I can't say if just one of the steps alone - forced maintenance or power plan reset - would have had the same result. My testing time was limited and, now that the PCs are all working correctly, I no longer have a problem PC on which to test.

I hope this is helpful. And a big THANK YOU to Ryu.
graymatter
Gerbil In Training
 
Posts: 1
Joined: Thu Nov 21, 2013 4:58 pm

Re: Windows 8.1 won't sleep automatically

Postposted on Mon Dec 16, 2013 12:30 am

Just an FYI... the fix quoted below did not work for me. PC will not automatically enter sleep mode.
Has it worked for anyone else?
Details: HP Pavilion desktop that came with Windows 8.0 (that was my first mistake as a I had an option for Windows 7 at the time)

Second mistake was "upgrading" to 8.1. As many others have reported, the auto sleep function worked fine until the upgrade.



graymatter wrote:Hi All,


I now seem to have solved the sleep problem by following two of Ryu Connor's instructions in this thread.

1. Manually start maintenance under Action Center - WinKey+X > Control Panel (Small or Large Icon View) > Action Center > Maintenance > Start Maintenace. Let it complete - this may take quite some time.

2. Under Power Options, select Change plan settings for the active power plan, then select Restore default settings for this plan. Now set the sleep timeout to your desired setting and set any other power plan options you require. I am using the High performance plan and only change the display off timeout, the sleep timeout and set the Require password on wake-up to No. I have left all other plan options at their default settings. Also, my sleep timeouts are generally quite short - 3 minutes on two of the PCs, 5 minutes and 10 minutes on the other two.

3. Restart the PC. Sleep now works perfectly on all my PCs.

I did not make any changes with powercfg or make any other relevant changes. I can't say if just one of the steps alone - forced maintenance or power plan reset - would have had the same result. My testing time was limited and, now that the PCs are all working correctly, I no longer have a problem PC on which to test.

I hope this is helpful. And a big THANK YOU to Ryu.
Valk97
Gerbil In Training
 
Posts: 1
Joined: Mon Dec 16, 2013 12:23 am

Re: Windows 8.1 won't sleep automatically

Postposted on Mon Dec 16, 2013 2:06 am

Looks like this thread has been revived, and I'm a little late to the party. I'm too tired to read the entire conversation, but I did notice that some of you have Samsung SSDs.......

The Samsung Magician SSD software causes problems with PCs going to sleep. It causes my Win7 rig to randomly wake, and I imagine it would with Win8.x as well. The solution is to not have the Magician software running in the background constantly, or at least unload it before putting the PC to sleep. Not sure if this applies to everything being discussed here, but I thought it was worth mentioning.
i5 2500k - P67 - GTX660 - 840 Pro 256GB - Xonar Essence STX - Senn HD595's
The Egg
Gerbil Elite
Silver subscriber
 
 
Posts: 613
Joined: Sun Apr 06, 2008 4:46 pm

Re: Windows 8.1 won't sleep automatically

Postposted on Thu Dec 26, 2013 9:22 am

I am suffering from this problem on my new PC as well.

I have found out the following pattern. If I set the computer not to turn off the display automatically, only to go to sleep automatically, then it works OK. Nevertheless, if I set the computer to turn off the display automatically (e.g. after a minute) and then to go to sleep automatically (e.g. after two minutes), it won’t go to sleep mode.

Could anyone confirm the same behaviour? Automatic sleep working standalone but not after automatic turning off of the screen…

Thanks for any replies.
josefec
Gerbil In Training
 
Posts: 1
Joined: Thu Dec 26, 2013 9:19 am

Re: Windows 8.1 won't sleep automatically

Postposted on Fri Dec 27, 2013 5:29 am

I was experiencing this problem in my PC also. What I did was fairly easy: Restored the power plan to its default values (I usually had my hard drive to never turn off and this prevents me from suspend the computer with this update) and I disabled Intel Smart Tecnology between 00am and 6pm (when I'm not at home usually) and voila! Finally it suspends again on its own!

To be more detailed, I couldn't suspend my pc by forcing it on the power button, it would come back online a few seconds after.

I think the update screwed the power plan...
Intel i5 3570K - Corsair A50 - Asus P8Z77-V - Corsair 2x4Gb - Asus 280X Direct CU2 - 2x Corsair F90 - Samsung Spinpoint F3 1Tb - Antec One Hundred - Corsair CS750M - ASUS MX239H AH-IPS - Logitech LS21 - Logitech K520 Combo - Win 8.1
Nokia Lumia 920
Jon1984
Gerbil XP
Silver subscriber
 
 
Posts: 317
Joined: Wed Mar 23, 2011 3:07 pm
Location: Portugal

Re: Windows 8.1 won't sleep automatically

Postposted on Fri Jan 10, 2014 11:39 pm

I've been experiencing this problem too. My PC would automatically go to sleep fine on windows 8.0 after the timer I had set in the power profile. But after upgrading to Windows 8.1 I noticed it never went to sleep automatically. I could push the sleep button on my keyboard and it would go to sleep. But it wouldn't go to sleep after the timer value in the power profile. Here is the sequence of events that I executed, which for some inexplicable reason solved the problem:

1. Launched a command prompt as system administrator (ie go to start page, right-click command prompt, choose run as administrator)
2. run command powercfg /requests to ensure all entries say "none" (ie there is nothing requesting to wake computer - if it doesn't say "none" for all categories you'll have to deal with those items first - then come back and do this if you still have a problem)
3. In my power profile I set "display off" for 1 minute. I set "go to sleep" for 2 minutes.
4. I then ran the command powercfg /energy duration 180 (ie I ran it for 3 minutes)
5. I then didn't touch the mouse or keyboard, and left the machine alone. After 3 minutes and 36 seconds (wait 4 minutes to be on the safe side), the system went to sleep.
6. I then rebooted the computer and waited the 4 minutes - it still went to sleep fine.

Note although the "fix" survived a reboot, it did not survive changing the sleep timer in my power profile. When I set it to a new value (1 minute) the problem came back again. I then re-ran the powercfg energy duration command, but this time since my sleep timer was 1 minute, I gave the command a duration of 2 minutes. The problem was fixed again. That seems to be the key - run the powercfg energy command for a duration longer than your sleep timer - but I'm not 100% sure as I didn't test using other timer and duration values. Even though my sleep timer was set at 1 minute, it still didn't go to sleep for 3 to 4 minutes after last keyboard/mouse activity.

Hope this works for you to.
rbrookes
Gerbil In Training
 
Posts: 2
Joined: Fri Jan 10, 2014 11:15 pm

Re: Windows 8.1 won't sleep automatically

Postposted on Tue Jan 21, 2014 3:04 pm

The only thing that really worked for me was leaving the HomeGroup. It was sort of created automatically during setup. I just did a clean install on my PC of Windows 8.1, and I will keep this in mind for the future if I format again. I don't use the HomeGroup for anything. You go to Control Panel -> HomeGroup to leave the group.

The symptoms were that I could manually choose Sleep, and it would work. The computer would ignore the time I selected in Control Panel -> Power Options. I set the sleep timer to 1 minute and used the process of elimination to find this fix.
arapon
Gerbil In Training
 
Posts: 2
Joined: Tue Jan 21, 2014 3:00 pm

Re: Windows 8.1 won't sleep automatically

Postposted on Wed Jan 22, 2014 1:32 pm

After posting my above workaround I found there were times when my PC still wouldn't sleep. I upgraded my Realtek PCIe GBE Family Controller network adapter to driver version 5.820.1028.2013 (dated Oct 28, 2013) and it now seems PC sleeps reliably in accordance with whatever sleep timer I have chosen in the power profile. However on reboot the PC gave me a message that it was installing software updates. I don't know if they were just the updates I did when I installed the new driver or if other automatically downloaded drivers were also installed. I'm also not in a homegroup (never was).
rbrookes
Gerbil In Training
 
Posts: 2
Joined: Fri Jan 10, 2014 11:15 pm

Re: Windows 8.1 won't sleep automatically

Postposted on Wed Jan 22, 2014 5:18 pm

rbrookes wrote:After posting my above workaround I found there were times when my PC still wouldn't sleep. I upgraded my Realtek PCIe GBE Family Controller network adapter to driver version 5.820.1028.2013 (dated Oct 28, 2013) and it now seems PC sleeps reliably in accordance with whatever sleep timer I have chosen in the power profile. However on reboot the PC gave me a message that it was installing software updates. I don't know if they were just the updates I did when I installed the new driver or if other automatically downloaded drivers were also installed. I'm also not in a homegroup (never was).


It doesn't seem like you gave us complete information here to help you. Are you saying that after you restart your computer the driver changed and you are now having the sleep problem again?
arapon
Gerbil In Training
 
Posts: 2
Joined: Tue Jan 21, 2014 3:00 pm

Re: Windows 8.1 won't sleep automatically

Postposted on Sat Feb 01, 2014 11:52 am

Solved (after 4 days of trying - Part 1 of 2)

Configuration: Win 8.1 Pro x64 with media center, Logitech M510D wireless mouse, webcam.

Problem: Computer wouldn't sleep correctly. Monitor wakes before computer can sleep.

I set the 'turn off display' to 1 minute and set 'put computer to sleep' to 10 minutes. Monitor would turn off at 1 minute but monitor would turn back on at 5 minutes after turning off. Sometimes computer would eventually go to sleep but mostly not. Would sleep OK if I unplugged the Ethernet cable from computer (as others reported)

Tried:
1) Ran powercfg -requests (always do this 1st. Nothing showed)
2) Checked for homegroup. No computers have homegroup enabled.
3) Re-installed NIC driver (no luck)
4) Removed batteries from Logitech mouse (solved issue - no more monitor turning back on before sleep)
5) Downloaded Logitech driver for M510d. It installed Logitech HID compliant Unifying mouse. (Didn't work)
6) Rebooted PC (worked)

Food for thought:

I thought mouse going to smart sleep for battery saving mode might be it but specs are less than minute. Sleep mode was initially working when I did W8.1 initial install but likely some program install or update caused issue. USB, keep powered on sleep, wasn't an issue as the monitor would turn back on before sleep mode could kick in.

Part 2 (solved)

Problem: The mouse solution, part 1, worked 8 times and for 14 hours. Now the computer doesn't sleep. Problem occurs 2 times a day - noon and midnight +/- 1 hour. Computer will sleep OK until 12 o'clock if I do a reboot.

I set the 'turn off display' to never and set 'put computer to sleep' to 1 minute. Would sleep OK if I unplugged the Ethernet cable between the router and DSL modem (Appears to be an internet issue now. Must be some program or task that gets run after so many hours or during some time of day). Would also work ok until next day if I rebooted computer.

Tried:
1) Ran powercfg -requests (always do this 1st. Nothing showed)
2) Removed batteries from Logitech mouse (didn't work)
3) Tried the maintenance that was mentioned here (didn't work)
4) Installed the update (didn't work)
5) Disabled IP6 (didn't work)
6) Stopped the following service: Networking Location Awareness (NLA- Suggest reading about it online). This DID enable it to sleep
7) Deleted unused network adapters (solved problem)

NLA is associated with network discovery. This ties back to the network adapter. I found 2 hidden network adapters (using device manager) that weren't being used, both were for IP6 over IP4, and one adapter that wasn't being used. I deleted all of them (suggest you just disable them in case) and now is working.

There was a February update, kb2921066, that fixed the sleep problem when using homegroup. I am not using homegroup, so it didn't help in my case. For homegroup users, this fixes your sleep problem.
Last edited by ken on Wed Feb 26, 2014 11:32 am, edited 6 times in total.
ken
Gerbil In Training
 
Posts: 1
Joined: Sat Feb 01, 2014 11:22 am

Re: Windows 8.1 won't sleep automatically

Postposted on Wed Feb 05, 2014 11:19 pm

I update my computer from windows 8 to windows 8.1 but after 3 days I decide to downgraded to windows 8 because of few problems. Anyway, I hope this link will help you solve your problem http://windows.microsoft.com/en-ph/wind ... -questions.
linnea
Gerbil In Training
 
Posts: 5
Joined: Fri Jan 03, 2014 5:52 am

Re: Windows 8.1 won't sleep automatically

Postposted on Wed Feb 12, 2014 4:06 pm

graymatter wrote:Hi All,

I have four desktop PC with varying hardware configurations, all between two and three years old, all running Windows 8.1 with Media Center. They were upgraded from Windows 7 to Windows 8 when it was released, then to Windows 8.1. I am a mad updater - so all BIOS, driver and Windows updates are checked for and applied on a regular basis. I would have only occasional sleep problems with Windows 7 and 8 - but I have found this to be not uncommon with Windows of all versions. Mostly the sleep functions worked fine.

After upgrading to Windows 8.1, ALL of the PCs would not automatically sleep. Actually, three of them would sleep automatically if I restarted the PC but did not use it. That is, do nothing on the PC after a restart - not even touch the keyboard or mouse. In this case the PC would then automatically sleep after the sleep timeout period - but not exactly useful. A restart on the fourth PC didn't have the same result - it would not automatically sleep.

Putting the PCs to sleep manually worked fine. And I am not experiencing any other problems with the PCs. Windows 8.1 works perfectly otherwise and I like it.

I now seem to have solved the sleep problem by following two of Ryu Connor's instructions in this thread.

1. Manually start maintenance under Action Center - WinKey+X > Control Panel (Small or Large Icon View) > Action Center > Maintenance > Start Maintenace. Let it complete - this may take quite some time.

2. Under Power Options, select Change plan settings for the active power plan, then select Restore default settings for this plan. Now set the sleep timeout to your desired setting and set any other power plan options you require. I am using the High performance plan and only change the display off timeout, the sleep timeout and set the Require password on wake-up to No. I have left all other plan options at their default settings. Also, my sleep timeouts are generally quite short - 3 minutes on two of the PCs, 5 minutes and 10 minutes on the other two.

3. Restart the PC. Sleep now works perfectly on all my PCs.

I did not make any changes with powercfg or make any other relevant changes. I can't say if just one of the steps alone - forced maintenance or power plan reset - would have had the same result. My testing time was limited and, now that the PCs are all working correctly, I no longer have a problem PC on which to test.

I hope this is helpful. And a big THANK YOU to Ryu.


IT WORKS!!!!
I read every bit of information on having Windows 8.1 sleep on its own and tried everything that was listed. The only thing that worked is what Graymatter shows in his thread. Run maintenance, restore the power plan, reboot and now my computer sleeps on its own after the one minute I have it set at.
Tried to fix this for a long time and now it works like it is supposed to. I have gone back and one by one undid all the changes I made befor I read this post and it still sleeps. Forget powercfg, IV6 and messing with the network adapter.

Thank You Graymatter and all those that have worked to solve this problem.
jakem
Gerbil In Training
 
Posts: 1
Joined: Wed Feb 12, 2014 3:47 pm

Re: Windows 8.1 won't sleep automatically

Postposted on Wed Feb 12, 2014 7:43 pm

I do know at least one of the updates in Patch Tuesday just now fixed sleep issues - http://support.microsoft.com/kb/2921066
I can't leave without my buddy Superfly!
Savyg
Gerbil Elite
Silver subscriber
 
 
Posts: 723
Joined: Thu Aug 26, 2004 6:18 am
Location: The ever growing army of the undead.

Re: Windows 8.1 won't sleep automatically

Postposted on Wed Feb 12, 2014 8:15 pm

Yeah, looks like that fixes the HomeGroup issue. I think someone mentioned that earlier in this thread as a source of woe.

Another one to watch out for is setting "Listen to this device" under your S/PDIF in. It has a power management option that should allow the machine to sleep, but it doesn't seem to work for me.

Unchecking "Listen to this device" will allow the PC to fall back asleep.
"Welcome back my friends to the show that never ends. We're so glad you could attend. Come inside! Come inside!"
Ryu Connor
Global Moderator
Gold subscriber
 
 
Posts: 3598
Joined: Thu Dec 27, 2001 7:00 pm
Location: Marietta, GA

Re: Windows 8.1 won't sleep automatically

Postposted on Thu Feb 13, 2014 12:12 pm

I use Win8.1. About a month ago or so, I suddenly could manually put my computer to sleep. Basically it instantly wakes back up. I few weeks ago I reinstalled windows, due to a multitude of issues, but still can put it to sleep. I tried removing myself from any home groups, but the issue remains. I also tried the usual suspects, of disallowing the mouse/keyboard from waking the PC.
clocks
Gerbil
 
Posts: 40
Joined: Fri Jan 21, 2011 9:23 am

Re: Windows 8.1 won't sleep automatically

Postposted on Sat Mar 15, 2014 11:55 am

PROBLEM SOLVED:
After upgrading to Windows 8.1 my computer stopped going to sleep automatically. (Microsoft has good intentions, but ends always doing some kind of sh...)
How did I solve that?
I disabled all sharings (Video, Music, etc) and left Homegroup, then restarted the computer.

To do that, I put the mouse at the right-bottom corner of screen, then clicked:
- Configurations
- Change computer configurations
- Network
- Homegroup

Then I disabled all sharing-switches and turned Homegroup off.
As I don't use homegroup for nothing, it will be no problem to live without it.
Now, after restarting, my computer goes to sleep normally.
Thank you all for the tips.
Microsoft should issue a fix for that!! It is a shame we need to do such things to go around this problem.
Joe.
JoeMJr
Gerbil In Training
 
Posts: 1
Joined: Wed Mar 12, 2014 7:23 am

Previous

Return to Windows

Who is online

Users browsing this forum: No registered users and 4 guests