Connecting a Linux client to a Windows 2k Native domain

Where Penguins and Daemons chill together in the warmth of the Sun.

Moderators: SecretSquirrel, notfred

Postposted on Fri Feb 15, 2002 7:33 am

Anyone have any experience connecting a linux client to a Windows 2k server? The normal samba command line I used for 9x shares isn't working. Actually should I use samba or just use 2Ks NFS emulation capability?

<font size=-1>[ This Message was edited by: ANApex on 2002-02-15 08:05 ]</font>
ANApex
Gerbil XP
 
Posts: 447
Joined: Thu Dec 27, 2001 6:00 pm
Location: PA

Postposted on Fri Feb 15, 2002 8:09 am

All you need is smbmount - which distro are you using?

I'd stick with smb personally.

<font size=-1>[ This Message was edited by: Bruce on 2002-02-15 08:10 ]</font>
Bruce
Gerbil Elite
 
Posts: 500
Joined: Thu Dec 27, 2001 6:00 pm
Location: New Zealand

Postposted on Fri Feb 15, 2002 8:33 am

I'm using RedHat 7.2, I typically use the mount command with the -t smbfs option, I'll try just using smbmount.
ANApex
Gerbil XP
 
Posts: 447
Joined: Thu Dec 27, 2001 6:00 pm
Location: PA

Postposted on Fri Feb 15, 2002 8:52 am

On 2002-02-15 08:33, ANApex wrote:
I'm using RedHat 7.2, I typically use the mount command with the -t smbfs option, I'll try just using smbmount.


you're in for a treat when you read the first 4 lines of the man page on smbmount. :wink:



oh, and I forgot to say: STAY AWAY FROM UNIX SERVICES ON 2K!! they suck major ass. seriously.

<font size=-1>[ This Message was edited by: Despite on 2002-02-15 08:54 ]</font>
Despite
Gerbil XP
 
Posts: 496
Joined: Thu Dec 27, 2001 6:00 pm
Location: Oklahoma

Postposted on Fri Feb 15, 2002 9:40 am

you're in for a treat when you read the first 4 lines of the man page on smbmount. :wink:


Yeah I know smbmount is just mount -t smbfs which is why I typically just use mount -t. You know 6 or 1/2 dozen of the other.
ANApex
Gerbil XP
 
Posts: 447
Joined: Thu Dec 27, 2001 6:00 pm
Location: PA

Postposted on Fri Feb 15, 2002 1:03 pm

Here is the command I use when mounting a drive for backups:

[mcnamara@dogbert /tmp]$ sudo mount -t smbfs -o username=backup,password=backup
//hal/d /tmp/mnt

Works fine for me. Redhat 6.2 w/ some upgrades, kernel 2.4.1 and smbmount version 2.0.6. Having probs with samba 2.2.1a, will updated when I have a moment.

BTW what is you error.
SecretSquirrel
Gerbil Jedi
Gold subscriber
 
 
Posts: 1642
Joined: Tue Jan 01, 2002 6:00 pm
Location: The Colony, TX (Dallas suburb)

Postposted on Fri Feb 15, 2002 1:05 pm

Cut out the sudo and your command is the same format I use Squirrel. I believe my error is an authentication one, I'll get specifics once I get home. Oh btw squirrel you're connecting to a Win 2k server? Is the server in mixed or native mode?

<font size=-1>[ This Message was edited by: ANApex on 2002-02-15 13:09 ]</font>
ANApex
Gerbil XP
 
Posts: 447
Joined: Thu Dec 27, 2001 6:00 pm
Location: PA

Postposted on Sat Feb 16, 2002 11:22 am

The machine I'm connecting to is running Win2k Pro and sharing drives. When I was actually doing this in a corp environment, I found in helped if you specified the domain in the workgroup option to mount. But, that was connecting to an NT 4.0 server.

I figured out my problme with Samba 2.2.1a. For some reason the mount would fail if smbmnt isn't reachable via your PATH env variable. Placing /usr/sbin (in my case) fixed that problem.
SecretSquirrel
Gerbil Jedi
Gold subscriber
 
 
Posts: 1642
Joined: Tue Jan 01, 2002 6:00 pm
Location: The Colony, TX (Dallas suburb)


Return to Linux, Unix, and Assorted Madness

Who is online

Users browsing this forum: No registered users and 4 guests