Noobie question - Ubuntu 7.10

Where Penguins and Daemons chill together in the warmth of the Sun.

Moderators: SecretSquirrel, notfred

Noobie question - Ubuntu 7.10

Postposted on Mon Jan 14, 2008 4:32 am

i recently installed Ubuntu 7.10 onto my work laptop, dual-booting with XP. I'm having an irritating problem in that the Ubuntu splash screen seems to cause the system to crash. If i boot the system normally, when it *should* be displaying the spash screen, the screen blanks and hangs indefinately. If i alter the boot command to -nospash, it boots fine.
First of all, anyone heard of this error before?
Secondly, i'm a linux noob and have no idea how to make GRUB save the -'nospash' change. i have to go in and change it every time i boot at the moment... which is a bit annoying!
new rig: C2D e6400 (THE OC RETURNS! (currently 3.6ghz @ 1.45v)), gigabyte DS3, g. skill 2gb DDR2 800 6400, Hiper type M 670W PSU, 9600GT, 320gb Seagate Baracuda, Antec P180 Case
maxxcool wrote:CRONK!
TRAINWRECK!
jiminyjetson
Gerbil XP
 
Posts: 346
Joined: Wed Aug 09, 2006 5:03 am
Location: Cardiff

Postposted on Mon Jan 14, 2008 4:46 am

The next time you boot into Linux, you'll need to edit the grub.conf file in the /boot directory. You should see a line that has "splash" written in it somewhere. Just comment out that line by placing a "#" as the very first character of the line. It may, however, be part of the kernel command line, if it is, just delete that portion.

As far as it freezing at the splash screen during boot...I don't know.
The best things in life are free.
http://www.gentoo.org
Guy 1: Surely, you will fold with me.
Guy 2: Alright, but don't call me Shirley.
titan
Grand Gerbil Poohbah
 
Posts: 3276
Joined: Mon Feb 18, 2002 7:00 pm
Location: Great Smoky Mountains

Postposted on Mon Jan 14, 2008 4:50 am

That's exactly what i needed to know. cheers :)
new rig: C2D e6400 (THE OC RETURNS! (currently 3.6ghz @ 1.45v)), gigabyte DS3, g. skill 2gb DDR2 800 6400, Hiper type M 670W PSU, 9600GT, 320gb Seagate Baracuda, Antec P180 Case
maxxcool wrote:CRONK!
TRAINWRECK!
jiminyjetson
Gerbil XP
 
Posts: 346
Joined: Wed Aug 09, 2006 5:03 am
Location: Cardiff

Postposted on Mon Jan 14, 2008 12:13 pm

I've posted this before, but there's a proper way to do that modification in Ubuntu/Debian. Since the grub config is partially auto-generated in Ubuntu, if you just manually modify the boot entries, they'll get changed back every time a system upgrade changes your kernels:

* Edit /boot/grub/menu.lst (you'll need to use sudo or root to edit this file)
* Find the following part:
Code: Select all
## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

Remove splash. So the line should just look like this:
Code: Select all
# defoptions=quiet

* Then run update-grub (you'll also need sudo/root for this).

Running update-grub propagates your options change to all managed entries in /boot/grub/menu.lst. If you just edited the entries in /boot/grub/menu.lst directly to remove splash, they'd be re-added every time your kernel was updated by your package manager and then things would break again. Debian/Ubuntu stores the default boot params in those special comments in the menu.lst file.
bitvector
Grand Gerbil Poohbah
 
Posts: 3234
Joined: Wed Jun 22, 2005 4:39 pm
Location: Mountain View, CA


Return to Linux, Unix, and Assorted Madness

Who is online

Users browsing this forum: No registered users and 5 guests