64-bit Ubuntu never seems to work for me

Where Penguins and Daemons chill together in the warmth of the Sun.

Moderators: SecretSquirrel, notfred

64-bit Ubuntu never seems to work for me

Postposted on Fri Apr 11, 2008 10:03 am

Hi

The last version of 64-bit ubuntu I managed to get to boot on my machine was Dapper Drake. All versions since that, when I try to boot, the progress bar shows, I then get some text which seems at least the kernel is okay. But then the signal to the monitor goes off and the monitor goes on standby. On some versions I've had the machine seemingly boot with no vidoe, but most just hang, including the Hardy Heron beta.

I'm not 100% sure what's wrong, but I'm wondering if it's my X800GTO graphics card, but it's a fairly old card so I would have thought it would be okay in linux.

BTW I get no such trouble in 32-bit ubuntu.
Athlon 64 X2 4200+, UT nF4 Ultra-D, 4GB RAM, 128GB m4 SSD, 500GB HD, 9600GT 512MB, Intel 1000PT, Corsair TX650V2, Customizer 105 USB Blk. kubuntu 11.10 x64.
HP G62t, Pentium Dual-Core P6100, 3GB RAM, 320GB HD1, Intel HD IGP, kubuntu 11.10 x64, Win 7 x64.
srg86
Gerbil First Class
 
Posts: 115
Joined: Tue Apr 25, 2006 7:57 am
Location: Waukesha, WI

Re: 64-bit Ubuntu never seems to work for me

Postposted on Fri Apr 11, 2008 10:10 am

If you wait just a few more days Ubuntu 8.04 will be out. Hopefully the next release solves your problems. :D
FDISK /MBR
Dirge
Gerbil Jedi
 
Posts: 1554
Joined: Thu Feb 19, 2004 3:08 am
Location: New Zealand

Re: 64-bit Ubuntu never seems to work for me

Postposted on Fri Apr 11, 2008 10:14 am

Dirge wrote:If you wait just a few more days Ubuntu 8.04 will be out. Hopefully the next release solves your problems. :D


hmm well I'm definatly not holding my breath, the beta so far does what every other version has done, stange that it doesn't seem to like that graphics card.
Athlon 64 X2 4200+, UT nF4 Ultra-D, 4GB RAM, 128GB m4 SSD, 500GB HD, 9600GT 512MB, Intel 1000PT, Corsair TX650V2, Customizer 105 USB Blk. kubuntu 11.10 x64.
HP G62t, Pentium Dual-Core P6100, 3GB RAM, 320GB HD1, Intel HD IGP, kubuntu 11.10 x64, Win 7 x64.
srg86
Gerbil First Class
 
Posts: 115
Joined: Tue Apr 25, 2006 7:57 am
Location: Waukesha, WI

Re: 64-bit Ubuntu never seems to work for me

Postposted on Fri Apr 11, 2008 10:17 am

you could try submitting a bug report? Sorry dude im all out of ideas as im not all that advanced as a Linux user.
FDISK /MBR
Dirge
Gerbil Jedi
 
Posts: 1554
Joined: Thu Feb 19, 2004 3:08 am
Location: New Zealand

Re: 64-bit Ubuntu never seems to work for me

Postposted on Fri Apr 11, 2008 10:26 am

Dirge wrote:you could try submitting a bug report? Sorry dude im all out of ideas as im not all that advanced as a Linux user.


Actually I think a couple of years ago a bug report was sent on this, but I don't think it ever got fixed as I'm definatly not the only one to encounter this problem, very odd. Maybe I should get an old'ish second hand PCI-E nVidia card and try it out.
Athlon 64 X2 4200+, UT nF4 Ultra-D, 4GB RAM, 128GB m4 SSD, 500GB HD, 9600GT 512MB, Intel 1000PT, Corsair TX650V2, Customizer 105 USB Blk. kubuntu 11.10 x64.
HP G62t, Pentium Dual-Core P6100, 3GB RAM, 320GB HD1, Intel HD IGP, kubuntu 11.10 x64, Win 7 x64.
srg86
Gerbil First Class
 
Posts: 115
Joined: Tue Apr 25, 2006 7:57 am
Location: Waukesha, WI

Re: 64-bit Ubuntu never seems to work for me

Postposted on Fri Apr 11, 2008 10:51 am

Tried adding 'nosplash' to the kernel boot parameters?
Amiga 1200, 68020@28MHz, 4MB+2MB RAM, Conner 80MB harddrive
FubbHead
Grand Gerbil Poohbah
 
Posts: 3483
Joined: Mon Apr 08, 2002 9:04 pm
Location: Borås, Sweden

Re: 64-bit Ubuntu never seems to work for me

Postposted on Fri Apr 11, 2008 10:52 am

srg86 wrote:All versions since that, when I try to boot, the progress bar shows, I then get some text which seems at least the kernel is okay. But then the signal to the monitor goes off and the monitor goes on standby.

Have you tried booting with splash disabled to see what's going on (and whether that is the cause of it)? You can do this by hitting 'e' at the GRUB menu to edit your boot parameters, then go down to the line that starts with 'kernel' and hit 'e' again. Then you want to simply erase 'splash' and 'quiet' with backspace. Hit enter to accept the changes and 'b' to boot with the edited kernel parameters (don't worry, these changes are temporary and will revert the next time you boot up).
bitvector
Grand Gerbil Poohbah
 
Posts: 3234
Joined: Wed Jun 22, 2005 4:39 pm
Location: Mountain View, CA

Re: 64-bit Ubuntu never seems to work for me

Postposted on Fri Apr 11, 2008 11:41 am

bitvector wrote:Have you tried booting with splash disabled to see what's going on (and whether that is the cause of it)? You can do this by hitting 'e' at the GRUB menu to edit your boot parameters, then go down to the line that starts with 'kernel' and hit 'e' again. Then you want to simply erase 'splash' and 'quiet' with backspace. Hit enter to accept the changes and 'b' to boot with the edited kernel parameters (don't worry, these changes are temporary and will revert the next time you boot up).


It worked! And X.org worked a treat too! (this was booting the live CD)

The only thing that was curiouse was that the volume controls were all turned down, I definatly hope that doesn't happen every boot on a proper installation, I remember trying Mandriva 10 or something with this sound card and it would turn it down after every boot, but other than that, everything worked perfectly!

I wonder why the boot splash doesn't like my graphics card?
Athlon 64 X2 4200+, UT nF4 Ultra-D, 4GB RAM, 128GB m4 SSD, 500GB HD, 9600GT 512MB, Intel 1000PT, Corsair TX650V2, Customizer 105 USB Blk. kubuntu 11.10 x64.
HP G62t, Pentium Dual-Core P6100, 3GB RAM, 320GB HD1, Intel HD IGP, kubuntu 11.10 x64, Win 7 x64.
srg86
Gerbil First Class
 
Posts: 115
Joined: Tue Apr 25, 2006 7:57 am
Location: Waukesha, WI

Re: 64-bit Ubuntu never seems to work for me

Postposted on Fri Apr 11, 2008 12:16 pm

srg86 wrote:It worked! And X.org worked a treat too! (this was booting the live CD)
Great. If, in the future, you have an installed copy with 'splash' set and would like to make the change permanent (rather than editing it every time), you can do the following:

* Edit /boot/grub/menu.lst (you'll need to use sudo or root to edit this file: e.g. sudo nano /boot/grub/menu.lst)
* Find the following part:
Code: Select all
## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash
Remove splash (so the line just looks like # defoptions=quiet).
* Then run update-grub (you'll also need sudo/root for this: e.g. sudo update-grub).

srg86 wrote:The only thing that was curiouse was that the volume controls were all turned down, I definatly hope that doesn't happen every boot on a proper installation, I remember trying Mandriva 10 or something with this sound card and it would turn it down after every boot, but other than that, everything worked perfectly!
I'm not sure about the LiveCD, but with an install, typically the mixer setting start off turned down all the way the first time, and on each boot then get restored from their previous settings (so hopefully where ever you left them).

srg86 wrote:I wonder why the boot splash doesn't like my graphics card?
Who knows... kinda strange it works in 32-bit but not 64-bit. But I imagine getting bootsplash working perfectly isn't that high of a development priority (relatively speaking), since you can just boot up in text mode if it doesn't work. FWIW, some other people on TR have had that exact same problem (here's one prior thread).
bitvector
Grand Gerbil Poohbah
 
Posts: 3234
Joined: Wed Jun 22, 2005 4:39 pm
Location: Mountain View, CA

Re: 64-bit Ubuntu never seems to work for me

Postposted on Fri Apr 11, 2008 12:40 pm

bitvector wrote:
srg86 wrote:It worked! And X.org worked a treat too! (this was booting the live CD)
Great. If, in the future, you have an installed copy with 'splash' set and would like to make the change permanent (rather than editing it every time), you can do the following:

* Edit /boot/grub/menu.lst (you'll need to use sudo or root to edit this file: e.g. sudo nano /boot/grub/menu.lst)
* Find the following part:
Code: Select all
## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash
Remove splash (so the line just looks like # defoptions=quiet).
* Then run update-grub (you'll also need sudo/root for this: e.g. sudo update-grub).


ahh I see, thanks for the heads up about all of this being managed. I've installed and used grub manually using a grub only boot floppy for my own amature OS kernel, but don't have much expereince at all with using the linux based grub tools. so definalty will try this when the final Hardy Heron comes out.

bitvector wrote:
srg86 wrote:The only thing that was curiouse was that the volume controls were all turned down, I definatly hope that doesn't happen every boot on a proper installation, I remember trying Mandriva 10 or something with this sound card and it would turn it down after every boot, but other than that, everything worked perfectly!
I'm not sure about the LiveCD, but with an install, typically the mixer setting start off turned down all the way the first time, and on each boot then get restored from their previous settings (so hopefully where ever you left them).


Yeah I've read that ALSA does default at first to all controls turned down, so I guess that's what it is, so I'm sure it will be restored, it's always been restored on 32-bit ubuntu with my onboard audio.

bitvector wrote:
srg86 wrote:I wonder why the boot splash doesn't like my graphics card?
Who knows... kinda strange it works in 32-bit but not 64-bit. But I imagine getting bootsplash working perfectly isn't that high of a development priority (relatively speaking), since you can just boot up in text mode if it doesn't work. FWIW, some other people on TR have had that exact same problem (here's one prior thread).


Yeah it's very strange how it works on 32-bit but not on 64-bit. Well it would surprise me that it isn't a relatively high development priotiry, as it doesn't just cause something like screen corruption, but causes a full scale hang, and it's practically the first thing you see when trying to boot the 64-bit lice CD, it doesn't give a very good impression. Yeah I see what you mean, others have had this problem and it's not just on ATI cards either.
Athlon 64 X2 4200+, UT nF4 Ultra-D, 4GB RAM, 128GB m4 SSD, 500GB HD, 9600GT 512MB, Intel 1000PT, Corsair TX650V2, Customizer 105 USB Blk. kubuntu 11.10 x64.
HP G62t, Pentium Dual-Core P6100, 3GB RAM, 320GB HD1, Intel HD IGP, kubuntu 11.10 x64, Win 7 x64.
srg86
Gerbil First Class
 
Posts: 115
Joined: Tue Apr 25, 2006 7:57 am
Location: Waukesha, WI

Re: 64-bit Ubuntu never seems to work for me

Postposted on Fri Apr 11, 2008 12:47 pm

It could be worse.. A X800XT I have works in neither (with splash enabled). :-)
Last edited by FubbHead on Fri Apr 11, 2008 1:06 pm, edited 1 time in total.
Amiga 1200, 68020@28MHz, 4MB+2MB RAM, Conner 80MB harddrive
FubbHead
Grand Gerbil Poohbah
 
Posts: 3483
Joined: Mon Apr 08, 2002 9:04 pm
Location: Borås, Sweden

Re: 64-bit Ubuntu never seems to work for me

Postposted on Fri Apr 11, 2008 12:56 pm

FubbHead wrote:I could be worse.. A X800XT I have works in neither (with splash enabled). :-)


That's very interesting. I wonder if the splash screen uses the VESA bios extensions, maybe lack of support for them in the graphics card's BIOS is causing the problem
Athlon 64 X2 4200+, UT nF4 Ultra-D, 4GB RAM, 128GB m4 SSD, 500GB HD, 9600GT 512MB, Intel 1000PT, Corsair TX650V2, Customizer 105 USB Blk. kubuntu 11.10 x64.
HP G62t, Pentium Dual-Core P6100, 3GB RAM, 320GB HD1, Intel HD IGP, kubuntu 11.10 x64, Win 7 x64.
srg86
Gerbil First Class
 
Posts: 115
Joined: Tue Apr 25, 2006 7:57 am
Location: Waukesha, WI


Return to Linux, Unix, and Assorted Madness

Who is online

Users browsing this forum: No registered users and 2 guests