Changing default sound devices in Ubuntu

Where Penguins and Daemons chill together in the warmth of the Sun.

Moderators: SecretSquirrel, notfred

Changing default sound devices in Ubuntu

Postposted on Tue Nov 11, 2008 4:34 pm

I recently installed 8.10 and decided to install the ALSA 1.0.18 package myself today.

I think I got quite far as I get this in the terminal:
Code: Select all
hdmi@hdmi-desktop:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC883 Analog [ALC883 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC883 Digital [ALC883 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
hdmi@hdmi-desktop:~$



When I start the alsamixer, the system is apparently set to use the [HDA ATI SB] device. I want to use the [HDA ATI HDMI] device, as ALSA is now saying they support sound over HDMI. I went into the sounds preferences and set that to HDMI, but the alsamixer is still showing the HDA device.

Does anyone know where I can change the default sound device? I have scoured the internet and haven't really found anything helpful yet.

Thanks.
. . . this is the digital projection of your mental self. . . .

Darth Lex-idius vs. Obi Lex kanobi
lex-ington
Minister of Gerbil Affairs
 
Posts: 2920
Joined: Fri Apr 25, 2003 9:59 pm
Location: Toronto, ON

Return to Linux, Unix, and Assorted Madness

Who is online

Users browsing this forum: Exabot [Bot] and 1 guest