help with samba install

Where Penguins and Daemons chill together in the warmth of the Sun.

Moderators: SecretSquirrel, notfred

Re: help with samba install

Postposted on Sat Jan 03, 2009 8:12 pm

OK, I can now write to the Samba share from the desktop too. I haven't touched the config since the last attempt when it didn't work. What the hell?
flip-mode
Gerbil Khan
Silver subscriber
 
 
Posts: 9086
Joined: Thu May 08, 2003 12:42 pm
Location: Cincinnati, OH

Re: help with samba install

Postposted on Sat Jan 03, 2009 8:16 pm

Hah, I had the opposite problem with Vista at first: 64-bit clients worked just peachy, but 32-bit wouldn't at all. I don't remember what caused that to go away now.

Congrats on getting the ruttin' thing cooperating, though.
Think for yourself, schmuck!
i5-2500K@4.3|Asus P8P67-LE|8GB DDR3-1600|Powercolor R7850 2G|1.5TB 7200.11|1988 Model M|Saitek X-45 & P880|Logitech MX 518|Dell 2209WA|Sennheiser PC151|Asus Xonar DX
bthylafh
Grand Gerbil Poohbah
 
Posts: 3194
Joined: Mon Dec 29, 2003 11:55 pm
Location: Southwest Missouri, USA

Re: help with samba install

Postposted on Sat Jan 03, 2009 8:28 pm

Yes, though the fact that I don't know what finally caused it to work is a little vexing.

Here's the current /usr/local/etc/smb.conf
Code: Select all
[global]
workgroup = WORKGROUP
netbios name = dimension
security = share

[share1]
path = /usr/networkshare/share1
writeable = yes
guest ok = yets
guest account = ftp
guest only = yes


I notice an error in there: guest ok = yets

samba is prolly wondering what the hell is yets.

I'll fix that and hopefully it will keep working!

Here is the output of testparm (after fixing the spelling error)

Code: Select all
$ testparm
Load smb config files from /usr/local/etc/smb.conf
Processing section "[share1]"
Global parameter guest account found in service section!
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
        security = SHARE

[share1]
        path = /usr/networkshare/share1
        read only = No
        guest only = Yes
        guest ok = Yes
flip-mode
Gerbil Khan
Silver subscriber
 
 
Posts: 9086
Joined: Thu May 08, 2003 12:42 pm
Location: Cincinnati, OH

Re: help with samba install

Postposted on Mon Jan 05, 2009 8:38 pm

just an update: samba sharing at home is going great! FWIW I think using "guest account = ftp" works well along with all the guest permissions I tossed in the conf file. Yay, fun!
flip-mode
Gerbil Khan
Silver subscriber
 
 
Posts: 9086
Joined: Thu May 08, 2003 12:42 pm
Location: Cincinnati, OH

Previous

Return to Linux, Unix, and Assorted Madness

Who is online

Users browsing this forum: No registered users and 2 guests