Gnome Terminal lumps monospace fonts together

Where Penguins and Daemons chill together in the warmth of the Sun.

Moderators: SecretSquirrel, notfred

Gnome Terminal lumps monospace fonts together

Postposted on Sun Jul 03, 2011 9:36 am

Running Arch Linux under VMWare: This is what I mean. I've tried a lot of monospace fonts, but it's always like this. Notice how the @ overlaps the t, and something's wrong with my username. I haven't tried other terminals, what's going on? Is this some kind of dpi missetting?
Image
Mothership: Thuban 1055T@3.7GHz, 12GB DDR3, M5A99X EVO, GTX470+Icy Vision Rev.2@840/3800, Vertex 2E 60GB
Supply ship: Sargas@2.8GHz, 12GB DDR3, M4A88TD-V EVO/USB3
Corsair: Macbook Air Ivy Bridge
Crayon Shin Chan
Minister of Gerbil Affairs
 
Posts: 2246
Joined: Fri Sep 06, 2002 11:14 am
Location: Malaysia

Re: Gnome Terminal lumps monospace fonts together

Postposted on Sun Jul 03, 2011 10:13 am

Something is seriously wrong here.

There is a good chance that vmware doens't report correct dpi, throwing things off. Check this out: https://wiki.archlinux.org/index.php/Fo ... rted_fonts

Additionally, I *strongly* recommend installing the freetype2-infinality or freetype2-ubuntu (with the associated cairo-ubuntu etc) packages and setting font hinting to 'slight'. The ubuntu patches need no configuration - install, set hintslight and you are ready. The infinality patches can provide slightly better quality but need more configuration (otherwise fonts will not look good). Both options result in *significantly* better quality than the default font renderer.

(Just my 2cc - typing this from Arch right now!)
BlackStar
Gerbil
 
Posts: 92
Joined: Fri May 11, 2007 3:38 am

Re: Gnome Terminal lumps monospace fonts together

Postposted on Sun Jul 03, 2011 11:25 am

Even without the correct DPI, I wouldn't expect it to be *that* messed up.

Any chance you can switch back to GNOME 2.x? IMO 3.x isn't really ready for prime time anyhow.
(this space intentionally left blank)
just brew it!
Administrator
Gold subscriber
 
 
Posts: 37854
Joined: Tue Aug 20, 2002 10:51 pm
Location: Somewhere, having a beer

Re: Gnome Terminal lumps monospace fonts together

Postposted on Mon Jul 04, 2011 4:06 pm

just brew it! wrote:Even without the correct DPI, I wouldn't expect it to be *that* messed up.

Any chance you can switch back to GNOME 2.x? IMO 3.x isn't really ready for prime time anyhow.


True it could be the compatibility between VMWare and Gnome 3.0. Composition of the desktop within Gnome 2.x happens within compiz. Gnome 3 (which I use) doesn't use compiz and that could represent the problem with the fonts you are experiencing.
Core i7 920 @stock - 6GB OCZ Mem - Adaptec 5805 - 2 x Intel X25-M in RAID1 - 5 x Western Digital RE4 WD1003FBYX 1TB in RAID 6 - Nvidia GTX 460
kc77
Gerbil Team Leader
 
Posts: 242
Joined: Sat Jul 02, 2005 2:25 am

Re: Gnome Terminal lumps monospace fonts together

Postposted on Tue Jul 05, 2011 6:26 am

DPI didn't really help. I'll try installing rxvt-unicode, see if that works.
Mothership: Thuban 1055T@3.7GHz, 12GB DDR3, M5A99X EVO, GTX470+Icy Vision Rev.2@840/3800, Vertex 2E 60GB
Supply ship: Sargas@2.8GHz, 12GB DDR3, M4A88TD-V EVO/USB3
Corsair: Macbook Air Ivy Bridge
Crayon Shin Chan
Minister of Gerbil Affairs
 
Posts: 2246
Joined: Fri Sep 06, 2002 11:14 am
Location: Malaysia

Re: Gnome Terminal lumps monospace fonts together

Postposted on Tue Jul 05, 2011 6:31 am

kc77 wrote:True it could be the compatibility between VMWare and Gnome 3.0. Composition of the desktop within Gnome 2.x happens within compiz. Gnome 3 (which I use) doesn't use compiz and that could represent the problem with the fonts you are experiencing.

AFAIK compiz is only used if your graphics card has the requisite OpenGL capabilities; in a VM, this would actually be your *virtual* graphics card. I'm not sure how VMware handles this (I use VirtualBox), but as a guess you need to have the guest additions installed for compiz to be enabled.
(this space intentionally left blank)
just brew it!
Administrator
Gold subscriber
 
 
Posts: 37854
Joined: Tue Aug 20, 2002 10:51 pm
Location: Somewhere, having a beer

Re: Gnome Terminal lumps monospace fonts together

Postposted on Sat Jul 09, 2011 9:51 am

I found the cause for this: you have specified a proportional font in your appearance or terminal settings. You must specify a monospace font instead.

Open gnome-appearance-settings, navigate to fonts and ensure your Monospace font is set to something like "Monospace" or "Courier New". Open gnome-terminal, open its preferences and search for the font setting: ensure it is set to "use system default" or a monospace font.

That's it!
BlackStar
Gerbil
 
Posts: 92
Joined: Fri May 11, 2007 3:38 am


Return to Linux, Unix, and Assorted Madness

Who is online

Users browsing this forum: No registered users and 1 guest