Zacate fileserver performance

Where Penguins and Daemons chill together in the warmth of the Sun.

Moderators: SecretSquirrel, notfred

Zacate fileserver performance

Postposted on Wed Aug 22, 2012 12:23 pm

Hey guys. I put together a Zacate E-350 fileserver running Debian 6 last March or so. It was great. I had encrypted filesystems and a gigabyte network connection pumping out 40 MB/s. Not screaming fast, but good enough for me. Then I totally screwed it up about a month ago by messing with my sources.list because I was tired of the crappy video / sound drivers :(

I reinstalled Debian, and sucessfully upgraded it to Wheezy, but now the performance is shot. I get 14 MB/s file transfers over the network with 100% cpu load (split 50/50 between samba and khelper(disk encryption?)). When I copy from an unencrypted volume, I only get 20 MB/s. At least if I remember right. I did the test a few days ago, and I've been thinking about it since...

I've already verified that the network connection is connecting at gigabit speed. It looks like it might be running both processes on the same processor? Even then, samba by itself shouldn't be such a hog, should it?

Anyone have any suggestions? Maybe a more Zacate friendly distro? I considered CentOS, but not the more desktop oriented ones because the security options drive me crazy on those.

Z
ZGradt
Gerbil In Training
 
Posts: 6
Joined: Sat Aug 15, 2009 8:08 am

Return to Linux, Unix, and Assorted Madness

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests