HTTP GET returned error code 0

Come join the... uh... er... fold.

Moderators: just brew it!, farmpuma

HTTP GET returned error code 0

Postposted on Sun Aug 31, 2008 2:51 pm

Hey guys,

I mentioned this in another thread but still haven't found a solution. My main PC absolutely refuses to download a core, and I can't seem to figure out why. I've just removed XP and installed Fedora Core 9, and STILL get the same error, with the firewall turned off.

[14:46:39] - Ask before connecting: Yes
[14:46:39] - Proxy: localhost:80
[14:46:39] - User name: 60l23 (Team 2630)
[14:46:39] - User ID: 5ED5C0674E329F42
[14:46:39] - Machine ID: 1
[14:46:39]
[14:46:39] Loaded queue successfully.
[14:46:39]
[14:46:39] + Processing work unit
[14:46:39] Core required: FahCore_78.exe
[14:46:39] Core not found.
[14:46:39] - Core is not present or corrupted.
[14:46:39] - Attempting to download new core...
[14:46:39] + Downloading new core: FahCore_78.exe
[14:46:40] > Press "c" to connect to the server to download
c[14:46:41] - Establishing connection
[14:46:44] - Error: HTTP GET returned error code 0
[14:46:44] + Error: Could not download core
[14:46:44] + Core download error (#2), waiting before retry...

[14:46:50] + Downloading new core: FahCore_78.exe
[14:46:50] - Error: HTTP GET returned error code 0
[14:46:50] + Error: Could not download core
[14:46:50] + Core download error (#3), waiting before retry...

And so on... I just experimented with the "ask before connecting" option, leaving it off doesn't change anything. Same goes with the proxy settings.

I can't think of any router firewalls I may have in place that would allow a browser to access the cores but not the client... I have no trouble downloading them manually, but I'm not going to deal with downloading a new core every time one is released.

As promised in the other thread, if anybody can help, I'll gladly fold under their name for a while on this box. It's an Athlon X2 @ 2.8, not great, but also has an 8800GTS that I'll gladly fold under if I get windows back on it.
41.60l23
Gerbil XP
 
Posts: 406
Joined: Wed Nov 29, 2006 10:34 pm
Location: Inside a wheel, powering your QuadFX. =(

Re: HTTP GET returned error code 0

Postposted on Sun Aug 31, 2008 5:28 pm

Sorry, I've never had this error=(
Image
If you're not folding with your idle computer time you're not part of the solution.
Gerbil Jedidiah
Grand Gerbil Poohbah
Gold subscriber
 
 
Posts: 3292
Joined: Thu Jul 27, 2006 5:57 pm
Location: The Smoky Back Room

Re: HTTP GET returned error code 0

Postposted on Sun Aug 31, 2008 5:34 pm

I recall your other post about this problem, but strangely, search does not find it. I also recall the reply was to try setting the option "Use Internet Explorer Settings" to no. Am I safe in assuming this change made no difference when you were running windows? I would expect the nix client doesn't have this option, but I don't know for certain.

You might try giving it an 8080 proxy. I usually use a space for the name and say no to username/password.

Are you using the 6.20 client or the 5.04 client?
Image Image
.* * M-51 * *. .The Whirlpool Galaxy.
farmpuma
Minister of Gerbil Affairs
Silver subscriber
 
 
Posts: 2324
Joined: Mon Mar 22, 2004 12:33 am
Location: Soybean field, IN, USA, Earth .. just a bit south of John .. err .... Fart Wayne, Indiana

Re: HTTP GET returned error code 0

Postposted on Sun Aug 31, 2008 5:46 pm

Actually, the solution that worked before was to set "Use Internet Explorer Settings" to yes. However, in the new clients, this option was not present in the configuration, and setting it that way in the config file as done in older clients didn't make a difference. Obviously, doesn't do much in Linux.

Changing the proxy settings unfortunately didn't do any good.. I'm using the 6.02 SMP client under Fedora 9 64-bit.
41.60l23
Gerbil XP
 
Posts: 406
Joined: Wed Nov 29, 2006 10:34 pm
Location: Inside a wheel, powering your QuadFX. =(


Return to TR Distributed Computing Effort

Who is online

Users browsing this forum: No registered users and 2 guests