Can't disable HDMI audio on DVI output

From the pixels, bits, and shaders to the graphic cards that power them. Discuss the latest from AMD and NVIDIA here.

Moderators: morphine, SecretSquirrel

Can't disable HDMI audio on DVI output

Postposted on Wed Nov 11, 2009 11:12 pm

Well, I've tried several solutions now, and I simply CANNOT get my Geforce 260 card to display properly on my Westinghouse L2410NM LCD monitor (native resolution 1920x1200).

I'm connecting the two with a DVI - HDMI cable going from the DVI output on my Geforce to the HDMI input on my monitor. However, ALL Nvidia driver versions for Windows 7 64-bit detect my monitor as an HDTV and will ONLY allow a setting of "HDMI" as the connector type in the Nvidia Control Panel.

This by itself would be okay. However, the Nvidia drivers absolutely will not stop trying to send an audio signal over this video-only connection. This leads to a very fuzzy image and washed-out colors. It looks so bad that it's unusable. Even if I manually set the connection to "HDMI - HDTV (Audio disabled)", this only fixes it for the current Windows user session. The Nvidia Driver will revert to trying to send the audio signal any time the driver is reloaded into memory. This means that it reverts to the unusable fuzziness and color quality every time the computer is restarted, every time it is put to sleep, and every time I switch user accounts.

This is what aggravates me: why do the Nvidia drivers not recognize that this card doesn't even HAVE a native HDMI output capable of sending an audio signal and why would the "no audio" setting in the control panel no be applied? Why do the Nvidia drivers not recognize that this card has NO audio device to send audio over an HDMI cable even if it id have an HDMI output?

I've tried driver versions 181.71 all the way to the latest 195.39 beta drivers, and they all do the same damned thing.

Basically, I just can't use this card with a HD connection at all. It's BROKEN. And I just got it yesterday to replace an 8800GTX that failed on me and that did NOT have this problem with this same exact system on this same exact monitor.

Any ideas?

TIA
Prospero424
Gerbil
Gold subscriber
 
 
Posts: 53
Joined: Fri May 30, 2003 4:03 pm
Location: Texas

Re: Can't disable HDMI audio on DVI output

Postposted on Thu Nov 12, 2009 1:48 am

Sounds like an overscan problem, quite common with the L2410NM it seems. Try making a custom resolution of 1920x1200 @ 60Hz with CVT reduced blanking timing to see if that fixes it.
Q9400@3.2GHz | GA-P35-DS3L | 8GB DDR2-800 | MSI GTX 560 Ti | Lian Li PC-7B | Corsair 450VX | Dell 2005FPW
crazybus
Minister of Gerbil Affairs
Gold subscriber
 
 
Posts: 2258
Joined: Wed Feb 26, 2003 8:25 pm

Re: Can't disable HDMI audio on DVI output

Postposted on Thu Nov 12, 2009 2:46 am

Thanks! I'll try that tomorrow evening and let you know if it works. Just to make sure: you're talking about doing this through the Nvidia Control Panel, right?
Prospero424
Gerbil
Gold subscriber
 
 
Posts: 53
Joined: Fri May 30, 2003 4:03 pm
Location: Texas

Re: Can't disable HDMI audio on DVI output

Postposted on Thu Nov 12, 2009 3:47 am

not sure about the display problem, but if u must have no audio you can always get a DVi to Hdmi adapter if you plan to order anything soon, they are usually like a few dollars or free with some graphics cards.
potatochobit
Gerbil Elite
 
Posts: 919
Joined: Mon Dec 01, 2008 3:56 pm

Re: Can't disable HDMI audio on DVI output

Postposted on Thu Nov 12, 2009 7:50 pm

Well, adding the custom resolution didn't work. It just does the exact same thing; I have to re-disable the audio stream every time the driver is loaded into memory.

Basically, it looks like all desktop antialiasing (ClearType, etc.) is being disabled whenever that audio stream is present as well as causing slightly washed-out colors. If only there was some way to force the drivers to treat it as a DVI connector instead of HDMI...
Prospero424
Gerbil
Gold subscriber
 
 
Posts: 53
Joined: Fri May 30, 2003 4:03 pm
Location: Texas

Re: Can't disable HDMI audio on DVI output

Postposted on Thu Nov 12, 2009 8:08 pm

Prospero424 wrote:Why do the Nvidia drivers not recognize that this card has NO audio device to send audio over an HDMI cable even if it id have an HDMI output?


Actually, it's designed to piggyback off your sound device (via internal cable) and send audio through the DVI port and out through a DVI->HDMI connection. It's wrongly assuming that's what you want to do.
Intel 2500K & Scythe Mugen2 | ASRock H67M-GE | 8GB DDR3 | Boot drive: OCZ Vertex 3
TV tuner: Aver HDDuet | Xonar DG | Fractal Design R4 | Rosewill Capstone 450M
insulin_junkie72
Gerbil XP
 
Posts: 498
Joined: Sun Nov 26, 2006 3:19 pm
Location: WI, USA

Re: Can't disable HDMI audio on DVI output

Postposted on Thu Nov 12, 2009 8:25 pm

potatochobit wrote:not sure about the display problem, but if u must have no audio you can always get a DVi to Hdmi adapter if you plan to order anything soon, they are usually like a few dollars or free with some graphics cards.

^ This. The adapters tend to strip the audio signal completely, so that you only get the video signal coming to the monitor. I'm also assuming that the monitor doesn't work correctly on HDMI? Have you tried it with a PS3 etc?
Canon 6D||[24-105/4L IS USM|100/2.8L Macro IS USM|70-300/4-5.6 IS USM|40/2.8 STM|50/1.4 USM|85/1.8 USM|Samyang/Bower 14/2.8 Full-Manual Rectilinear Wide-angle|
Canon EOS-M|11-22/4-5.6 IS STM|22/2 STM|EF-M 18-55/3.5-5.6 IS STM|
For sale!|24/2.8 IS USM
|
Airmantharp
Maximum Gerbil
 
Posts: 4697
Joined: Fri Oct 15, 2004 9:41 pm

Re: Can't disable HDMI audio on DVI output

Postposted on Thu Nov 12, 2009 8:36 pm

Airmantharp wrote:
potatochobit wrote:not sure about the display problem, but if u must have no audio you can always get a DVi to Hdmi adapter if you plan to order anything soon, they are usually like a few dollars or free with some graphics cards.

^ This. The adapters tend to strip the audio signal completely, so that you only get the video signal coming to the monitor. I'm also assuming that the monitor doesn't work correctly on HDMI? Have you tried it with a PS3 etc?


That's definitely worth a shot. I'll swing by Fry's and pick up a DVI-HDMI dongle (any particular spec or brand I should look for?) and give that a shot.

I've got a cable box with an HDMI output (both audio and video). That's a great idea. I'll hook the monitor up to that and let ya'll know if it works. Only thing I'm worried about is that it will be a LOT harder to tell if the fuzziness and washed-out colors are present with a moving picture and no way to compare it to what it sh9ould look like.
Prospero424
Gerbil
Gold subscriber
 
 
Posts: 53
Joined: Fri May 30, 2003 4:03 pm
Location: Texas

Re: Can't disable HDMI audio on DVI output

Postposted on Thu Nov 12, 2009 8:50 pm

I'd say get the cheap one, given the goal. And try comparing the output to a regular HDTV; though I'm not sure how far off it would be, at least you could see if the monitor is doing the right things with the audio stream.
Canon 6D||[24-105/4L IS USM|100/2.8L Macro IS USM|70-300/4-5.6 IS USM|40/2.8 STM|50/1.4 USM|85/1.8 USM|Samyang/Bower 14/2.8 Full-Manual Rectilinear Wide-angle|
Canon EOS-M|11-22/4-5.6 IS STM|22/2 STM|EF-M 18-55/3.5-5.6 IS STM|
For sale!|24/2.8 IS USM
|
Airmantharp
Maximum Gerbil
 
Posts: 4697
Joined: Fri Oct 15, 2004 9:41 pm

Re: Can't disable HDMI audio on DVI output

Postposted on Thu Nov 26, 2009 6:00 pm

Nope, it does the same thing with a dongle and an HDMI cable.

I guess Nvidia's drivers are just broken (at least with my hardware/software config) and I'll just have to wait for a fix from them. Because I'm out of ideas.

Dammit...
Prospero424
Gerbil
Gold subscriber
 
 
Posts: 53
Joined: Fri May 30, 2003 4:03 pm
Location: Texas

Re: Can't disable HDMI audio on DVI output

Postposted on Thu Nov 26, 2009 7:34 pm

It looks like you'll either have to use VGA or override the monitor's EDID. That thread isn't specific to your L2410NM, but from this thread, 5C,85,80,51,00,00,FF,FF,04,00,00,00,7E,01,00 is the hex value you should use. You can double check for your specific monitor using Monitor Asset Manager to pull the raw EDID data, specifically bytes 07-09, which should match 5C,85,80,51. This "fix" will also most likely disable HDCP support if that matters to you.
Q9400@3.2GHz | GA-P35-DS3L | 8GB DDR2-800 | MSI GTX 560 Ti | Lian Li PC-7B | Corsair 450VX | Dell 2005FPW
crazybus
Minister of Gerbil Affairs
Gold subscriber
 
 
Posts: 2258
Joined: Wed Feb 26, 2003 8:25 pm

Re: Can't disable HDMI audio on DVI output

Postposted on Thu Nov 26, 2009 11:03 pm

I appreciate the idea, but I already tried the .inf-editing method. The problem is that none of the drivers from this year for Win7 x64 or Vista x64 any longer have a "[nv_SoftwareDeviceSettings]" section or a "OverrideEdidFlags" entry in the "nv_disp.inf" driver information file.

I'll give the registry editing method another try, tho, 'cause I couldn't get it right the first time I tried it.
Prospero424
Gerbil
Gold subscriber
 
 
Posts: 53
Joined: Fri May 30, 2003 4:03 pm
Location: Texas

Re: Can't disable HDMI audio on DVI output

Postposted on Thu Nov 26, 2009 11:13 pm

Prospero424 wrote:I appreciate the idea, but I already tried the .inf-editing method. The problem is that none of the drivers from this year for Win7 x64 or Vista x64 any longer have a "[nv_SoftwareDeviceSettings]" section or a "OverrideEdidFlags" entry in the "nv_disp.inf" driver information file.

I'll give the registry editing method another try, tho, 'cause I couldn't get it right the first time I tried it.

The driver inf modding method only works in XP afaik. The registry method *should* work I think.
Q9400@3.2GHz | GA-P35-DS3L | 8GB DDR2-800 | MSI GTX 560 Ti | Lian Li PC-7B | Corsair 450VX | Dell 2005FPW
crazybus
Minister of Gerbil Affairs
Gold subscriber
 
 
Posts: 2258
Joined: Wed Feb 26, 2003 8:25 pm

Re: Can't disable HDMI audio on DVI output

Postposted on Thu Nov 26, 2009 11:33 pm

Firstly, I used Monitor Asset Manager to simply create a monitor.inf file using the data it extracted from my Westinghouse and then used the Windows Device Manager to install it. Instead of "PnP Monitor" showing up under the Monitor section, it now reads "Westinghouse L2410NM (EDID Override)", which is nice and all, but the fuzziness still comes back unless I manually toggle the "HDMI - HDTV (Audio Disabled)" setting in the Nvidia Control Panel every time I reboot, change profiles, or resume from sleep. Damn, I was hoping that would work :(

Then, I got half-way through the registry editing method, but I simply have no confidence in what I have attempted to deduce the string should be.

To clarify, this is the example reg entry given for those other Westinghouse models in that HardOCP thread:

REGEDIT4

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video\{57D0CCD3-B24F-4502-BC7F-9883FDF4E92E}\0000]
"OverrideEdidFlags0"=hex:5C,85,07,42,00,00,FF,FF,04,00,00,00,00,80,00,FF,FF,FF,FF,FF,FF,00,5C,85,FA,14,00,00,00,00,10,11,01,03,80,52,2E,78,2A,E6,9D,A3,54,4A,99,26,0F,47,4A,A1,08,00,81,C0,81,80,81,00,8B,C0,01,01,01,01,01,01,01,01,02,3A,80,18,71,38,2D,40,58,2C,45,00,C4,8E,21,00,00,1E,00,00,00,FD,00,3A,48,1E,44,0F,00,0A,20,20,20,20,20,20,00,00,00,FC,00,57,65,73,74,69,6E,67,68,6F,75,73,65,20,00,00,00,FC,00,4C,56,4D,2D,33,37,77,33,73,65,0A,20,20,00,01
"OverrideEdidFlags1"=hex:5C,85,03,37,00,00,FF,FF,04,00,00,00,00,80,00,FF,FF,FF,FF,FF,FF,00,5C,85,FA,14,00,00,00,00,10,11,01,03,80,52,2E,78,2A,E6,9D,A3,54,4A,99,26,0F,47,4A,A1,08,00,81,C0,81,80,81,00,8B,C0,01,01,01,01,01,01,01,01,02,3A,80,18,71,38,2D,40,58,2C,45,00,C4,8E,21,00,00,1E,00,00,00,FD,00,3A,48,1E,44,0F,00,0A,20,20,20,20,20,20,00,00,00,FC,00,57,65,73,74,69,6E,67,68,6F,75,73,65,20,00,00,00,FC,00,4C,56,4D,2D,33,37,77,33,73,65,0A,20,20,00,01
"OverrideEdidFlags2"=hex:5C,85,FA,14,00,00,FF,FF,04,00,00,00,00,80,00,FF,FF,FF,FF,FF,FF,00,5C,85,FA,14,00,00,00,00,10,11,01,03,80,52,2E,78,2A,E6,9D,A3,54,4A,99,26,0F,47,4A,A1,08,00,81,C0,81,80,81,00,8B,C0,01,01,01,01,01,01,01,01,02,3A,80,18,71,38,2D,40,58,2C,45,00,C4,8E,21,00,00,1E,00,00,00,FD,00,3A,48,1E,44,0F,00,0A,20,20,20,20,20,20,00,00,00,FC,00,57,65,73,74,69,6E,67,68,6F,75,73,65,20,00,00,00,FC,00,4C,56,4D,2D,33,37,77,33,73,65,0A,20,20,00,01


And this is what I have so far for my own:

REGEDIT4

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video\{E13F5F26-E8D7-4AD0-9403-49B80640E516}\0000]
"OverrideEdidFlags0"=hex:5C,85,80,51,00,00,FF,FF,04,00,00,00,7E,01,00


Seems like I'm missing a LOT of data, there. Any idea how to figure it out?
Prospero424
Gerbil
Gold subscriber
 
 
Posts: 53
Joined: Fri May 30, 2003 4:03 pm
Location: Texas

Re: Can't disable HDMI audio on DVI output

Postposted on Fri Nov 27, 2009 12:57 am

Well EDID contains a fair amount of information, a lot of it being unimportant. That hexadecimal sequence is the one I've seen around that works as a generic value. There's another thread at hardocp specific to the L2410NM where that method has worked.

Alternatively, you could either try:

1. Make a custom monitor inf using PowerStrip (which won't have EDID information). Not completely sure that will fix it though.

or

2. Modify the monitor's EDID in the registry. It's stored in HKLM\SYSTEM\CurrentControlSet\Enum\Display\*monitorname*\*GUID*\Device Parameters\EDID

The 127th byte (second to last) determines whether any EDID extensions are loaded [ref]. Try setting it to the hex value 00. Restart the computer see if that works.

It's probably a good idea to update the EDID checksum as well, which is the 128th byte. Using Phoenix EDID Designer, you can load the current EDID from the registry, switch the program out of read-only mode, change the "Number of Extensions" to 0, and the program should show you the updated EDID checksum.
Image

edit: See my later post for an easier alternative method to directly editing the registry.
Last edited by crazybus on Tue Mar 30, 2010 2:30 pm, edited 1 time in total.
Q9400@3.2GHz | GA-P35-DS3L | 8GB DDR2-800 | MSI GTX 560 Ti | Lian Li PC-7B | Corsair 450VX | Dell 2005FPW
crazybus
Minister of Gerbil Affairs
Gold subscriber
 
 
Posts: 2258
Joined: Wed Feb 26, 2003 8:25 pm

Re: Can't disable HDMI audio on DVI output

Postposted on Fri Nov 27, 2009 6:38 pm

Okay, let me make sure I've got this right before I commit any changes.

First, I change the "01" before the "30" at the bottom of this "Edit Binary Value" window to read "00"

Image
By prospero424

Then I change the "30" to read "31" because Phoenix EDID designer reports the updated checksum to be 31

Image
By prospero424

Then I simply save the changes in the registry editor and restart Windows, and that's it?
Prospero424
Gerbil
Gold subscriber
 
 
Posts: 53
Joined: Fri May 30, 2003 4:03 pm
Location: Texas

Re: Can't disable HDMI audio on DVI output

Postposted on Fri Nov 27, 2009 7:46 pm

Well, I went ahead and tried it in my impatience, and it worked like a charm! No more fuzziness or washed-out colors, no more manually toggling the "audio disabled" switch in the Nvidia Control Panel. Excellent! Edit: the Nvidia Control Panel now properly reports it as a DVI connection rather than HDMI, as well.

I greatly appreciate your input, crazybus. I was starting to think I'd never fix it. And I'll post this fix on the other tech forums I posted this problem on, including the Nvidia driver forums.
Last edited by Prospero424 on Sat Nov 28, 2009 12:23 am, edited 1 time in total.
Prospero424
Gerbil
Gold subscriber
 
 
Posts: 53
Joined: Fri May 30, 2003 4:03 pm
Location: Texas

Re: Can't disable HDMI audio on DVI output

Postposted on Fri Nov 27, 2009 8:28 pm

Glad to hear it worked. My only worry is that this probably also disables HDCP.
Q9400@3.2GHz | GA-P35-DS3L | 8GB DDR2-800 | MSI GTX 560 Ti | Lian Li PC-7B | Corsair 450VX | Dell 2005FPW
crazybus
Minister of Gerbil Affairs
Gold subscriber
 
 
Posts: 2258
Joined: Wed Feb 26, 2003 8:25 pm

Re: Can't disable HDMI audio on DVI output

Postposted on Fri Nov 27, 2009 9:25 pm

Yeah, that is a concern for others who may wind up using this workaround. Luckily, I have no HDCP-enabled media or optical drives, so it's pretty much a moot point, personally. Also, the Nvidia Control Panel has an "HDCP Status" page and it still reports that my system is compliant, but I have no reliable way to test this.

Thanks again!
Prospero424
Gerbil
Gold subscriber
 
 
Posts: 53
Joined: Fri May 30, 2003 4:03 pm
Location: Texas

Re: Can't disable HDMI audio on DVI output

Postposted on Tue Dec 22, 2009 1:30 am

Update:

I just reloaded my machine and had to apply this "fix" again, and I realized that I screwed up with these instructions. Editing the registry WILL NOT WORK unless you first (as I mentioned above all too briefly) use Monitor Asset Manager to create a custom .inf for the Westinghouse, then use Windows Device Manager to install the .inf manually (updating the driver files for the default monitor), and THEN modify the registry. If you just try to modify the default display registry key, it will keep reverting to the default values and the "fix" will not "stick".

Basically, you don't get the "EDID_OVERRIDE" registry key shown in the screenshot above unless you install that custom monitor driver.

Sorry for any confusion or frustration this oversight may have caused anyone who may have referred to this thread to fix the problem for themselves.
Prospero424
Gerbil
Gold subscriber
 
 
Posts: 53
Joined: Fri May 30, 2003 4:03 pm
Location: Texas

Re: Can't disable HDMI audio on DVI output

Postposted on Sat Mar 20, 2010 6:01 pm

This thread fixed the sound to my TV, thanks!

For anyone who is still having this kind of issue, I wrote up a handy guide on it, which you can find here http://currysauce.org/2010/03/20/how-to-disable-sound-output-over-hdmi-for-nvidia-graphics-cards/

Hope someone finds it useful. Fixing this issue took me ages because the information is so scattered.

:D
cupboard
Gerbil In Training
 
Posts: 1
Joined: Sat Mar 20, 2010 5:56 pm

Re: Can't disable HDMI audio on DVI output

Postposted on Sun Mar 21, 2010 3:06 pm

Thanks for the write-up. I agree that information on how to work around this problem is ridiculously scattered. You could save a few steps and avoid entering the registry by directly modifying the .inf file created by Monitor Asset Manager.

Create the new .inf file:
Image

Get the new EDID checksum using Pheonix EDID Designer:
Image

Locate the HKR,EDID_OVERRIDE, "0" section in the .inf you saved and change the last two hex bytes to 0x00 and the checksum Phoenix EDID Designer gave you, respectively. You could then keep this .inf file around in case you ever needed to use it again.
Image

To maybe clarify some confusion in this thread, the fix I proposed earlier involved modifying the "EDID" registry binary value located under "Device Parameters" for the particular monitor in question, not EDID_OVERRIDE, but either should work, and the EDID_OVERRIDE method is the way you should do it according to Microsoft documentation.
Q9400@3.2GHz | GA-P35-DS3L | 8GB DDR2-800 | MSI GTX 560 Ti | Lian Li PC-7B | Corsair 450VX | Dell 2005FPW
crazybus
Minister of Gerbil Affairs
Gold subscriber
 
 
Posts: 2258
Joined: Wed Feb 26, 2003 8:25 pm

Re: Can't disable HDMI audio on DVI output

Postposted on Tue Apr 13, 2010 10:11 pm

Has anyone tested this with hdcp? I have an ati cable card tuner and a Geforce 9800 gt running on a Panasonic TC-P54V10 and im having the same problem getting the audio to stay disabled. im running a dvi to hdmi 4 foot cable to the tv and have the same fuzzy picture, washed out blacks/colors as described above when audio is enabled.

pls help, this problem is killing me!
anthon710
Gerbil In Training
 
Posts: 1
Joined: Tue Apr 13, 2010 9:48 pm

Re: Can't disable HDMI audio on DVI output

Postposted on Wed Apr 14, 2010 4:01 pm

The Nvidia control panel indicates that HDCP is still active, so it's quite possible that it could work with an ATI card. I would go ahead and try it. You can always revert the monitor .inf to default if it doesn't work.
Q9400@3.2GHz | GA-P35-DS3L | 8GB DDR2-800 | MSI GTX 560 Ti | Lian Li PC-7B | Corsair 450VX | Dell 2005FPW
crazybus
Minister of Gerbil Affairs
Gold subscriber
 
 
Posts: 2258
Joined: Wed Feb 26, 2003 8:25 pm


Return to Graphics

Who is online

Users browsing this forum: bertsheet, Kurkotain and 3 guests