CMD Problem

Monopoly money comes in many flavors: 7, Vista, XP, 2K, ME, 98, etc.

Moderators: Flying Fox, Ryu Connor

CMD Problem

Postposted on Mon Jun 06, 2011 4:51 pm

Hi, I've applied a change to my system through the CMD line prompt that I don't seem to be able to reverse.

I did this:

Create a shortcut and enter the following in the Location box.
POWERCFG -Change -monitor-timeout-ac 1


It works when I double click it i.e. screen shuts down in 1 min, BUT, when I try the opposite with this cmd:

Create another shortcut when you want to use the system for an extended period. POWERCFG -Change -monitor-timeout-ac 300


It didn't activate at all i.e. it didn't override the previous cmd above.

I'd like to turn off this initial function and be back where I was (I've learnt my lesson!)

Any idea how to do so? Thx.
solitudinalcomp
Gerbil
 
Posts: 45
Joined: Tue Aug 24, 2010 6:13 pm

Re: CMD Problem

Postposted on Tue Jun 07, 2011 1:43 am

Try running it in a command window (instead of by clicking a shortcut), to see if any diagnostics are displayed.

Try changing the power settings back via the Control Panel GUI.
(this space intentionally left blank)
just brew it!
Administrator
Gold subscriber
 
 
Posts: 37845
Joined: Tue Aug 20, 2002 10:51 pm
Location: Somewhere, having a beer

Re: CMD Problem

Postposted on Tue Jun 07, 2011 8:08 am

OK, I tried running
POWERCFG -Change -monitor-timeout-ac 300
from the CMD prompt and not the shortcut.

It didn't work. The 1 min timeout is still overriding any other changes.
solitudinalcomp
Gerbil
 
Posts: 45
Joined: Tue Aug 24, 2010 6:13 pm

Re: CMD Problem

Postposted on Tue Jun 07, 2011 8:15 am

solitudinalcomp wrote:OK, I tried running
POWERCFG -Change -monitor-timeout-ac 300
from the CMD prompt and not the shortcut.

It didn't work. The 1 min timeout is still overriding any other changes.

Did it display any error messages, or did you just get another command prompt?

Did you try resetting it via the Display Properties? (Assuming you are on XP: Right-Click on the desktop, Properties -> Screen Saver -> Power)

While you're in the display properties, also make sure you don't have the "Blank" screen saver set to kick in after 1 minute.
(this space intentionally left blank)
just brew it!
Administrator
Gold subscriber
 
 
Posts: 37845
Joined: Tue Aug 20, 2002 10:51 pm
Location: Somewhere, having a beer

Re: CMD Problem

Postposted on Tue Jun 07, 2011 8:50 am

No, Windows 7.

When I entered the command from the CMD prompt (i.e. not the shortcut like you said!), I simply entered the 300 min monitor timeout but it didn't work.

In my display settings it says 'turn off display - 5 hrs'.

So, obviously, this has been overriden by that initial command.

Surely, it's just a question of deleting the entry from the registry, right in order to get the comp back to how it was?

How do I do it?
solitudinalcomp
Gerbil
 
Posts: 45
Joined: Tue Aug 24, 2010 6:13 pm

Re: CMD Problem

Postposted on Tue Jun 07, 2011 9:00 am

solitudinalcomp wrote:No, Windows 7.

When I entered the command from the CMD prompt (i.e. not the shortcut like you said!), I simply entered the 300 min monitor timeout but it didn't work.

In my display settings it says 'turn off display - 5 hrs'.

So, obviously, this has been overriden by that initial command.

Surely, it's just a question of deleting the entry from the registry, right in order to get the comp back to how it was?

How do I do it?



If my engineering degree has taught me something is that 300 min = 5 hours.

If you are trying to not turn off your monitor just select never on the drop down menu.
Keyboard not detected, press F1 to continue...

Dell Inspiron 15 7537 Core i7 4500U, 8GB RAM, GT 750M, MX100 512GB
KamikaseRider
Gerbil
 
Posts: 60
Joined: Thu Dec 21, 2006 1:24 pm
Location: Brazil

Re: CMD Problem

Postposted on Tue Jun 07, 2011 9:00 am

Oh, for pity's sake.

To reset it from the GUI: open the start menu, then in the search bar at the bottom type "power plan" (no quotes), select the "choose a power plan", select which plan you want (I'd go for balanced), then click "change plan settings", and in the window that opens up select "restore default settings for this plan".

Done.
Think for yourself, schmuck!
i5-2500K@4.3|Asus P8P67-LE|8GB DDR3-1600|Powercolor R7850 2G|1.5TB 7200.11|1988 Model M|Saitek X-45 & P880|Logitech MX 518|Dell 2209WA|Sennheiser PC151|Asus Xonar DX
bthylafh
Grand Gerbil Poohbah
 
Posts: 3189
Joined: Mon Dec 29, 2003 11:55 pm
Location: Southwest Missouri, USA

Re: CMD Problem

Postposted on Tue Jun 07, 2011 9:14 am

OK, I did all that but the 1 min override is still taking precedence!

If you read my original post, the situation is exactly the same as when I made the post. So that means I've tried everything everyone has suggested but it hasn't worked!

So, even though it said, 'turn off display - 5 hrs', that is not what is happening - as I've tried to explain!
solitudinalcomp
Gerbil
 
Posts: 45
Joined: Tue Aug 24, 2010 6:13 pm

Re: CMD Problem

Postposted on Tue Jun 07, 2011 10:25 am

solitudinalcomp wrote:OK, I did all that but the 1 min override is still taking precedence!

If you read my original post, the situation is exactly the same as when I made the post. So that means I've tried everything everyone has suggested but it hasn't worked!

So, even though it said, 'turn off display - 5 hrs', that is not what is happening - as I've tried to explain!


Ohh...ok now I get it.

Have you tried "POWERCFG -Change -monitor-timeout-ac 0"??
Keyboard not detected, press F1 to continue...

Dell Inspiron 15 7537 Core i7 4500U, 8GB RAM, GT 750M, MX100 512GB
KamikaseRider
Gerbil
 
Posts: 60
Joined: Thu Dec 21, 2006 1:24 pm
Location: Brazil

Re: CMD Problem

Postposted on Tue Jun 07, 2011 10:41 am

Will that change the timeout from 1 min to 0 min? That would be a bigger problem!
solitudinalcomp
Gerbil
 
Posts: 45
Joined: Tue Aug 24, 2010 6:13 pm

Re: CMD Problem

Postposted on Tue Jun 07, 2011 10:59 am

For kicks, try opening the cmd prompt as an administrator first, then type in the command.

As for the how:
1) type "cmd" in the run/search box.
2) "cmd.exe" should be the highlighted program it finds
3) Press Ctrl+Shift+enter. You should get a UAC prompt asking for permissions. Click [Yes]
4) The command prompt window should open. Verify it says "Administrator:" in the window's title.
5) type in you power command line and hit enter!

Hope that helps.
///_-)
SnowboardingTobi
Gerbil Team Leader
Gold subscriber
 
 
Posts: 267
Joined: Wed May 21, 2003 10:56 am
Location: in your house, on the toilet, reading the newspaper

Re: CMD Problem

Postposted on Tue Jun 07, 2011 11:34 am

solitudinalcomp wrote:Will that change the timeout from 1 min to 0 min? That would be a bigger problem!


No, 0 disables the timeout feature.
cphite
Gerbil Elite
 
Posts: 559
Joined: Thu Apr 29, 2010 9:28 am

Re: CMD Problem

Postposted on Tue Jun 07, 2011 11:54 am

OK, I tried:
POWERCFG -Change -monitor-timeout-ac 0
and it didn't work.

I tried it from the desktop in the same way I activated:
POWERCFG -Change -monitor-timeout-ac 1
I never activated it as administrator. In fact, I don't really understand the concept of running as administrator. I just download and install programs to my drives and run them.
solitudinalcomp
Gerbil
 
Posts: 45
Joined: Tue Aug 24, 2010 6:13 pm

Re: CMD Problem

Postposted on Tue Jun 07, 2011 12:13 pm

solitudinalcomp wrote:OK, I tried:
POWERCFG -Change -monitor-timeout-ac 0
and it didn't work.

I tried it from the desktop in the same way I activated:
POWERCFG -Change -monitor-timeout-ac 1
I never activated it as administrator. In fact, I don't really understand the concept of running as administrator. I just download and install programs to my drives and run them.


I was hoping that 0 would work.

As an "I'm out of ideas let's try anything - thing" you could reboot into safe mode and try to change the energy settings on the control panel manually and then rebooting.
Keyboard not detected, press F1 to continue...

Dell Inspiron 15 7537 Core i7 4500U, 8GB RAM, GT 750M, MX100 512GB
KamikaseRider
Gerbil
 
Posts: 60
Joined: Thu Dec 21, 2006 1:24 pm
Location: Brazil

Re: CMD Problem

Postposted on Tue Jun 07, 2011 12:30 pm

Anything here helpful?

http://support.microsoft.com/kb/935799
Since you asked specifically about Registry:

"How to use the registry to set the preferred power plan
Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows


To change the preferred power plan, follow these steps:

Click Start
Start button
, type regedit in the Start Search box, and then click regedit.exe in the Programs list.

User Account Control permission
If you are prompted for an administrator password or for confirmation, type your password, or click Continue.
Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\ControlPanel\NameSpace\{025A5937-A6BE-4686-A844-36FE4BEC8B6D}
Right-click PreferredPlan, and then click Modify.
In the Value data box, enter one of the following:
Type 381b4222-f694-41f0-9685-ff5bb260df2e to use the Balanced plan.
Type a1841308-3541-4fab-bc81-f71556f20b4a to use the Power saver plan.
Type 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c to use the High performance plan.
You can also type the power scheme GUID for a custom power plan that you have created. To determine the GUID for all existing power schemes, type Powercfg /List at the command prompt, and then press ENTER.
Click OK, and then exit Registry Editor."
Sancte Isidore, ora pro nobis!
Caveat lector.
liar
Gerbil Elite
 
Posts: 634
Joined: Thu Mar 06, 2003 3:35 pm
Location: Concord,CA.


Return to Windows

Who is online

Users browsing this forum: No registered users and 5 guests