Data drive keeps "spooling up" repeatedly after Win8 Upgrade

All things storage here: hard drives, DVD RW drives, little wicker baskets.

Moderators: morphine, Steel

Data drive keeps "spooling up" repeatedly after Win8 Upgrade

Postposted on Sat Dec 15, 2012 7:40 pm

I'd really appreciate any help troubleshooting this issue.

I put together a computer with all new parts about a year ago. I have a SSD as an OS disk and 2x 2TB drives in RAID 1 as a data disk.

I never had any problems related to the drives at all, until I did an upgrade install from Windows 7 to Windows 8 recently. Now, whenever I try to listen to music or watch a movie stored on the data disks, the media constantly freezes, and then I can hear the drives "spool up", often several times in a row. Most times, it will get halfway through a song, or get to the next song, and then start doing this again. With Winamp, it seems to automatically buffer part of a song beforehand -- it'll play a few seconds and then freeze up before it can read the rest of the song.

I know coincidences do happen, but my intuition says this has something to do with my Windows 8 install, possibly because I upgraded instead of doing a clean install. I'm leaning toward reinstalling, but since that's something of a pain, I'd like to know if there's other steps I could take to troubleshoot. Maybe there's some new settings in Windows 8 related to this, that could affect it?

This is a desktop, with Power-Saving settings set to the default Balanced setting. It says to turn off the Hard Disk after 20 minutes, so I don't think that setting is coming into play.

edit: Forgot to mention I have Intel RST running, and it hasn't thrown any alerts or warnings.
edit:
Hardware:
OS - OCZ Vertex 3 120GB
Data - x2 Samsung Spinpoint F4 2TB
MOBO - ASUS P8P67 LE
RAID 1 is setup via the MOBO
Last edited by MJZ82 on Sat Dec 15, 2012 11:16 pm, edited 1 time in total.
MJZ82
Gerbil
 
Posts: 63
Joined: Tue Nov 24, 2009 2:24 pm

Re: Data drive keeps "spooling up" repeatedly after Win8 Upg

Postposted on Sat Dec 15, 2012 8:56 pm

One thing that comes to mind is an issue with some of the WD drives that I read about. They had a default setting in the drive firmware that leading to them parking the heads much more often then they should. So, people were running into a situation similar to what you are describing. With music it's easy enough for the player and the cache of the drive to spool enough data that the drive could go into a power savings mode (even if you have it off in Windows.)

I don't know if your drives are affected by this issue but it's something to look into.
nanoflower
Gerbil First Class
Silver subscriber
 
 
Posts: 196
Joined: Wed Mar 04, 2009 1:10 pm

Re: Data drive keeps "spooling up" repeatedly after Win8 Upg

Postposted on Sat Dec 15, 2012 10:03 pm

Make and model for the system hardware? Particularly the disk drives, motherboard, and RAID controller (if separate from the motherboard)?
He who laughs last, laughs first next time.
ludi
Gerbil Elder
 
Posts: 5470
Joined: Fri Jun 21, 2002 10:47 pm
Location: Sunny Colorado front range

Re: Data drive keeps "spooling up" repeatedly after Win8 Upg

Postposted on Sat Dec 15, 2012 11:15 pm

Hardware:
OS - OCZ Vertex 3 120GB
Data - x2 Samsung Spinpoint F4 2TB
MOBO - ASUS P8P67 LE
RAID 1 is setup via the MOBO
MJZ82
Gerbil
 
Posts: 63
Joined: Tue Nov 24, 2009 2:24 pm

Re: Data drive keeps "spooling up" repeatedly after Win8 Upg

Postposted on Sun Dec 16, 2012 2:16 am

I had this same "perpetual spinning up" problem with my 8x 2tb Samsung F4 array as well (this is with areca hardware raid). I solve it by setting "turn off hard disk after" to "never" in the windows control panel -> power options settings. It seems either the F4 have trouble spinning up coming out of a low power state when in a raid array or there is some kind of incompatibility. This happened on my ICH raid setup and Areca raid setup. This doesn't happen when the drive is used in a non-raid setup.
vandy
Gerbil
 
Posts: 84
Joined: Wed Feb 16, 2011 2:53 pm

Re: Data drive keeps "spooling up" repeatedly after Win8 Upg

Postposted on Sun Dec 16, 2012 4:51 am

vandy wrote:I had this same "perpetual spinning up" problem...


Hmm well I've had these drives in RAID 1 for over a year with no problems whatsoever. This happened as soon as I upgraded to Windows 8.
MJZ82
Gerbil
 
Posts: 63
Joined: Tue Nov 24, 2009 2:24 pm

Re: Data drive keeps "spooling up" repeatedly after Win8 Upg

Postposted on Sun Dec 16, 2012 12:03 pm

Which version of RST?

11.7 was just released http://downloadcenter.intel.com/SearchR ... %c2%ae+RST)

(Personally I'm all about Storage Spaces over RAID, but that's not what you asked about so hey.)
I can't leave without my buddy Superfly!
Savyg
Gerbil Elite
Silver subscriber
 
 
Posts: 701
Joined: Thu Aug 26, 2004 6:18 am
Location: The ever growing army of the undead.

Re: Data drive keeps "spooling up" repeatedly after Win8 Upg

Postposted on Sun Dec 16, 2012 2:13 pm

MJZ82 wrote:
vandy wrote:I had this same "perpetual spinning up" problem...


Hmm well I've had these drives in RAID 1 for over a year with no problems whatsoever. This happened as soon as I upgraded to Windows 8.


Exactly same thing happened to my 8x 2TB Samsung F4 RAID 6 Array. Powers down fine for the first year. After I reinstalled Windows 2008 R2, it no longer spins back up properly. I don't know what the cause is this happens with Intel ICH raid and my Areca (hardware raid). The first time it happened, I freaked out but my raid controller didn't fail the drive. So I pulled the drives out and ran samsung diagnostic tool on them and they all passed with no errors. Nowadays, I don't spin them down anymore.

Try to see if you still get the problem if you don't spin them down.

EDIT: I know you specifically mention windows 8, but i don't thing it is a OS problem.
vandy
Gerbil
 
Posts: 84
Joined: Wed Feb 16, 2011 2:53 pm

Re: Data drive keeps "spooling up" repeatedly after Win8 Upg

Postposted on Mon Dec 17, 2012 9:28 pm

Savyg wrote:Which version of RST?

11.7 was just released http://downloadcenter.intel.com/SearchR ... %c2%ae+RST)

(Personally I'm all about Storage Spaces over RAID, but that's not what you asked about so hey.)


Well, updating RST seems to have fixed it. Thanks for the tip. I was a few updates behind on this software, so maybe there were some bugs/incompatibility with it when using Windows 8.
MJZ82
Gerbil
 
Posts: 63
Joined: Tue Nov 24, 2009 2:24 pm


Return to Storage

Who is online

Users browsing this forum: No registered users and 1 guest