Catalyst 13.1 issues

From the pixels, bits, and shaders to the graphic cards that power them. Discuss the latest from AMD and NVIDIA here.

Moderators: morphine, SecretSquirrel

Catalyst 13.1 issues

Postposted on Thu Jan 31, 2013 8:29 am

I have a Sapphire Radeon HD7870 GHz edition w/2GB GDDR5 VRAM. Since installing catalyst 13.1 driver suite, I've seen strange artifacts with random small squares on windows borders (in W7 64 bit), and at least 2 gpu driver reinitialization while playing Tropico4. I was worried my gfx card was failing, but I've reverted to catalyst 12.10 and all of these issues have dissapeared, so it seems to be some kind of driver problem. Anyone else has had this issues?
jokinin
Gerbil
 
Posts: 31
Joined: Sat Aug 15, 2009 8:25 am

Re: Catalyst 13.1 issues

Postposted on Thu Jan 31, 2013 9:13 am

I haven't noticed any problems with my 7850. Does it do that with any games besides Tropico 4?
Think for yourself, schmuck!
i5-2500K@4.3|Asus P8P67-LE|8GB DDR3-1600|Powercolor R7850 2G|1.5TB 7200.11|1988 Model M|Saitek X-45 & P880|Logitech MX 518|Dell 2209WA|Sennheiser PC151|Asus Xonar DX
bthylafh
Grand Gerbil Poohbah
 
Posts: 3157
Joined: Mon Dec 29, 2003 11:55 pm
Location: Southwest Missouri, USA

Re: Catalyst 13.1 issues

Postposted on Thu Jan 31, 2013 10:18 am

I have the same exact issue. Well, half of it anyway, the strange desktop corruption. And on a 7850.

It doesn't appear in screenshots, and I can reproduce it easily by scrolling in Chrome. For example, I scroll one line, the corruption appears, I scroll another line, they disappear, and I can repeat that pattern dozens of times.

My assumption was that they had screwed up browser hardware acceleration or something, but I wasn't certain if chrome was the only cause.

I don't have any problems in games at all, whether BF3 or Skyrim. I ran Furmark for awhile too, but everything seems fine.

My guess was either the hardware acceleration, the idle clock profile being changed so low that 2d stuff was having problems, or some other issue with clock profiles switching. Or some combination thereof.

I haven't really had time to delve into it, but you're not the only one. I haven't bothered to revert, but I assumed that would solve it. This issue immediately appeared only after I went from 12.7? to 13.1

Edit: I also didn't bother to actually turn off hardware acceleration in Chrome or experiment with different browsers. Like I said, I haven't had the time. Maybe this weekend I'll see what I can discover.
Glorious
Darth Gerbil
Gold subscriber
 
 
Posts: 7844
Joined: Tue Aug 27, 2002 6:35 pm

Re: Catalyst 13.1 issues

Postposted on Thu Jan 31, 2013 10:36 am

13.2 Beta is running great for me on my 7850.

http://support.amd.com/us/kbarticles/Pa ... river.aspx
i7 860 - GA-P55-USB3 - 8GiB - HD7850 - SSD - 3.64TB HDD - Xonar D1 - U2410 - Win7 Pro x64.
DancinJack
Minister of Gerbil Affairs
 
Posts: 2040
Joined: Sat Nov 25, 2006 3:21 pm
Location: Austin, TX

Re: Catalyst 13.1 issues

Postposted on Thu Jan 31, 2013 11:28 am

As I uninstalled the 13.1 and rolled back to 12.10, I don't know if other games do the same. I will try Tropico4 with 12.10 later to see if it works ok, but I played this game with 12.10 before and I don't remember any driver gpu reinitialization previous updating to 13.1
In the beginning it seemed to affect Opera most, but also tested with Firefox and reproduced those weird random small squares and lines. Computer didn't seem to be unstable on desktop though.
I guess i will wait for 13.2 WHQL and try again.
jokinin
Gerbil
 
Posts: 31
Joined: Sat Aug 15, 2009 8:25 am

Re: Catalyst 13.1 issues

Postposted on Thu Jan 31, 2013 10:22 pm

I have not had any luck with any drivers after WHQL 12.10.
-12.1X betas causes Stalker CoP to crash when loading.
-13.1 WHQL also caused Stalker CoP to crash when loading.
-13.2 beta cause very severe flickering in Rage. When I uninstalled it and installed 12.10 back, Catalyst, Steam, Dxdiag, Flash would not work and crash. System restore failed. I had to reinstall the OS.

Obviously they are making a lot of critical changes which causes severe defects on many PCs.
Core i7 960 3.2GHz | 12GB RAM | 1.5TB HD | Asus GTX Titan | Dell WFP 3008 30" 2560x1600 | Windows 7 Ultimate 64 Bit
michael_d
Gerbil Elite
 
Posts: 562
Joined: Sun Dec 16, 2007 2:42 pm

Re: Catalyst 13.1 issues

Postposted on Fri Feb 01, 2013 12:27 am

I've had the same issues with a 4670 and Firefox on both XP with SP3 and Windows 8. My way of solving it was to turn off the 2d Hardware acceleration in Firefox. I think there's just something funky going on in the AMD drivers. In my case the corruption didn't always show up. I might go for a couple of days or a few minutes before I would see it. Scrolling up or down a page got rid of it.
nanoflower
Gerbil First Class
 
Posts: 186
Joined: Wed Mar 04, 2009 1:10 pm

Re: Catalyst 13.1 issues

Postposted on Fri Feb 01, 2013 1:23 am

Michael not sure if your problems are representative of AMD drivers. If you had issues like that and you sure it's not the hardware I would've done a full uninstall of the driver, run driver sweeper, and then reinstall the driver of your choice. If you install different versions of a driver enough (including betas), I'm sure you'd run into issues.

I came to comment on the squares issue though. I've had similar problems, but this only appears on my HDMI output of my 7870. The other outputs never have issues with this. I thought my graphics card was failing. It is completely random as others are stating and it doesn't show up in game.
Bensam123
Gerbil Elite
 
Posts: 949
Joined: Wed May 29, 2002 12:19 pm

Re: Catalyst 13.1 issues

Postposted on Fri Feb 01, 2013 9:29 pm

I was having basically this exact same problem, weird artifacts on window borders with 13.1 on a 7870. Like you, I reverted to 12.10 and it fixed the issue. Try the 13.2 beta drivers, I installed those and I haven't re-encountered the issue.
V33G33
Gerbil In Training
 
Posts: 1
Joined: Fri Feb 01, 2013 9:25 pm

Re: Catalyst 13.1 issues

Postposted on Sat Feb 02, 2013 8:54 am

Thanks for all the replies, I guess I will wait for the official release of 13.2, shouldn't take to long now!
jokinin
Gerbil
 
Posts: 31
Joined: Sat Aug 15, 2009 8:25 am


Return to Graphics

Who is online

Users browsing this forum: Yahoo [Bot] and 4 guests