AMD Monitor Shut-off Not Working Correctly in Windows 8

Monopoly money comes in many flavors: 7, Vista, XP, 2K, ME, 98, etc.

Moderators: Flying Fox, Ryu Connor

AMD Monitor Shut-off Not Working Correctly in Windows 8

Postposted on Mon Feb 04, 2013 8:03 am

*** Updated subject to reflect that this may be an AMD/ATI issue, and not just Windows 8 ***

------------------------ original first post follows ---------------------------

I think I may have gotten a setting wrong somewhere along the way.

My intention is to have Windows shut the screen off after 30 minutes, the HDD after 60, and go to sleep after several days of non-use.

But for some reason, my current "theme" isn't allowing that. I woke up this morning with the monitor "black but electrically charged" and nothing but a white "hand cursor" on the middle of the screen.

Power options is set correctly:

Screen saver is set to "none"
Turn off monitor: 30 minutes
Turn off hard disk: 60 minutes
Sleep after 10,000 minutes

Hybrid sleep is on
Hibernate is set to "never"

Any ideas? This is annoying! :)
Last edited by BIF on Tue Feb 05, 2013 7:33 pm, edited 2 times in total.
BIF
Gerbil Jedi
Gold subscriber
 
 
Posts: 1565
Joined: Tue May 25, 2004 7:41 pm

Re: Windows 8 monitor shut-off not working correctly

Postposted on Mon Feb 04, 2013 8:50 am

Hmm, my win 8 machine does exactly the same thing.

[edit]
I've got a Radeon 7770.
Last edited by GodsMadClown on Tue Feb 05, 2013 8:43 pm, edited 1 time in total.
GodsMadClown
Gerbil
Silver subscriber
 
 
Posts: 99
Joined: Thu Feb 27, 2003 10:02 am

Re: Windows 8 monitor shut-off not working correctly

Postposted on Mon Feb 04, 2013 8:51 am

Same problem, on ATI card. They recently "improved" the shutdown feature, and since then my monitory does not reliably shut down. It may have some interaction with an old Weather software program I run which used to do the same thing on dual-monitor setups only.

Oh, this is Windows 7 x64 for me.

What video card do you have?
liquidsquid
Minister of Gerbil Affairs
 
Posts: 2447
Joined: Wed May 29, 2002 10:49 am
Location: New York

Re: Windows 8 monitor shut-off not working correctly

Postposted on Tue Feb 05, 2013 2:56 pm

I've noticed this as well. Windows 7 x64 and my monitor does not shut off automatically anymore. It stays on with a black background and my cursor in the middle of the screen. I think it must be a Windows update that MSFT pushed in the last few weeks that is causing this. ATI card using the latest 13.1 WHQL drivers.
revcrisis
Gerbil
 
Posts: 10
Joined: Fri Sep 19, 2008 8:37 am

Re: Windows 8 monitor shut-off not working correctly

Postposted on Tue Feb 05, 2013 3:24 pm

How many of you guys are on ati cards? I'm not having a problem with my gtx 560ti (310.90 drivers).
I7 3820, 16 GB of ram, 240 gig corsiar nuetron, gtx 560 ti, asus x79 ws, HP ZR24w
128 GB surface pro
thecoldanddarkone
Minister of Gerbil Affairs
 
Posts: 2236
Joined: Wed Mar 26, 2003 4:35 pm

Re: Windows 8 monitor shut-off not working correctly

Postposted on Tue Feb 05, 2013 3:40 pm

HD7850 and I have had the same issues, certainly not all the time but it does happen, I'm leaning toward an update causing the issue because I don't remember this happening in the first couple weeks of having win8.
credible
Gerbil Team Leader
 
Posts: 205
Joined: Fri Oct 07, 2011 7:47 pm

Re: Windows 8 monitor shut-off not working correctly

Postposted on Tue Feb 05, 2013 4:10 pm

I've got this problem too on Windows 7 x64 with an AMD 7770 card. Pressing Ctrl-Alt-Del brings the screen back, but nothing else seems to. For me, this issue started back before Halloween (2012), seemed to go away for a while around Christmas (2012) but is back now as of mid January (2013).
JiveMiguel
Gerbil
 
Posts: 10
Joined: Mon Nov 15, 2010 2:20 pm

Re: Windows 8 monitor shut-off not working correctly

Postposted on Tue Feb 05, 2013 4:27 pm

I too have an ATI card; the HIS 7970 X .

The behavior began in recent days, and I know that I too updated to the more recent ATI driver set as pushed by Catalyst. Forget the number right now, but I believe I updated the drivers last Friday or Saturday.
BIF
Gerbil Jedi
Gold subscriber
 
 
Posts: 1565
Joined: Tue May 25, 2004 7:41 pm

Re: Windows 8 monitor shut-off not working correctly

Postposted on Tue Feb 05, 2013 4:51 pm

I'm on Win8 with Intel graphics, and my monitors sleep normally. Seems to be an ATI issue, not an 8 one.
Siglessness is boring.
Image - M4800-Eight1
Image - Vargr-Z97
Forge
Lord High Gerbil
 
Posts: 8033
Joined: Wed Dec 26, 2001 7:00 pm
Location: SouthEast PA

Re: Windows 8 monitor shut-off not working correctly

Postposted on Tue Feb 05, 2013 7:34 pm

Forge wrote:I'm on Win8 with Intel graphics, and my monitors sleep normally. Seems to be an ATI issue, not an 8 one.


I agree, and so I've changed the subject for accuracy.


Update: Hah, so today the monitor is actually shutting off after 30 minutes. No changes made at my end. Go figure.
BIF
Gerbil Jedi
Gold subscriber
 
 
Posts: 1565
Joined: Tue May 25, 2004 7:41 pm


Return to Windows

Who is online

Users browsing this forum: No registered users and 4 guests