Win 8 slipshod Notification When Plugging in a USB Device

Monopoly money comes in many flavors: 7, Vista, XP, 2K, ME, 98, etc.

Moderators: Flying Fox, Ryu Connor

Win 8 slipshod Notification When Plugging in a USB Device

Postposted on Sun Feb 10, 2013 3:05 am

Okay, so I have a number (probably greater than 10 20 okay, a lot) of USB devices.

Sometimes I plug them in (or switch them on) only when I'm preparing to use them, say when I'm plugging in a hard drive, USB stick, MIDI keyboard or drum trigger, etcetera and I unplug or switch them off when I'm done; to save power and to keep various LED displays from going blue or dim over time.

Windows 8 plays the "connect" sound only about half the time. The rest of the time, it's quiet and there's no confirming popup balloon in the system tray either. This is frustrating because I've grown dependent on a proper notification signal (of some sort!). Usually, it's easier to unplug and replug the device rather than open device manager.

But that's just wrong, so can anybody suggest how I can either get the sounds to work all the time or just turn on the balloons? Or devise another type of notification method?

Neither Device Manager, Task Bar configuration screens, nor Classic Start Menu offer any possible solutions.

Ideas?
BIF
Gerbil Jedi
Gold subscriber
 
 
Posts: 1600
Joined: Tue May 25, 2004 7:41 pm

Re: Win 8 slipshod Notification When Plugging in a USB Devic

Postposted on Sun Feb 10, 2013 8:52 am

Switch back to Windows 7 until Win8 SP1 comes out?
(this space intentionally left blank)
just brew it!
Administrator
Gold subscriber
 
 
Posts: 37834
Joined: Tue Aug 20, 2002 10:51 pm
Location: Somewhere, having a beer

Re: Win 8 slipshod Notification When Plugging in a USB Devic

Postposted on Sun Feb 10, 2013 10:39 am

There is unlikely to be a Windows 8 SP1.

I haven't seen this behavior BIF. I have seen it not be an instant chime when plugged or unplugged. Presumably the occasional delay occurs because loading/unloading the driver for the device in question takes a little longer. We're talking just a second or two delay, but it then it always chimes.

A quick bit of Google-Fu is also coming up short to show anyone else with the same problem. Sorry! :(
"Welcome back my friends to the show that never ends. We're so glad you could attend. Come inside! Come inside!"
Ryu Connor
Global Moderator
Gold subscriber
 
 
Posts: 3558
Joined: Thu Dec 27, 2001 7:00 pm
Location: Marietta, GA

Re: Win 8 slipshod Notification When Plugging in a USB Devic

Postposted on Sun Feb 10, 2013 1:51 pm

Have you changed any of the Windows default sound options? (Control Panel->Sound->Sounds) Try loading the Windows Default scheme.

Have you changed any notifications? (Control Panel->Notification Area Icons) There is one called Windows Explorer which is used for safely ejecting removable devices. Mine doesn't show a visual notification when I add or remove anything that's been used on the system before, or anything that has drivers. When I plug in something new it may install drivers. I have it set to 'Only Show Notifications' here.

Have you changed anything in Autoplay? Even with 'Use Autoplay...' disabled and 'Removable Drive = Take no action' I still get sound notifications. However you can change this to 'Ask me every time' to at least show a pop-up in the upper-right of the desktop.

The only way I can get new device sounds to stop is by changing the sound option for 'Device Connect'. The second two options are long shots to fix the problem as a Windows issue, but with Autoplay, at least for some devices, you ought to be able to get a visual notification every time. (I would choose 'Ask me every time' just because I am paranoid about auto-running stuff, even Explorer, for security sake.)

Other thoughts - is there any pattern? Is it certain devices only? Do you have any other programs that take over the sound output? (I usually run Foobar music player this way...no system or other program sounds are played unless music is stopped, not just paused.)

p.s. Is Core Parking enabled or disabled? :D
MadManOriginal
Graphmaster Gerbil
 
Posts: 1438
Joined: Wed Jan 30, 2002 7:00 pm
Location: In my head...

Re: Win 8 slipshod Notification When Plugging in a USB Devic

Postposted on Sun Feb 10, 2013 9:40 pm

JBI: Are you seriously suggesting that I fallback to Windows 7 only because of USB notifications? Come on, I know you're better than that! :P :lol:

Ryu: Thank you for checking for me.

MMO: I will go through your list of things to check and I'll post back. Thanks! And...regarding Core Parking: LOL! I needed that laugh, too! :lol:
BIF
Gerbil Jedi
Gold subscriber
 
 
Posts: 1600
Joined: Tue May 25, 2004 7:41 pm

Re: Win 8 slipshod Notification When Plugging in a USB Devic

Postposted on Sun Feb 10, 2013 10:02 pm

BIF wrote:JBI: Are you seriously suggesting that I fallback to Windows 7 only because of USB notifications? Come on, I know you're better than that! :P :lol:

Yeah, should've probably put a smiley on that post. :wink: But "wait for service pack 1" is generally reasonable advice (assuming there's going to *be* a service pack 1).
(this space intentionally left blank)
just brew it!
Administrator
Gold subscriber
 
 
Posts: 37834
Joined: Tue Aug 20, 2002 10:51 pm
Location: Somewhere, having a beer

Re: Win 8 slipshod Notification When Plugging in a USB Dev

Postposted on Sun Feb 10, 2013 10:56 pm

Hi. I get this too. Sometimes its a lag - slow response followed by a very slow attempt to read files (on a i7 box), sometimes no read at all. This often happens on my Dell 2410 monitor ports - and never happened on W7 and does not seem to be a wiring issue (since it works sometimes, etc - and no wiring changes since W7 -both 64 bit OS). I also get slow reads on my corsair USB 3 case front port - erratically,

I wondered if it was drivers since W8 doesn't seem to cover older stuff well. I also checked Google and forums - finding nothing. It is odd - and frustrating.
ordskiweicz
Gerbil Team Leader
Silver subscriber
 
 
Posts: 226
Joined: Fri Feb 27, 2009 5:44 pm

Re: Win 8 slipshod Notification When Plugging in a USB Devic

Postposted on Sun Feb 10, 2013 11:26 pm

That depends on what one considers "older stuff". Some of my connections are for relatively newer MIDI keyboards, mice, or other devices that actually have drivers released somewhat recently.
BIF
Gerbil Jedi
Gold subscriber
 
 
Posts: 1600
Joined: Tue May 25, 2004 7:41 pm

Re: Win 8 slipshod Notification When Plugging in a USB Devic

Postposted on Mon Feb 11, 2013 3:56 pm

No intention to derail the thread, but I've been having loads of small issues with Windows 8. I simply don't have the time to deal with the number of issues I'm having, even assuming all of them have a solution at the present moment. It's going to be lest costly (for the company I work for) for me to buy Windows 7 and redo my workstation and then go about being productive than for me to continue to deal with these numerous issues. It's pretty well driving me insane.

Having said that, Windows 8 gives me no major problems on my home computer where I don't use the computer for nearly as much, mostly just email and web.

Just saying, "go back to Windows 7" is not crazy at all if your time and productivity are of any value.
flip-mode
Gerbil Khan
Silver subscriber
 
 
Posts: 9084
Joined: Thu May 08, 2003 12:42 pm
Location: Cincinnati, OH


Return to Windows

Who is online

Users browsing this forum: No registered users and 5 guests