Personal computing discussed

Moderators: askfranklin, renee, emkubed, Captain Ned

 
willmore
Gerbil
Topic Author
Posts: 57
Joined: Wed May 28, 2008 11:08 am

pcper.com down? [mostly solved]

Thu Jun 27, 2019 9:02 am

[EDITED: Solved, see post further down.]

Is anyone having trouble reaching pcper.com? I get redirected to 127.0.0.1 when I try to go to their site. I wonder if I tripped some kind of content or spam filter.

Does anyone have a contact there who can look into it?
Last edited by willmore on Thu Jun 27, 2019 10:14 am, edited 2 times in total.
 
notfred
Maximum Gerbil
Posts: 4610
Joined: Tue Aug 10, 2004 10:10 am
Location: Ottawa, Canada

Re: pcper.com down?

Thu Jun 27, 2019 9:03 am

Works for me, redirect to localhost could be something on your end.
 
meerkt
Graphmaster Gerbil
Posts: 1441
Joined: Sun Aug 25, 2013 2:55 am

Re: pcper.com down?

Thu Jun 27, 2019 9:22 am

 
willmore
Gerbil
Topic Author
Posts: 57
Joined: Wed May 28, 2008 11:08 am

Re: pcper.com down?

Thu Jun 27, 2019 9:24 am

Thanks, I tried isitdown and it showed it okay, but I don't know what they do to check if something is up. I can ping it, but any reference to it in my web browser (FF) goes to localhost.

I did just try wget on it and it got the index.html and it looks normal. Wonder what FF did to get so confused?
 
willmore
Gerbil
Topic Author
Posts: 57
Joined: Wed May 28, 2008 11:08 am

Re: pcper.com down?

Thu Jun 27, 2019 9:28 am

Solved. Don't know what happened, but it looks like FF has its own DNS cache and it got corrupted somehow. The way to solve it was to go to View History->right click on pcper.com and select "forget this site". Then everything was fine. (so far).

Thanks everyone!

EDITED: Forgot the link to where I found the solution: http://forums.mozillazine.org/viewtopic ... &t=2245331
 
willmore
Gerbil
Topic Author
Posts: 57
Joined: Wed May 28, 2008 11:08 am

Re: pcper.com down? [solved]

Thu Jun 27, 2019 9:33 am

Even more followup. I am now logged out--I assume 'forget about this site' also kills cookies. No problem, hit the "login to reply" button and......127.0.0.1. Forgetting the site doesn't help. Looks like there might still be something on their end?
 
Captain Ned
Gold subscriber
Global Moderator
Posts: 27964
Joined: Wed Jan 16, 2002 7:00 pm
Location: Vermont, USA

Re: pcper.com down? [solved]

Thu Jun 27, 2019 9:38 am

Who do you use for DNS?
What we have today is way too much pluribus and not enough unum.
 
meerkt
Graphmaster Gerbil
Posts: 1441
Joined: Sun Aug 25, 2013 2:55 am

Re: pcper.com down? [solved]

Thu Jun 27, 2019 9:53 am

The site works for me. Try another browser to see if it's a FF issue or something global to your computer or LAN.
 
willmore
Gerbil
Topic Author
Posts: 57
Joined: Wed May 28, 2008 11:08 am

Re: pcper.com down? [solved]

Thu Jun 27, 2019 10:03 am

Captain Ned wrote:
Who do you use for DNS?

My ISP. The thing is it's the same hostname, so DNS shouldn't really be playing a role at that point.

Can anyone reproduce? Do the 'forget this site' thing and then go to a story with comments and click on the "login to reply" button?
 
willmore
Gerbil
Topic Author
Posts: 57
Joined: Wed May 28, 2008 11:08 am

Re: pcper.com down? [solved]

Thu Jun 27, 2019 10:04 am

meerkt wrote:
The site works for me. Try another browser to see if it's a FF issue or something global to your computer or LAN.

I don't have another browser, but I did try it on FF on my cell phone (Android) and it shows the same issue. It goes to 127.0.0.1 when trying to follow the login link.

EDITED: I take it back, I have a ChromeBook handy..... It shows the same behavior.
EDITED2: Okay, tried the login page specifically with wget and:
$ wget https://pcper.com/user-login/
--2019-06-27 11:06:27--  https://pcper.com/user-login/
Resolving pcper.com (pcper.com)... 104.200.29.114
Connecting to pcper.com (pcper.com)|104.200.29.114|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://127.0.0.1 [following]
--2019-06-27 11:06:27--  http://127.0.0.1/
Connecting to 127.0.0.1:80... failed: Connection refused.
 
meerkt
Graphmaster Gerbil
Posts: 1441
Joined: Sun Aug 25, 2013 2:55 am

Re: pcper.com down? [mostly solved]

Thu Jun 27, 2019 11:02 am

Strange. Looks like a 302 problem? I get to the login page just fine, and there's no 302, only 200.
Try on your phone to connect thru the cell network rather than WiFi.

And not that it looks like the problem, but for good measure try also other DNS servers, like 1.1.1.1 or 8.8.8.8 or 9.9.9.9.
 
willmore
Gerbil
Topic Author
Posts: 57
Joined: Wed May 28, 2008 11:08 am

Re: pcper.com down? [mostly solved]

Thu Jun 27, 2019 2:31 pm

Yeah, stranger and stranger. I told FF to forget the site and changed the NS to 8.8.8.8, went to the page and got the same redirect.
wget does the same thing.

But, the cell phone using FF and mobile data works....

What is going on....

Thanks for you help, by the way, it's greatly appreciated.
 
meerkt
Graphmaster Gerbil
Posts: 1441
Joined: Sun Aug 25, 2013 2:55 am

Re: pcper.com down? [mostly solved]

Thu Jun 27, 2019 2:37 pm

Are there any web/ad blocking rules on your router?

Tried power cycling the router?
 
Redocbew
Gold subscriber
Minister of Gerbil Affairs
Posts: 2159
Joined: Sat Mar 15, 2014 11:44 am

Re: pcper.com down? [mostly solved]

Thu Jun 27, 2019 2:40 pm

On my Ubuntu box it's sometimes necessary to flush the DNS cache from the system also with systemd-resolve for changes in DNS entries to take immediate effect. I'm assuming you're using Windows, so maybe that has something similar?
Do not meddle in the affairs of archers, for they are subtle and you won't hear them coming.
 
willmore
Gerbil
Topic Author
Posts: 57
Joined: Wed May 28, 2008 11:08 am

Re: pcper.com down? [mostly solved]

Thu Jun 27, 2019 6:18 pm

Redocbew wrote:
On my Ubuntu box it's sometimes necessary to flush the DNS cache from the system also with systemd-resolve for changes in DNS entries to take immediate effect. I'm assuming you're using Windows, so maybe that has something similar?


Fedora 29 here, FWIW. I'll look to see if they config systemd similarly.

@meerkt, nope, router just moves packets, it doesn't do any filtering other than dropping incoming connection requests. No pi-hole like stuff at all.

I'll try flushing the system level DNS and see if that helps.

Nope, that didn't do it. *sigh* I'm waiting for my forum membership over there to get out of moderation. Once it does, I'll ask them if there's something it might be.

Who is online

Users browsing this forum: derFunkenstein and 4 guests
GZIP: On