Page 1 of 37

Something's different...

Posted: Sun Jul 07, 2019 2:10 pm
by drfish
Edit: 7/20: Thread split, bug reports please post here.

Hang tight folks.

Edit: Obviously the site has a redesign and obviously it has things we don't like. Here's my list of BUGS and REQUESTS, please add more to the thread as they occur to you. Some of these issues are specific to us as writers, but I'm putting everything on this master list. I'd appreciate it if you kept your requests to the most critical of features just to cut down on the noise. Please don't take offense if your suggestion doesn't make my list, I'll be doing my own discretion based pruning to keeps things reasonable.

Bugs:
1) Quotes in old front page comments are broken
2) Editor's choice badges aren't showing up
3a) Image captions on old stories are gone FIXED
3b) Image captions on old stories aren't centered, italicized, or tight under the images
4) Affiliate links aren't created automatically by the CMS
5) Front page comments that went missing after The Click (I'm told this will be fixed within a couple days)
6) The drop down for hardware type doesn't filter down to just reviews. For example, it shows news items too, which leaves Bargain Basement posts mixed in
7) Missing feature images on older posts
8) Story summaries aren't being pulled for intros, the start of the article is
9) Some image switchers work, others are showing all the images in a big group
10) Subheads and sub-subheads are in the same font as the body of the story FIXED
11) Login required before each front page comment
12) RSS feed is busted FIXED/Apparently not?
13) AJAX error for mark forums read

Requests:
1) Also hyperlinking in front page comments DONE
2) Overall improvement on information density and readability
3) Replace "xx hours ago" with time and date of post DONE, date only, though
4) Show the number of comments a story has in the summary (ideally, make it a link directly to the comments) DONE
5) Move the comment thread with the most recently replied to comment to the top DONE
6) Blue/dark theme
7) Upvotes/downvotes DONE
8) Top comments summary
9) Hot threads summary
10) Clarification on TR subs and what they are/mean now
11) The dropdown page navigator with descriptions of the pages
12) No ability to control featured story, only chronological DONE
13) Fix
fo
r t
he
squ
ish
ed
tex
t w
hen
lo
ts
of
com
men
ts
pil
e u
p
14) Direct control of what gets published as the summary for news, blogs, and articles
15) Ability to edit comments
16) Change social media buttons to not cover content and stay hidden if directed to
17) Replacement for news.x

Re: Something's different...

Posted: Sun Jul 07, 2019 2:25 pm
by just brew it!
Threw me for a loop when the page formatting changed when I clicked for the next page of the Zen 2 review! :o

Also noticed some SSL security glitches earlier... I assume this was part of the switchover too?

Re: Something's different...

Posted: Sun Jul 07, 2019 2:37 pm
by meerkt
The homepage is loop-redirecting to itself, but checking remotely it does work.
Dislike the new design. :(

And the forums redirect and work thru an Amazon WS address.

Re: Something's different...

Posted: Sun Jul 07, 2019 2:43 pm
by just brew it!
meerkt wrote:
The homepage is loop-redirecting to itself, but checking remotely it does work.
Dislike the new design. :(

And the forums redirect and work thru an Amazon WS address.

Try clearing your cache.

Yeah, not sure how I feel about the new design either, but we'll see how I feel after living with it for a while.

Re: Something's different...

Posted: Sun Jul 07, 2019 2:47 pm
by meerkt
Same also without cache, on two browsers. (And... a few minutes later it works also locally.)

I'll reserve judgment on the redesign until I've had a chance to use it a bit, but I don't see what's to like.
All-white, low-density, blog-style are core elements in what I dislike in current design trends. Plus UI dumbification, like not showing actual dates or times.

Besides the design, I'm curious, what's the benefit of WordPress here?

Re: Something's different...

Posted: Sun Jul 07, 2019 3:14 pm
by NovusBogus
Yeah...can't say I'm a fan of low information density. Maybe let the user choose between a couple of display styles?

Re: Something's different...

Posted: Sun Jul 07, 2019 3:15 pm
by SecretMaster
Any way to bring the classic blue theme back on the new design?

Re: Something's different...

Posted: Sun Jul 07, 2019 3:20 pm
by drfish
I'm not a big fan myself FWIW. Front page comments linked to forum accounts are coming soon.

Sorry for the abrupt change and lack of warning. We were surprised by the timing as well. Details to come...

Re: Something's different...

Posted: Sun Jul 07, 2019 3:24 pm
by DancinJack
Oooof, I was a huge fan of the top forum threads list, along with the blue theme. Regardless of how this new design changes over time I will complain incessantly if those two things aren't in the plans.

As usual though, I'll give it some time and see how I feel in a couple weeks.

Re: Something's different...

Posted: Sun Jul 07, 2019 3:30 pm
by meerkt
Guessing: The custom CMS isn't easy to get running on AWS.

The homepage redirect loop is back. Maybe has to do with subdomains? Also the forums redirect-loop when using www, but work fine without it at https://techreport.com/forums

Re: Something's different...

Posted: Sun Jul 07, 2019 3:38 pm
by just brew it!
Or they just don't want to maintain a custom CMS any more.

Re: Something's different...

Posted: Sun Jul 07, 2019 3:43 pm
by bfg-9000
Well if the site is going to resemble Overclockers.com, I hope it does not also go to the same model where amateur members produce all the original content too

Re: Something's different...

Posted: Sun Jul 07, 2019 3:47 pm
by The Egg
On the actual design, I'll reserve my judgement until all the kinks are worked out, and I've had some time with it. Some growing pains are expected.

On the choice of timing for the redesign......the same day as two tremendously huge hardware releases was probably the worst day to pick out of any day this year.

Re: Something's different...

Posted: Sun Jul 07, 2019 3:48 pm
by meerkt
I suspect the day was not picked.

Re: Something's different...

Posted: Sun Jul 07, 2019 3:57 pm
by JustAnEngineer
The Egg wrote:
On the choice of timing for the redesign......the same day as two tremendously huge hardware releases was probably the worst day to pick out of any day this year.
Colossal F-up.

Did anyone notice that the logo on the forum pages no longer links to the main site?

You can get to the main page with https://techreport.com, but https://www.techreport.com is a fail.

Re: Something's different...

Posted: Sun Jul 07, 2019 4:06 pm
by drfish
JustAnEngineer wrote:
The Egg wrote:
On the choice of timing for the redesign......the same day as two tremendously huge hardware releases was probably the worst day to pick out of any day this year.
Colossal F-up.

Did anyone notice that the logo on the forum pages no longer links to the main site?

You can get to the main page with https://techreport.com, but https://www.techreport.com is a fail.


You're being too polite. I'm really sorry for this mess. We'll sort it out ASAP.

Re: Something's different... (new)

Posted: Sun Jul 07, 2019 4:19 pm
by DancinJack
Yeah the forum logo thing should be an easy fix. It's linking to an ec2 instance right now though :lol:

  <!-- TR site header - desktop -->
    <div id="tr-min-width">
    <div id="tr-container" style="background-color:#213666">

        <div id="tr-header">

            <a href="http://ec2-3-13-17-136.us-east-2.compute.amazonaws.com/" id="tr-logo"><img src="/img/blank.gif" alt="The Tech Report"></a>


heh

edit: oh noes, most forum links are borked
          <div id="tr-navbar">
                <div id="tr-linklist">
                    <a href="http://ec2-3-13-17-136.us-east-2.compute.amazonaws.com/cpu/"><span class="tr-firstchar">CPU</span>s</a>
                    <a href="http://ec2-3-13-17-136.us-east-2.compute.amazonaws.com/graphics/"><span class="tr-firstchar">G</span>RAPHICS</a>
                    <a href="http://ec2-3-13-17-136.us-east-2.compute.amazonaws.com/motherboards/"><span class="tr-firstchar">M</span>OTHERBOARDS</a>
                    <a href="http://ec2-3-13-17-136.us-east-2.compute.amazonaws.com/case+power/"><span class="tr-firstchar">C</span>ASES &amp; POWER</a>
                    <a href="http://ec2-3-13-17-136.us-east-2.compute.amazonaws.com/storage/"><span class="tr-firstchar">S</span>TORAGE</a>
                    <a href="http://ec2-3-13-17-136.us-east-2.compute.amazonaws.com/mobile/"><span class="tr-firstchar">M</span>OBILE</a>
                    <a href="http://ec2-3-13-17-136.us-east-2.compute.amazonaws.com/gaming/"><span class="tr-firstchar">G</span>AMING</a>
                    <a href="https://ec2-3-13-17-136.us-east-2.compute.amazonaws.com/forums/" class="tr-highlighted"><span class="tr-firstchar">F</span>ORUMS</a>
                    <a href="http://jobs.techreport.com/"><span class="tr-firstchar">J</span>OBS</a>
                    <div id="tr-more">
                        <a href="#"><span class="tr-firstchar">M</span>ORE...</a>
                        <ul>
                            <li><a href="http://ec2-3-13-17-136.us-east-2.compute.amazonaws.com/news.x"><span class="tr-firstchar">N</span>EWS</a></li>
                            <li><a href="http://ec2-3-13-17-136.us-east-2.compute.amazonaws.com/breadbox.x"><span class="tr-firstchar">B</span>READBOX</a></li>
                            <li><a href="http://ec2-3-13-17-136.us-east-2.compute.amazonaws.com/archive.x?tags=Podcast"><span class="tr-firstchar">P</span>ODCASTS</a></li>
                            <li><a href="http://ec2-3-13-17-136.us-east-2.compute.amazonaws.com/blogs.x"><span class="tr-firstchar">B</span>LOGS</a></li>
                            <li><a href="http://ec2-3-13-17-136.us-east-2.compute.amazonaws.com/system/"><span class="tr-firstchar">S</span>YSTEMS</a></li>
                            <li><a href="http://ec2-3-13-17-136.us-east-2.compute.amazonaws.com/multimedia/"><span class="tr-firstchar">M</span>ULTIMEDIA</a></li>
                            <li><a href="http://ec2-3-13-17-136.us-east-2.compute.amazonaws.com/misc/"><span class="tr-firstchar">M</span>ISCELLANY</a></li>
                            <li><a href="http://ec2-3-13-17-136.us-east-2.compute.amazonaws.com/archive.x"><span class="tr-firstchar">A</span>RCHIVE</a></li>
                            <li id="tr-menulast"><a href="http://ec2-3-13-17-136.us-east-2.compute.amazonaws.com/aboutus.x"><span class="tr-firstchar">A</span>BOUT US</a></li>
                        </ul>
                    </div>
                    <div class="tr-social">
                        <a href="http://ec2-3-13-17-136.us-east-2.compute.amazonaws.com/feeds.x" class="tr-rss"></a>
                        <a href="//twitter.com/thetechreport" class="tr-twit"></a>
                        <a href="//www.facebook.com/pages/The-Tech-Report/60933942920" class="tr-face"></a>
                    </div>
                </div>


i'm sure Bruno will get it straighened out asap. Also mods feel free to pull these if you don't want that ec2 URL exposed.

Re: Something's different... (new)

Posted: Sun Jul 07, 2019 4:22 pm
by drfish
I'm going to go procure some adult beverage while the dust settles. :x

Re: Something's different... (new)

Posted: Sun Jul 07, 2019 5:27 pm
by Rand
I really don't think much of the UI design.
Ultra low density, all white, the 'recent posts' right column appears to be completely useless as it's just a copy of the primary/center column, having to specifically go the a separate page to even know a new review has been posted. Plus general UI simplification all around.

I'm hoping this is decidedly a beta UI and changes will be coming because right now this seems like a considerable down grade all around.
If I didn't love TR so much I wouldn't have even stuck around to read the review itself...

Re: Something's different... (new)

Posted: Sun Jul 07, 2019 5:27 pm
by brucek2
My Firefox on windows browser won't connect to the site due to "too many redirects." It does have some privacy configs that maybe come into play, but I don't have this issue with any other site I know of.

Chrome is working but when I use my regular home IP it tells me that my IP address has been perma-banned. I am suspicious that was an actual intended decision as AFAIK my occasional posts have never been seen as offensive or controversial and it's been a while since the last one anyway.

I miss the old layout, which was relatively unique for it's high density and high exposure of reader comments which are an important part of why I like this site. I hope it comes back as an optional choice.

Re: Something's different... (new)

Posted: Sun Jul 07, 2019 5:28 pm
by Mikael33
I noticed the resign and went to check the forums about it earlier and it said I was IP banned, I got skurred :lol:

Re: Something's different... (new)

Posted: Sun Jul 07, 2019 5:54 pm
by drfish
I'm still posting in this new thread and the same old thread in the "other" forums. It's less than ideal. Trust me, I have a similar list of complaints.

Re: Something's different... (new)

Posted: Sun Jul 07, 2019 6:01 pm
by NovusBogus
I got the IP ban notice as well, they probably accidentally used a wrong wildcard or something. I won't hold it againt them though; for a moment there I felt like a rambunctious teenage forum warrior again. 8)

Lots of stuff is going direct to ec2 URLs, definitely some cleanup work to be done.

Re: Something's different... (new)

Posted: Sun Jul 07, 2019 6:07 pm
by DeadOfKnight
This provides very little information at a glance, and next to nothing for navigation and filtering options. It seems to be a trend these days.

I can't be the only one that hates this. TR had a really nice layout, even for mobile. I get it, everyone wants to keep up and stay "modern".

However, TR is an enthusiast site, not a clickbait feed for people with ADD. Tech sites like Gizmodo aren't really used for reference like TR.

Re: Something's different... (new)

Posted: Sun Jul 07, 2019 6:23 pm
by ludi
I'm going to be the contrarian (sort of) and say I like the overall look of the redesign, but I don't like the low information density on the desktop. It seems like a bit of proper latest-and-greatest index navigation could and should be retained.

Re: Something's different... (new)

Posted: Sun Jul 07, 2019 6:33 pm
by Philldoe
I mean.. just bring back the all blue theme and we're good. The white is murder on my eyes.

Re: Something's different...

Posted: Sun Jul 07, 2019 6:45 pm
by JustAnEngineer
drfish wrote:
Sorry for the abrupt change and lack of warning. We were surprised by the timing as well.
I expect that this wasn't what Bruno planned to be doing at midnight on a Sunday night.

Re: Something's different... (new)

Posted: Sun Jul 07, 2019 7:09 pm
by FireGryphon
Well this is terrible. All I see on my phone now is a blog-style scrolling list of articles. Where are the top comments and recent forum posts?

It’s as if the community is gone from TR, and quite frankly, that’s the strongest part of the site, and always was. I understand if a custom CMS is too much work, but there has got to be something better than this...

Re: Something's different... (new)

Posted: Sun Jul 07, 2019 7:16 pm
by chuckula
Ok look, I get that the fanboys were excited about some chiplets but... Hey, WHA HAPPANED!!?!?!?!? to the freakin' website!

Re: Something's different... (new)

Posted: Sun Jul 07, 2019 8:01 pm
by synthtel2
No worries from me about the technical issues, stuff happens, but I've got to say I too really hate the new look. Scaling to 90% and forcing colors to light-on-dark makes it tolerable, but that's clunky itself.