Personal computing discussed

Moderators: David, mac_h8r1, Nelliesboo

Gerbil XP
Topic Author
Posts: 301
Joined: Sat Dec 13, 2008 1:24 am
Location: White River Junction, Vermont

Laptop power issue

Wed Aug 22, 2012 2:28 pm

I was given a gateway laptop that is about 3 years old. They said it worked before they put it in a closet and unfortunately it didn't come with the ac power brick/cord. I ordered one on amazon and checked the connector. Everything fits nice and snug in with no play and the brick LED is on. Well I was expecting to see the little battery icon on the laptop itself at least show some kind of LED light come on. No sign of life. I tried to power it on a few times and no luck. I even tried to remove the hard drive, ram, and battery then plug it in and turn it on...still nothing. Any ideas on what else to try? It would be sad if a semi new laptop like it is toast :(
Intel I7-2600k, Asus P8P67, 16GB DDR3 1600mhz, Geforce GTX 1070, ASUS Xonar D2, Samsung Evo 250GB, Western Digital Black 1TB, Corsair HX750w

Who is online

Users browsing this forum: No registered users and 1 guest