Personal computing discussed

Moderators: renee, Steel, notfred

 
flip-mode
Grand Admiral Gerbil
Topic Author
Posts: 10218
Joined: Thu May 08, 2003 12:42 pm

Still can't share, wallowing in despair :x

Mon Oct 03, 2005 7:31 am

Let me start by saying :x

Ok, I tried everything from this thread. I did a clean-slate install of both the desktop and laptop - that sucked as I don't really enjoy installing windows. Anyway, here's all my hardware I'm using:

Uniwill 258KAO Laptop with SIS based ethernet adapter
DFI NF2 Ultra Infinity on-board nforce ethernet adapter
D-Link 5 port Switch
One cross-over cable (not serving any cross-over purpose, but the manual told me it would work just fine)
One standard ethernet cable

Under [Network connection] > Properties > Configure > Advanced
the lappy only has:
media type
network address

the desky has:
network address
optimize for
speed/duplex settings
wakeonlan from poweroff

I can ping the desky from the lappy, but can't ping the lappy from the desky.

I using workgroup sharing, i.e. I don't have any static i.p. setup or anything, since I'm a networking nube and I don't know how. When I try to access the workgroup (called Dianna, my street) from the lappy it says "Dianna is not accessible. You might not have permission to use this network resource. Contact the admin... blah blah." If I just use the crossover cable between the two comps, then I can see both comps from the lappy, but can't access the desky and get a message "\\Grimace is not accessible. You might not have permission... "

Would going static help? If so can someone tell me how to do that? All I really care about is sharing the D drive on the desky, I don't need to share any of the lappy's files as I can just drop them onto the desky. Basically, if you haven't noticed, I just want the desky to be my file server, and I can't for the frigging life of me make it work :x It worked a couple weeks ago but then stopped working after a reformat of the desky :x

Please deliver me.
 
Logan[TeamX]
Gerbil First Class
Posts: 100
Joined: Fri Oct 03, 2003 10:28 am
Location: Sitting here, making sure you don't crash
Contact:

Mon Oct 03, 2005 7:57 am

Wow, here's a "good morning!" topic if I ever saw one! :D

Alright, first of all, which version of Windows do you have on each laptop?

Please don't tell me there's anything Win9X (95, 98, 98 2nd ed) trying to access anything Windows XP-based, especially Windows XP Homeless Edition. If not, carry on. If so, obtain a large amount of hallucinogenic painkillers. Then carry on.

In Windows XP, go to your Network Card properties on each machine and ENSURE that the Windows Firewall is OFF. Completely OFF. For both machines. Do this by going Control Panel --> Network Connections --> Doube-click the network card icon displayed within --> Click the Properties button --> Click the Advanced tab --> Click the Settings button --> Ensure the Firewall is turned OFF. Click OK and/or Close as required to return to the main Network Card properties page.

Next, using the handy-dandy Support tab on your Local Area Connection page, check your IP address for each machine. Write it down. Ensure that for each IP address segment displayed that it corresponds with your net mask being 255. So, if your net mask is 255.255.255, your beginning address numbers should be identical. I can't stress that enough.

So, if one network card is 192.168.1 and one is 192.168.10 or something to that effect, you're going to need to fix that before you go any further. Once you're sure that both computers are on the same network (as proven by the above address steps), try to ping them.

Report back when you get there, and we'll take it from there. It's always best to start from the beginning - in this case, eliminating the Windows Firewall, checking for disparate Operating Systems, and ensuring both computers are on the same network.
Systems Admin for an international mining contractor.

Specialties: network security and monitoring, network design - VLANs, BOVPNs and WAN networking, AD / DNS / AD-aware services, Exchange 2003/2007, email archiving, many hats indeed.
 
flip-mode
Grand Admiral Gerbil
Topic Author
Posts: 10218
Joined: Thu May 08, 2003 12:42 pm

Mon Oct 03, 2005 8:12 am

Logan, thanks for jumping in :)

XP professional SP2 installed on both the lappy and the desky

Turned off firewall for both at your suggestion.

Address settings:

Lappy:
IP 169.254.222.138
Subnet mask 255.255.0.0

Desky:

IP 169.254.181.7
Subnet Mask 255.255.0.0
 
flip-mode
Grand Admiral Gerbil
Topic Author
Posts: 10218
Joined: Thu May 08, 2003 12:42 pm

Mon Oct 03, 2005 8:13 am

I don't understand why the firewall gets in the way when it has an exception for file sharing. When the share was working a few weeks ago the firewall was enabled.
 
blitzy
Gerbil Jedi
Posts: 1844
Joined: Thu Jan 01, 2004 6:27 pm
Location: New Zealand

Mon Oct 03, 2005 8:15 am

any particular reason for using those ip addresses?

http://en.wikipedia.org/wiki/Private_IP_address
 
just brew it!
Administrator
Posts: 53994
Joined: Tue Aug 20, 2002 10:51 pm
Location: Somewhere, having a beer

Mon Oct 03, 2005 9:03 am

blitzy wrote:
any particular reason for using those ip addresses?

http://en.wikipedia.org/wiki/Private_IP_address

Windows will assign a 169.254.x.x address if you don't configure one manually, and there's no DHCP server on your LAN:
Internet RFC 3330 wrote:
169.254.0.0/16 - This is the "link local" block. It is allocated for communication between hosts on a single link. Hosts obtain these addresses by auto-configuration, such as when a DHCP server may not be found.

(Full text of RFC 3330 here)
Nostalgia isn't what it used to be.
 
blitzy
Gerbil Jedi
Posts: 1844
Joined: Thu Jan 01, 2004 6:27 pm
Location: New Zealand

Mon Oct 03, 2005 9:15 am

ah ok, thanks never heard of that one before
 
Kraft75
Gerbil
Posts: 96
Joined: Tue Jan 20, 2004 11:53 am

Mon Oct 03, 2005 9:17 am

Are you sure you're not running any type of third party firewall, ie. Zone Alarm? Cause I remember having trouble connecting to a computer on my LAN using Zone Alarm... even when I have the Zone Alarm disabled, it would still block windows files sharing. I had to unsinstall it, then it worked properly.


... :o
 
notfred
Maximum Gerbil
Posts: 4610
Joined: Tue Aug 10, 2004 10:10 am
Location: Ottawa, Canada

Mon Oct 03, 2005 11:29 am

You need to dump the arp cache, open a command prompt and type "arp -a" after trying pings in both directions. Paste the output of both here and that will help us work out what is going on. Also paste the output of "ipconfig /all" and "route print".
 
flip-mode
Grand Admiral Gerbil
Topic Author
Posts: 10218
Joined: Thu May 08, 2003 12:42 pm

Mon Oct 03, 2005 12:02 pm

No third party software - fresh installs of XP less than 24 hours old (at least the lappy is booting and shutting down more quickely.)

I'll check that arp chache in about two hours when I get home from university and post the results, thanks.
 
Kraft75
Gerbil
Posts: 96
Joined: Tue Jan 20, 2004 11:53 am

Mon Oct 03, 2005 1:01 pm

You can also check if the correct protocols are installed, and enabled(checkmark) in the properties of your LAN Connection (in Network Connections). At our office, we disable both "Microsoft Network Client" and "File and Printer Sharing" from the connections properties, to minimize traffic on our LAN, though we still leave TCP/IP enabled for internet and IP printers.
 
flip-mode
Grand Admiral Gerbil
Topic Author
Posts: 10218
Joined: Thu May 08, 2003 12:42 pm

Mon Oct 03, 2005 1:37 pm

ipconfig /all of Desktop:

Windows IP Configuration
Host Name . . . . . . . . . . . . : grimace
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : NVIDIA nForce Networking Controller
Physical Address. . . . . . . . . : 99-F8-C6-7E-F2-D9
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address. . . : 169.254.181.7
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

ipconfig /all of laptop:

Windows IP Configuration
Host Name . . . . . . . . . . . . : scout-a64
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Sis 900-Based PCI Fast Ethernet Adapter
Physical Address. . . . . . . . . : 00-03-0D-18-0B-15
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address. . . : 169.254.222.138
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

arp -a both machines respond with "No ARP Entries Found"
 
Kraft75
Gerbil
Posts: 96
Joined: Tue Jan 20, 2004 11:53 am

Mon Oct 03, 2005 2:38 pm

Might be a dumb question: Do you have the latest drivers for both NIC cards?

There's another thing you could try, is assigning manually IP addresses to both computers, and try pinging again.

Network Connections -> Local Area Network -> Properties -> Double-click on the TCP/IP protocol, and use the following adresses:

Desktop:
IP Address: 192.168.1.100
Subnet Mask: 255.255.255.0
Default Gateway: Blank

Laptop:
IP Address: 192.168.1.101
Subnet Mask: 255.255.255.0
Default Gateway: Blank

Now try pinging each other using the new IP addresses... longshot but worth a try at this point.
 
notfred
Maximum Gerbil
Posts: 4610
Joined: Tue Aug 10, 2004 10:10 am
Location: Ottawa, Canada

Mon Oct 03, 2005 2:47 pm

arp -a reporting nothing found is wrong, particularly after trying a ping. Also what is interesting is the Node Type being Hybrid on the Desktop and Unknown on the Laptop.

I'm getting suspicious of the Laptop's ethernet drivers. It is an SiS which haven't been known for their reliability. Maybe worth throwing a Knoppix CD in the laptop and seeing if that makes it ping OK (would need to manually assign the same IP address). Also try the same thing with the desktop. It should at least tell you which end you have issues and whether those issues are hardware or drivers.
 
just brew it!
Administrator
Posts: 53994
Joined: Tue Aug 20, 2002 10:51 pm
Location: Somewhere, having a beer

Mon Oct 03, 2005 2:50 pm

Go into the connection properties on both systems, and verify that "Client for Microsoft Networks" and "File and Printer Sharing for Microsoft Networks" is installed and enabled.

Also make sure you have created the same account on both machines, with the same password. (Yes, I know this was in the previous thread, but it bears repeating.)
Nostalgia isn't what it used to be.
 
flip-mode
Grand Admiral Gerbil
Topic Author
Posts: 10218
Joined: Thu May 08, 2003 12:42 pm

Mon Oct 03, 2005 2:54 pm

Ok Kraft, I tried that from each machine and they both returned:

Packets: Sent = 4, Received = 0, Lost = 4 (100% loss)

:x

Thanks though Kroft.

I'm going to replace the cross-over cable with a standard cable and try again.

Anyone else?
 
drsauced
Gerbil Jedi
Posts: 1543
Joined: Mon Apr 21, 2003 1:38 pm
Location: Here!

Tue Oct 04, 2005 1:56 am

What cables you using? I'm thinking if you tried EVERYTHING in these threads and you still can't connect, a cable must be bunged.

Chuck the cables, and buy some new ones!

Let me qualify that, use TWO straight-through cables to connect comps to a switch, and x-over cable from computer to computer, not computer to switch.
Calm seas never made a skilled mariner. But, sadly I'm an A's fan.
 
VaTech Hokie
Minister of Gerbil Affairs
Posts: 2216
Joined: Mon Dec 06, 2004 4:45 pm
Location: Waiting for the return of the great TB

Tue Oct 04, 2005 5:33 pm

Im sorry but this has got to be on the Top Ten TR quotes of all time...this is sig quality.

Logan[TeamX] wrote:

Please don't tell me there's anything Win9X (95, 98, 98 2nd ed) trying to access anything Windows XP-based, especially Windows XP Homeless Edition. If not, carry on. If so, obtain a large amount of hallucinogenic painkillers. Then carry on.

I.


EDIT: Im sorry everytime i read it I laugh again!
More relevant you have it working yet?

I have had the same kind of thing happen before. Where its working for a while and then it magically stops and you have to start from scratch new workgroup and all.

So let me act as a dell tech for ya: "Sir first is your computer turned on at the moment?"

"Have you tried restarting your computer sir?"
Always Proud to be Hokie
 
notfred
Maximum Gerbil
Posts: 4610
Joined: Tue Aug 10, 2004 10:10 am
Location: Ottawa, Canada

Tue Oct 04, 2005 7:20 pm

Networking works in layers. If you don't have the layer 3 connectivity (arp -a reporting nothing, ping not working and no firewalls) then concentrate on your cables and your drivers first. Once that is working, you can move up the networking stack and try and get sharing to work.

Who is online

Users browsing this forum: No registered users and 2 guests
GZIP: On