Personal computing discussed

Moderators: mac_h8r1, Nemesis

Gerbil XP
Topic Author
Posts: 391
Joined: Thu Dec 20, 2012 5:31 pm

USB port power settings

Wed Jun 19, 2013 6:08 am

I don't know what I did or if it was even me but the USB ports on my PC used to be on all the time, even after shut down. I liked having it that way for charging various devices while I am sleeping. However, something changed and now they are shutting down when I shut the PC down. I checked in the Control panel under power options and from what I can tell they should be on. I have not changed anything in the BIOS for the motherboard so I am thinking it has to be in windows 8 some where. Any ideas on where I should be looking for this setting?
Gerbil Jedi
Posts: 1899
Joined: Fri Aug 20, 2010 6:03 pm
Location: philly suburbs

Re: USB port power settings

Wed Jun 19, 2013 6:41 am

Is it a gigabyte board, My p67-ud4-b3 has the same feature but it is only on select ports. I had to set it up in the bios if i recall correctly.

Did you happen to upgrade or clear the BIOS by chance? If you did you would have to go into the BIOS and set it up again.

My board has 3 usb2 in the front 8 usb2 +2 usb3 in the IO cluster then i have a PCI bracket that mounts vertically with 2 more usb2 for a grand total of 13 usb 2 ports and 2 usb 3 ports. I have them all filled up but the 2 usb3 ports and the pci slot usb2 ports. I use 7 just for charging ...4 go to my 3d glasses for my tv 2 are micro usb and the other 2 are super micro:) One for charging my jaybyrd 2 bluetooth sports headphones "that work fantastic for my IOS devices" The the 2 IOS charging cables one Ipad 2/iphone 4s and iphone 5's new cable.
I have no USB 3 devices...But i do want a fast 64GB USB3 flash drive bad:)
2600k@4848mhz @1.4v CM Nepton40XL 16gb Ram 2x EVGA GTX770 4gb Classified cards in SLI@1280mhz Stock boost on a GAP67-UD4-B3, SBlaster Z powered by TX-850 PSU pushing a 34" LG 21/9 3440-1440 IPS panel. Pieced together 2.1 sound system
Gerbil XP
Topic Author
Posts: 391
Joined: Thu Dec 20, 2012 5:31 pm

Re: USB port power settings

Wed Jun 19, 2013 7:48 pm

Its a Asus V LK motherboard and I have not done anything to Bios, no updates, no changes of any kind. Why I think its something in Win8.
Silver subscriber
Gerbil Elite
Posts: 677
Joined: Tue Sep 27, 2011 12:14 pm
Location: Gerbil-land, Canada

Re: USB port power settings

Thu Jun 20, 2013 3:25 pm

Were you shutting down or sleeping?

Check your settings under power management advanced settings.

Only have a Win7 box here to compare with.
Grand Admiral Gerbil
Posts: 10254
Joined: Thu Jun 19, 2003 3:11 pm

Re: USB port power settings

Thu Jun 20, 2013 6:25 pm

In Device Manager (Winkey+R devmgmt.msc, though note you'll need to elevate your rights if you're not logged in as an admin):
Expand the USB controllers node and look at the properties for each Hub. There should be a "Power Management" tab, on which there's a checkbox for "Allow the computer to turn off this device" -- you'll want to uncheck that for the hub controlling the USB ports you want to remain powered. (And since it's not always easy to figure out which hub goes with which USB port, you may want to turn them on for all hubs -- especially if this is a desktop where battery life isn't a concern).

I haven't verified this on Win8 (need to get around to putting that back into a VM) but devmgmt.msc is still available there so it shouldn't be any different.

It's possibe you'll need to go into your BIOS and change something there also. Sometimes BIOS settings get reset (especially if you have a failing battery, though Win8 might have futzed with them during install also) and having power after shutdown (rather than sleep) is really in the hands of the hardware/BIOS not the OS. Depending on the motherboard, it's possible only a subset of the USB ports remain powered after shutdown, and maybe you got lucky with the ones you happened to pick before and you're just using the "wrong" ones now.
Posts: 13
Joined: Sat Jun 29, 2013 2:23 pm

Re: USB port power settings

Sun Jun 30, 2013 2:19 pm

as uber gerbil said, in bios there IS( depending on your mobo ) a setting, you can try the s3 or s4 power states. setting your computer to sleep in windows as opposed to hibernate is ideal. my guess is windows changed it's setting on you, i have this issue sometimes in win7 x64 ultimate. hope this helps.
mobo: msi 970 g46
gpu: ati 4850 @ 750core/1100mem arctic cooling twin frozr cooler
cpu: 955be @ 3.8ghz @ 1.375v's 2.6ghz n/b 1.275 scythe scrt-1000
ram: 2x2 samsung hyko @ 800mhz @ 6-8-8-24
psu: corsair 650hx
hdd's: 500gb + 1tb( 16 and 32mb cache )samsung

Who is online

Users browsing this forum: Jonsey and 23 guests