Personal computing discussed

Moderators: morphine, SecretSquirrel

 
XorCist
Gerbil First Class
Topic Author
Posts: 116
Joined: Wed Apr 18, 2007 6:54 pm
Location: Clovis, CA

Weird fps stuttering

Sat Aug 12, 2017 1:10 pm

I have a XFX R9 380X. Ever since I installed 17.7.2 I've been having a weird fps stuttering. I had to uninstall 17.7.2 because of a weird HDMI handshake issue, and went back to 17.7.1. I did a DDU going from 7.2 to 7.1.

The issue I'm having is I normally sit at 100fps in Dota2, but every couple seconds it dips down to 70, and then ramps right back up.
When I'm browsing in chrome and scrolling down a page, if I scroll quickly, there is a noticeable catch while it catches up.
Paying emulators (snes9x and bsnes) has a annoying frame skip every 3 seconds.

I did some searching for win10 microstutter, and thats what it seems similar to, but I can't find a fix for it.

I'm running Win10 on i7-6700 Skylake
MSI Z170a-Pro
Samsung 850 Evo M.2 250gb
G.SKILL Ripjaws V Series 16GB (2 x 8GB) DDR4 2400


I updated all my board drivers yesterday, ran TRIM on the SSD, but the issue still persists.

Anyone have an idea?

Looking at Task Manager, I'm not going over 67% right now. Its jumping between 40% and 67%. I'm transcribing 2 videos in plex, and playing dota. Using 9gb of 16.

I'm not 100% its a video card issue, or maybe a cpu issue.
 
synthtel2
Gold subscriber
Gerbil Elite
Posts: 603
Joined: Mon Nov 16, 2015 10:30 am

Re: Weird fps stuttering

Sat Aug 12, 2017 2:53 pm

67% is pretty high. Does the problem persist if you make sure it's idling at under 10% before firing up a game?
 
XorCist
Gerbil First Class
Topic Author
Posts: 116
Joined: Wed Apr 18, 2007 6:54 pm
Location: Clovis, CA

Re: Weird fps stuttering

Sat Aug 12, 2017 6:35 pm

So off a fresh boot, I sit at 1% cpu use, 20% memory use, and 0-1% disk use. The biggest memory use is for Dropbox and Antimalware Service Exectuteable.

Loaded dota straight up after that

32% cpu, 36% memory, and once loaded and in a game 0% disk use.

Still does the stuttering in game. sitting steady at 99 fps, and then a drop to 70~ fps, and then right back up. When it drops, u can see a lag/catch.

If I watch task manager, there is no change.

I am running a balanced power plan.
Min use 0%
Max 100%
 
synthtel2
Gold subscriber
Gerbil Elite
Posts: 603
Joined: Mon Nov 16, 2015 10:30 am

Re: Weird fps stuttering

Sat Aug 12, 2017 7:43 pm

Can you describe what you mean when you say lag/catch more precisely? Is it dropping to 70 for a second (but staying consistent) as if some momentary background work is slowing it down, or is it just a frame or two completely dropped dragging the average readout down to 70? IOW, on a TR-style frametime plot, is this a wide but shallow or narrow but deep drop? Does input behave as you would expect if a frame or two just disappeared, or is there input/chronological wonkiness?

Can you correlate the framerate drop with a spike or drop on a graph of CPU use? If you have sufficiently granular readouts of GPU and/or PCIe link utilization, what about those?

3.2GB memory use right after boot is pretty high, and I'm still suspicious of background tasks. Just to get a better sense of idle load here (since it's tough to tell with 8 threads), how many processes are running after a reboot, and what are the top consumers of all that memory? If you can measure CPU time in seconds (rather than percent) for granularity, what are the top consumers of that? Resource monitor might help on that one (I forget where stuff is in Windows).

What are your CPU and GPU thermals like, and are they running full-speed the whole time? You could try locking them at 100% speed to see if there's any difference.
 
XorCist
Gerbil First Class
Topic Author
Posts: 116
Joined: Wed Apr 18, 2007 6:54 pm
Location: Clovis, CA

Re: Weird fps stuttering

Sat Aug 12, 2017 8:18 pm

So I'm looking at openhardwaremonitor, and under GPU Load it has weird drops. When I see the fps drop, for some reason the gpu core is dropping to random numbers. 6%, 27% 4%. And each time it drops it bumps right back to 100%.

Something must be wrong with it. I just changed the thermal paste about a month ago cause Dota was crashing randomly and my temps were SKY high.
Now looking again my temps on the gpu are sitting at 98C under full load, and the fan is at 100%

I tried Afterburner, but couldn't find a good graph to put it on. So I left it back at auto. I even uninstalled it yesterday cause I was thinking maybe Afterburner was causing the issue.

I used Masscool Fanner-420 https://www.newegg.com/Product/Product. ... 6835100301

I cleaned it all with alcohol to get all the old paste off, and then I did a thin layer all over, and then a small drop in the middle.
 
DancinJack
Grand Gerbil Poohbah
Posts: 3018
Joined: Sat Nov 25, 2006 3:21 pm
Location: Kansas

Re: Weird fps stuttering

Sat Aug 12, 2017 8:31 pm

XorCist wrote:
Now looking again my temps on the gpu are sitting at 98C under full load, and the fan is at 100%


I think you found your issue?
i7 6700K - Z170 - 16GiB DDR4 - GTX 1080 - 512GB SSD - 256GB SSD - 500GB SSD - 3TB HDD- 27" IPS G-sync - Win10 Pro x64 - Ubuntu/Mint x64 :: 2015 13" rMBP Sierra :: Canon EOS 80D/Sony RX100
 
XorCist
Gerbil First Class
Topic Author
Posts: 116
Joined: Wed Apr 18, 2007 6:54 pm
Location: Clovis, CA

Re: Weird fps stuttering

Sat Aug 12, 2017 8:37 pm

DancinJack wrote:
XorCist wrote:
Now looking again my temps on the gpu are sitting at 98C under full load, and the fan is at 100%


I think you found your issue?



Yea I'm going to take it out right now, and re-clean and re-apply and see what happens. IF it fixes it even temporarily I think maybe the thermal paste is bad. Ive had it for almost 2 years since it was first opened. And keeping it in the garage probably didn't help it.


K I reapplied.

Sitting at 37C at idle. Been spectating a game for the last couple minutes. 79C 71% fan speed. GPU Load keeps fluctuating 100%, 14%, 83%, 55%.


The lag/catch....the best way I could describe it would be say your watching a HD video on an underpowered device, and it goes smooth, and then it has a visible spot where like it speeds up because the buffer caught back up. That's the best way I could describe it.

Maxxed at 82C with 76% fan speed.

Ambient temp is 27C

After boot this is what I have.
141 processes
2480 threads
50450 handles

Resource monitor shows that the biggest ram users on boot are MSMPENG.EXE and Dropbox.exe. According to a quick google, MSMPENG is Windows Defender.

Here is a pastebin of my processes after boot
https://pastebin.com/QMmLBcHS
 
synthtel2
Gold subscriber
Gerbil Elite
Posts: 603
Joined: Mon Nov 16, 2015 10:30 am

Re: Weird fps stuttering

Sat Aug 12, 2017 9:37 pm

The thermals were almost certainly the culprit, but I consider half that number of processes just after boot to be unreasonably high. Maybe go to task manager (and/or msconfig for services) and disable any startup stuff you know you don't need? It's unlikely to help framerates much, but it may make a big difference in general system responsiveness.

Edit, Windows may have started handling services differently recently and that may be responsible for a lot of it. (I hardly use Windows except when repairing other people's machines and if it were a recent change I might have missed its effects.)

Who is online

Users browsing this forum: No registered users and 16 guests