Personal computing discussed

Moderator: Dposcorp

 
rinshun
Gerbil
Topic Author
Posts: 19
Joined: Tue Nov 11, 2014 12:42 am

Utorrent lags in high speed downloads

Sun Feb 10, 2019 11:59 am

Hello,

Utorrent is lagging when I let it download at high speeds. It works fine if I lower the speeds. It won't affect only the application, but the whole system, even the mouse stutters. It was working fine before I changed my motherboard format my SSD and reinstalled windows 10.

In resource manager, there is no indication of high CPU/memory/disk usage

How can i fix this?

Thanks!
 
bthylafh
Maximum Gerbil
Posts: 4141
Joined: Mon Dec 29, 2003 11:55 pm
Location: Southwest Missouri, USA

Re: Utorrent lags in high speed downloads

Sun Feb 10, 2019 1:24 pm

Try updating your network adapter's driver. Also check if other high-speed transfers (such as to another computer on your LAN) are affected.
Hakkaa päälle!
i7-8700K|Asus Z-370 Pro|32GB DDR4|Asus Radeon RX-580|Samsung 960 EVO 1TB|1988 Model M||Logitech MX 518 & F310|Samsung C24FG70|Dell 2209WA|ATH-M50x
 
just brew it!
Gold subscriber
Administrator
Posts: 52303
Joined: Tue Aug 20, 2002 10:51 pm
Location: Somewhere, having a beer

Re: Utorrent lags in high speed downloads

Sun Feb 10, 2019 1:36 pm

Yeah, sounds like a dodgy NIC driver to me.
Nostalgia isn't what it used to be.
 
Usacomp2k3
Gerbil God
Posts: 22556
Joined: Thu Apr 01, 2004 4:53 pm
Location: Orlando, FL
Contact:

Re: Utorrent lags in high speed downloads

Sun Feb 10, 2019 4:43 pm

Does changing the # of connections change anything?
 
Waco
Gold subscriber
Minister of Gerbil Affairs
Posts: 2662
Joined: Tue Jan 20, 2009 4:14 pm
Location: Los Alamos, NM

Re: Utorrent lags in high speed downloads

Sun Feb 10, 2019 4:55 pm

I wonder if you've disabled your NIC's interrupt moderation feature (assuming it even has it). Lots of streams can really hurt crappy NIC drivers and they also typically peg a single core in Windows.
Desktop: Z170A Gaming Pro Carbon | 6700K @ 4.4 | 16 GB | Radeon VII | XSPC RX360 | Heatkiller R3 | Samsung 4K 40" | 2048 + 240 + LSI 9207-8i (128x8) SSD
NAS: 1950X | Designare EX | 32 GB ECC | 7x8 TB RAIDZ2 | 8x2 TB RAID10 | FreeNAS | ZFS | LSI SAS
 
rinshun
Gerbil
Topic Author
Posts: 19
Joined: Tue Nov 11, 2014 12:42 am

Re: Utorrent lags in high speed downloads

Sun Feb 10, 2019 6:04 pm

First of all, thank you guys for your answers! I really apreciate it.

bthylafh wrote:
Try updating your network adapter's driver. Also check if other high-speed transfers (such as to another computer on your LAN) are affected.

1. I updated the drivers, but my motherboard is an H61, (MW-H61H2-M2 1.0) so, it's very old. I also had to update the bios firmware to make it work with my GPU (it worked!). I followed the procedures in their website: http://www.ecs.com.tw/ECSWebSite/Produc ... -Intel-RR-

I only used the CPU EVO to update to 8.1, there are still 2 bios updates: one for support to windows 8.1 and other to support intel 3rd gen cpus. I use windows 10 and 2nd gen CPU, I want to avoid updating the bios if possible because it's a risky procedure and may brick my PC; and there is no guarantee it will fix the issue because there is limited info on what the update does at the website.

2. I checked downloading on chrome using MEGA and they work fine, no lag at all even at twice the torrent speed. (torrents start to lag at 2MB/s)
Waco wrote:
I wonder if you've disabled your NIC's interrupt moderation feature (assuming it even has it). Lots of streams can really hurt crappy NIC drivers and they also typically peg a single core in Windows.

That's possible. I rechecked the CPU usage and it is only ~30%overall; but core 0 is working at 100%
The system is freshly installed, maybe something went wrong somewhere? How to reenable this moderation feature to check it out?

Usacomp2k3 wrote:
Does changing the # of connections change anything?

It starts lagging with only 15 connections, it's hard to test because if I go lower it's hard to keep good transfer rates
 
Waco
Gold subscriber
Minister of Gerbil Affairs
Posts: 2662
Joined: Tue Jan 20, 2009 4:14 pm
Location: Los Alamos, NM

Re: Utorrent lags in high speed downloads

Sun Feb 10, 2019 6:37 pm

First step would be grabbing the drivers for your NIC from the manufacturer's website. By default interrupt moderation should be enabled if it is supported.
Desktop: Z170A Gaming Pro Carbon | 6700K @ 4.4 | 16 GB | Radeon VII | XSPC RX360 | Heatkiller R3 | Samsung 4K 40" | 2048 + 240 + LSI 9207-8i (128x8) SSD
NAS: 1950X | Designare EX | 32 GB ECC | 7x8 TB RAIDZ2 | 8x2 TB RAID10 | FreeNAS | ZFS | LSI SAS
 
bthylafh
Maximum Gerbil
Posts: 4141
Joined: Mon Dec 29, 2003 11:55 pm
Location: Southwest Missouri, USA

Re: Utorrent lags in high speed downloads

Sun Feb 10, 2019 7:12 pm

Looks like that motherboard has an Atheros onboard NIC... so good luck finding manufacturer drivers. :/ Here's an unofficial site, at least: https://www.ath-drivers.eu/

If you don't mind spending a little money you can get an Intel NIC (the gold standard) for around $35, or a Realtek one for less.
Hakkaa päälle!
i7-8700K|Asus Z-370 Pro|32GB DDR4|Asus Radeon RX-580|Samsung 960 EVO 1TB|1988 Model M||Logitech MX 518 & F310|Samsung C24FG70|Dell 2209WA|ATH-M50x
 
just brew it!
Gold subscriber
Administrator
Posts: 52303
Joined: Tue Aug 20, 2002 10:51 pm
Location: Somewhere, having a beer

Re: Utorrent lags in high speed downloads

Mon Feb 11, 2019 5:24 am

rinshun wrote:
That's possible. I rechecked the CPU usage and it is only ~30%overall; but core 0 is working at 100%

That's not a good sign. Especially given the mouse lag, it sounds like that one core is being forced to handle all of the interrupts and is being overwhelmed.

With the old motherboard, it's possible that Windows 10 driver support for the NIC isn't great. If that's the case, you may end up needing to use a discrete NIC to fix this.

Edit: Looks like that motherboard uses a Qualcomm Atheros NIC. FWIW there do seem to be other reports of Windows 10 problems with Atheros NICs; for example: https://answers.microsoft.com/en-us/win ... e551ca820d
Nostalgia isn't what it used to be.
 
rinshun
Gerbil
Topic Author
Posts: 19
Joined: Tue Nov 11, 2014 12:42 am

Re: Utorrent lags in high speed downloads

Mon Feb 11, 2019 10:57 am

I updated the drivers in the motherboard website. Still didn't fix the issue. Then I installed the drivers in the link: https://www.ath-drivers.eu/. I unpacked the x64 files to a folder and then used the update drivers in device manager. It was properly showing the new version in device manager after that. I restarted the PC and then the system crashed. I used the restore point so back to square one. Can a NIC driver crash the system or it was only coincidence?
 
SuperSpy
Gold subscriber
Minister of Gerbil Affairs
Posts: 2365
Joined: Thu Sep 12, 2002 9:34 pm
Location: TR Forums

Re: Utorrent lags in high speed downloads

Mon Feb 11, 2019 11:29 am

Yes, drivers can absolutely crash the system (in fact they are usually one of the few things that can crash the system).

I'd shell out for an Intel NIC and dump the Atheros garbage.
Desktop: i7-4790K @4.8 GHz | 32 GB | EVGA Gefore 1060 | Windows 10 x64
Laptop: MacBook Pro 2017 2.9GHz | 16 GB | Radeon Pro 560
 
Arvald
Silver subscriber
Gerbil Elite
Posts: 735
Joined: Tue Sep 27, 2011 12:14 pm
Location: Gerbil-land, Canada

Re: Utorrent lags in high speed downloads

Mon Feb 11, 2019 4:35 pm

rinshun wrote:
Hello,

Utorrent is lagging when I let it download at high speeds. It works fine if I lower the speeds. It won't affect only the application, but the whole system, even the mouse stutters. It was working fine before I changed my motherboard format my SSD and reinstalled windows 10.

In resource manager, there is no indication of high CPU/memory/disk usage

How can i fix this?

Thanks!

The big question is number of connections.
if set to unlimited then this can easily drag the machine down as many NIC are unable to handle the possible torrents connections.
I've done a fair amount of torrrenting over the years and better NIC always helped.

Who is online

Users browsing this forum: No registered users and 2 guests