Personal computing discussed

Moderators: renee, morphine, Steel

 
jmc2
Gerbil XP
Topic Author
Posts: 364
Joined: Mon Aug 22, 2011 8:30 am

M.2 card, 1TB_M.2 works, 2TB_M.2 Pc won't boot

Mon Aug 24, 2020 12:31 pm

X370 Gigabyte, 3950x cpu

EDIT...These M.2s are NOT for booting the pc.

The 8x slot will not let the pc boot with a 2TB Intel M.2 stick installed.
A 1TB WD M.2 stick works.

The bottom 4x slot works with everything...1TB and 2TB sticks.

I tried two different cards and both had this problem with the 8x slot.
I thought my cards were defective till I tried the 1TB sticks. Then thankfully found that the 4x slot worked properly.

And for anyone else wondering... the 4_M.2 stick Asus card that is for Threadripper will work here but only the bottom M.2 stick will show up.
At least I get a really good heatsink for the 2TB Q-Intel M.2...It slows down badly with a 50 GB file transfer.
Down to hard drive speeds then to <20MB/s - the speed will now go back and forth several times minute (20/150/20/150) as it cools and heats.
I'm hoping the Asus card heatsink will stop this.
 
just brew it!
Administrator
Posts: 54499
Joined: Tue Aug 20, 2002 10:51 pm
Location: Somewhere, having a beer

Re: M.2 card, 1TB_M.2 works, 2TB_M.2 Pc won't boot

Mon Aug 24, 2020 12:51 pm

There are literally 9 different X370 motherboards from Gigabyte. Which one do you have?

Is it possible that the 2TB drives appear to be bootable, and the system is therefore trying (unsuccessfully) to boot from them when they are installed in the first M.2 slot? Check the boot order in the BIOS.
Nostalgia isn't what it used to be.
 
jmc2
Gerbil XP
Topic Author
Posts: 364
Joined: Mon Aug 22, 2011 8:30 am

Re: M.2 card, 1TB_M.2 works, 2TB_M.2 Pc won't boot

Mon Aug 24, 2020 2:14 pm

just brew it! wrote:
There are literally 9 different X370 motherboards from Gigabyte. Which one do you have?

Is it possible that the 2TB drives appear to be bootable, and the system is therefore trying (unsuccessfully) to boot from them when they are installed in the first M.2 slot? Check the boot order in the BIOS.


Motherboard..."GA-AX370-Gaming 5"

I wish I was able to get into the bios with the 8x_slot Adapter card/2TB M.2 installed but the pc just beeps once as usual but then several seconds later beeps again, etc. etc...
Wish I had a spare empty 2TB to test with because the 1TB that works is new/untouched. So there may be something going on there with that.

Plan on getting more 2TBs if I can catch them on sale. Wish they did not stick it to us on the 4TB drive prices.
Not going to get the Intel Quad cells again tho as prices are better now for the better drives.

Thanks
 
just brew it!
Administrator
Posts: 54499
Joined: Tue Aug 20, 2002 10:51 pm
Location: Somewhere, having a beer

Re: M.2 card, 1TB_M.2 works, 2TB_M.2 Pc won't boot

Tue Aug 25, 2020 8:46 am

A few thoughts...

The x8 slot is PCIe 3.0, while the x4 slot is PCIe 2.0. Maybe the Intel SSDs are having trouble negotiating the proper bus speed when plugged into PCIe 3.0 slot?

The x8 slot shares bandwidth with the x16 slot (x16 slot effectively becomes x8 when the x8 slot is in use); were you aware of this?

Are you booting from the onboard M.2 slot, or a SATA port?
Nostalgia isn't what it used to be.
 
jmc2
Gerbil XP
Topic Author
Posts: 364
Joined: Mon Aug 22, 2011 8:30 am

Wed Aug 26, 2020 11:09 am

just brew it! wrote:
A few thoughts...
The x8 slot is PCIe 3.0, while the x4 slot is PCIe 2.0. Maybe the Intel SSDs are having trouble negotiating the proper bus speed when plugged into PCIe 3.0 slot?
The x8 slot shares bandwidth with the x16 slot (x16 slot effectively becomes x8 when the x8 slot is in use); were you aware of this?
Are you booting from the onboard M.2 slot, or a SATA port?


PCIe 3.0...I'll have to see if my bios will let me change the speed of the 8x slot down to 2.0

16x slot down to 8x...I did not know that but my old Vega 56 seems to be fine.
Now the next gen cards that I plan to buy may not be as happy with 8x. Plan on getting whatever is second place on the AMD release.

I'm booting from the onboard M.2 slot (1TB WD-Black)

I tried a number of things to try to get the 2TB Intel 660p to work...
I formatted it to 1TB like the 1TB WB-Black_(which **Works** fine there)

I deleted the 2TB volume on the Intel 660p.
...nothing works at all, can never even reach the bios. (Thank goodness it works in the 4x slot so I know it works at all)

Can't wait for the next gen Threadrippers to come out. Will get whatever is the bottom one. (right now that is 24 cores)
Anything to get off this crippled motherboard and have my 4 slot M.2 adapter card work properly! (Now I do LOVE the 16 cores!)
I was amazed when I had Windows Defender scan a whole high speed M.2 drive... used over 90% of the 16 cores...(need more cores) :)

Only thing left to try is to down speed the 8x slot as you mentioned.
Fingers crossed!

Thank you.
 
Waco
Maximum Gerbil
Posts: 4850
Joined: Tue Jan 20, 2009 4:14 pm
Location: Los Alamos, NM

Re: M.2 card, 1TB_M.2 works, 2TB_M.2 Pc won't boot

Wed Aug 26, 2020 12:52 pm

You don't need a Threadripper, specifically, you just need something that supports PCIe lane bifurcation.
Victory requires no explanation. Defeat allows none.
 
jmc2
Gerbil XP
Topic Author
Posts: 364
Joined: Mon Aug 22, 2011 8:30 am

Re: M.2 card, 1TB_M.2 works, 2TB_M.2 Pc won't boot

Thu Aug 27, 2020 7:03 am

Waco wrote:
You don't need a Threadripper, specifically, you just need something that supports PCIe lane bifurcation.


EDIT... did find and change the PCIe speeds, 3,2,1 no luck, No boot with 2TB M.2 in 8x slot at any speed.

Ah, thanks for that. I can never remember what it is called.

But I've only read of bifurcation in high end Intels and of course in AMD it is only Threadrippers... AFAIK.

EDIT... Did find this about X570 but even then it seems to only supports two of the M.2 slots out of the four on the card.

"AMD X570 motherboard instead, you can use that platform’s CPU PCIe lane bifurcation capability to direct up to eight lanes of PCIe 4.0 to the Hyper M.2 X16 Gen 4 Card—enough for up to two more PCIe 4.0 SSDs"

So my Asus 4 slot M.2 adapter card seems to need access to 4 PCIe lanes for each M.2 slot used. So looks like next gen Threadripper is it. Just hope it comes out this year.
Last edited by jmc2 on Fri Aug 28, 2020 11:27 am, edited 1 time in total.
 
jmc2
Gerbil XP
Topic Author
Posts: 364
Joined: Mon Aug 22, 2011 8:30 am

Re: M.2 card, 1TB_M.2 works, 2TB_M.2 Pc won't boot

Fri Aug 28, 2020 11:19 am

Well, I moved the video card out of the 16x Slot and no luck.
Different M.2 adapter card and different 2TB Intel 660p M.2 stick and 16x Slot...no booting or bios access.

So think I'm done here till I can move back up to bottom end next gen Threadripper.
(This 3950x is 30% faster then the first gen 1950x Threadripper that I have, not going back there.)

Thanks for the thoughts!

Who is online

Users browsing this forum: No registered users and 1 guest
GZIP: On