Personal computing discussed

Moderators: Flying Fox, Ryu Connor

 
internetsandman
Gerbil First Class
Topic Author
Posts: 102
Joined: Wed Jul 01, 2009 2:55 am

Windows Explorer taking a long time to launch

Sat Aug 12, 2017 11:29 pm

I recieved a new Alienware 15 R4 laptop on Thursday, went through all my setup and system migration, and everything seemed fine by Thursday night. Today, from this morning, whenever I start up my computer, it takes longer than normal to log in, and when I do, I'm greeted with a blank screen from which I can move my mouse. From here, it takes approximately 4 minutes and 30 seconds for explorer to properly launch (taskbar appears, background images appear, etc.). I use ctrl+alt+del to access task manager, and I can see that apparently, explorer is running. Terminating the process and restarting it doesn't change anything. I googled around and tried a few suggestions (updating all my drivers and my BIOS, looking into the registry editor, disabling certain startup option though I can't remember which ones), but to no avail., I tried booting into safe mode and explorer started working immediately, as it should, but I can't figure out what would be causing explorer to hang for so long before starting when booting normally.
 
just brew it!
Gold subscriber
Administrator
Posts: 48795
Joined: Tue Aug 20, 2002 10:51 pm
Location: Somewhere, having a beer

Re: Windows Explorer taking a long time to launch

Sat Aug 12, 2017 11:36 pm

Did you install anything between the time it worked fine and now?
Nostalgia isn't what it used to be.
 
internetsandman
Gerbil First Class
Topic Author
Posts: 102
Joined: Wed Jul 01, 2009 2:55 am

Re: Windows Explorer taking a long time to launch

Sat Aug 12, 2017 11:55 pm

just brew it! wrote:
Did you install anything between the time it worked fine and now?


Not as far as I'm aware. I went to run a game stream on friday, everything seemed fine except for random wifi disconnects, that was all I really did on friday and then today this started.
 
UberGerbil
Grand Admiral Gerbil
Posts: 10259
Joined: Thu Jun 19, 2003 3:11 pm

Re: Windows Explorer taking a long time to launch

Sun Aug 13, 2017 4:20 pm

Are you on a domain or otherwise have networking credentials (VPN, mounted network drives, etc) that may be taking time to resolve?

What version of Windows?

For stuff like this, enabling the Bootlog (via MSCONFIG.EXE) and then poring over the results is often the slowest-but-surest way to identify the culprit.
 
toki
Gerbil Team Leader
Posts: 237
Joined: Fri Nov 08, 2013 3:55 pm

Re: Windows Explorer taking a long time to launch

Sun Aug 13, 2017 5:09 pm

I noticed windows taking a long time to load today. I thought something was wrong with my drive and now I see this thread. That is odd. It stayed pause between the boot screen to the splash screen for a long time.
 
Flying Fox
Gerbil God
Posts: 25403
Joined: Mon May 24, 2004 2:19 am
Contact:

Re: Windows Explorer taking a long time to launch

Sun Aug 13, 2017 7:23 pm

toki wrote:
I noticed windows taking a long time to load today. I thought something was wrong with my drive and now I see this thread. That is odd. It stayed pause between the boot screen to the splash screen for a long time.

Your delay is during a different time. The OP's is after the splash screen, right before the time Desktop/Shell launches, to it actually shows up. Yours could be drivers and/or hardware polling. The OP's could be Run/RunOnce, Automatic (not delayed) services and/or even Shell extensions.
The Model M is not for the faint of heart. You either like them or hate them.

Gerbils unite! Fold for UnitedGerbilNation, team 2630.
 
toki
Gerbil Team Leader
Posts: 237
Joined: Fri Nov 08, 2013 3:55 pm

Re: Windows Explorer taking a long time to launch

Sun Aug 13, 2017 9:50 pm

I just checked it again and it loaded up like it should this time. I'm not sure what the problem could have been on my end. It started to worry me though.
 
MOSFET
Silver subscriber
Gerbil First Class
Posts: 173
Joined: Fri Aug 08, 2014 12:42 am

Re: Windows Explorer taking a long time to launch

Sun Aug 13, 2017 9:55 pm

Just out of curiosity,is the new Alienware booting from SSD?
 
freebird
Gerbil
Posts: 38
Joined: Thu Aug 31, 2006 4:03 pm

Re: Windows Explorer taking a long time to launch

Sun Aug 13, 2017 11:32 pm

The 1st thing I would try to narrow it down would be run msconfig.exe and disable all startup programs. I've seen a startup app that couldn't connect to the internet block stuff for several minutes until it timed out. If that didn't work I also look at services that autostart, but probably try safe or diagnostic boot before messing with services.
 
ludi
Darth Gerbil
Posts: 7198
Joined: Fri Jun 21, 2002 10:47 pm
Location: Sunny Colorado front range

Re: Windows Explorer taking a long time to launch

Sun Aug 13, 2017 11:34 pm

toki wrote:
I just checked it again and it loaded up like it should this time. I'm not sure what the problem could have been on my end. It started to worry me though.

Take a look at your update history (System Settings => Check for Updates => "Update History" link) and see if a bunch of recent stuff shows up. It's possible your laptop shipped with a slightly outdated version of Windows and the update process bogged down the machine more than it otherwise should.

Or, maybe it was auto-updating a bunch of vendor preload bloat.
Abacus Model 2.5 | Quad-Row FX with 256 Cherry Red Slider Beads | Applewood Frame | Water Cooling by Brita Filtration
 
internetsandman
Gerbil First Class
Topic Author
Posts: 102
Joined: Wed Jul 01, 2009 2:55 am

Re: Windows Explorer taking a long time to launch

Tue Aug 15, 2017 11:02 pm

I've found two potential problems

In the bootlog, a consistent anomaly seems to be "BOOTLOG_NOT_LOADED \SystemRoot\System32\drivers\dxgkrnl.sys", occuring about four or five times, and then the final error is "BOOTLOG_NOT_LOADED \SystemRoot\system32\drivers\WdFilter.sys"

I also saw in the Dell Support Assistant two application errors, one with the "CLR20r3" code which seems to be the Tobii Eye Engine, I'm not sure if uninstalling the Tobii Eye Tracking software will help this. The other was APPCRASH, from AUDIODG.EXE, and I'm not sure what would need to be done to fix that
 
Chrispy_
Gold subscriber
Grand Gerbil Poohbah
Posts: 3982
Joined: Fri Apr 09, 2004 3:49 pm
Location: Europe, most frequently London.

Re: Windows Explorer taking a long time to launch

Wed Aug 16, 2017 6:35 am

Sounds like something that's trying to launch on logon and either timing out or trying to and then failing, so that it has to try again next logon.

  • Check the Scheduled tasks to see if anything there is unneccesary with a "when any user logs in" trigger.
  • Check msconfig (windows 7) or Task manager (10) > startup tab to nuke any junk that you don't need.
  • Check mapped network drives or cloud storage aren't required for any actions "at logon".

My HTPC started taking forever on Windows 10 to login after entering my login credentials. It was driving me nuts and it turned out to be dropbox one time and an autostart applet on a network drive another time. Network drives are especially dumb, since an SSD laptop can boot and let you login before the network is even connected. It'll do that and then you'll login and your network drive will show as disconnected for another 10-15 seconds whilst it fiinishes initialising the NIC/Wi-fi adapter and loading network services. Automatically started programs, utilities, services and scheduled task actions on these network drives or the web are dumb and will not retry the connection, they just wait for a timeout, all whilst you stare at either a blank screen or spinning welcome animation.
Congratulations, you've noticed that this year's signature is based on outdated internet memes; CLICK HERE NOW to experience this unforgettable phenomenon. This sentence is just filler and as irrelevant as my signature.

Who is online

Users browsing this forum: No registered users and 1 guest