Page 1 of 1

Strange Issue with SolidWorks 2017

Posted: Mon Dec 04, 2017 11:36 am
by general_tux
Hi all,

About 6 months ago, my work purchased a couple new Dell Workstations to replace our aging PCs for running SolidWorks. At the same time, we updated to SolidWorks 2017. One of the new machines has worked great but the other has been plagued with a number of strange issues.

The first is that SolidWorks crashes a lot more frequently than it ever used to and a lot more frequently than the other workstation. At least once a day, SolidWorks will crash hard to the desktop. There is no apparent rhyme or reason to the crash, as in there are no steps that can be reliably used to cause the crash. Even the SolidWorks RX diagnostic utility shows that each crash is unique and that they all have a unique call stack.

The other issue is that occasionally the SolidWorks startup splash screen will hang on "loading registry". It will stay at this step indefinitely. Closing the program and then restarting results in the same hang. The only solution I have found that will allow the program to start is to restart Windows.

I have been in contact with SolidWorks support for the last 4 months and they have not been able to diagnose the cause of these issues. The only idea they have had is that the Creators Update broke something the SolidWorks relies on. Since this machine had the Creators Update installed on it from the factory, I have not found how I can roll the machine back to a state that does not have the update without a full reinstall of Windows. This is not something that corporate IT would like to do and therefore they want to exhaust all other options before we try that.

So far, I have tried the following, all without any measurable improvement:
    1)updated to all of the available SolidWorks 2017 service packs, currently at SP5.0
    2)repaired SolidWorks
    3)reinstalled SolidWorks
    4)uninstalled SolidWorks, removed all SolidWorks entries from the registry, and then reinstalled SolidWorks again
    5)I tried using SolidWorks from a different Windows user, just in case.

I have also made sure that all of my drivers are to date and made sure to use the SolidWorks approved GPU drivers.

I know this isn't a SolidWorks forum, but I am just wondering if anyone has any other ideas that I can try. I have never experienced such a persistent set of software bugs that exist in multiple updates, across several drivers and across multiple user accounts on the machine. The other identical workstation that we purchased at the same time that has the same hardware, drivers and software has not had these issues.

Does anyone have any ideas of what I can try?


Re: Strange Issue with SolidWorks 2017

Posted: Mon Dec 04, 2017 12:02 pm
by drfish
Huh. FWIW, I've used SW 2017 SP1 and SP4 on all three major versions of Win10 available this year with no such problems. I'm a one man IT show, so I don't have the constraints you need deal with. As such, many of the things I would try probably aren't options for you. Here's some low-effort ideas though.

1) Swap the drive to the working workstation from the problematic one, see if the problem follows the drive or is specific to the PC.
2) Blaming the Creators update is probably BS, but if you can't roll back, can you jump to the Fall update? That'll effectively get you a fresh Windows install.
3) Is everything else on the PC 100% stable? No reason to suspect memory trouble? Not a bad idea to run a quick test.

Re: Strange Issue with SolidWorks 2017

Posted: Mon Dec 04, 2017 12:18 pm
by captaintrav
No rhyme or reason to the crashing more often than not would indicate some hardware problem. Run memtest86 on the beast.

Re: Strange Issue with SolidWorks 2017

Posted: Mon Dec 04, 2017 12:22 pm
by general_tux
Hi drfish, it would be difficult to swap the drives since the other machine is my managers and it would be difficult for him to meet his deadlines without a functional system. Also, updating to to the Fall update would also be tough due to how locked down the update process is on these workstations. IT needs to push the update, otherwise they get a bit heavy-handed and roll it back for you. All IT is also offsite, since we are just a small, rather remote, office. Therefore, any major change would involve lots of conference calls that would further eat up time, but it may come to needing that.

The strange thing is, everything else on the machine has seemed perfect. All of the other software that I use has been rock solid and there have been no indications of a hardware issue. The only program that has been problematic has been SolidWorks and its crashes only seem to effect itself. Windows has not shown any signs of general instability.

Captaintrav, I'll try running memtest86 overnight. I'll post what I find out.


Re: Strange Issue with SolidWorks 2017

Posted: Tue Dec 05, 2017 12:46 pm
by general_tux
So just a quick update. I ran memtest86 on the problem machine and no errors were detected. I may try running a longer test (10 passes) tonight to see if that reveals anything.

Anyone have any other ideas?

Re: Strange Issue with SolidWorks 2017

Posted: Mon Dec 11, 2017 12:21 pm
by general_tux
This is hopefully the final update. I updated to SW2017 SP5.0 last week Monday and things have improved immensely. I have had only one crash since the update (instead of at least one per day) and lots of the other weird issues I was experiencing have been fixed as well. Hopefully this is the end of those strange problems so I can actually get back to work. Thanks again!

Re: Strange Issue with SolidWorks 2017

Posted: Mon Dec 11, 2017 12:50 pm
by drfish
Good to hear, though your original post said you were already at 5.0. :o