Personal computing discussed

Moderators: Flying Fox, Ryu Connor

 
roont
Graphmaster Gerbil
Topic Author
Posts: 1316
Joined: Fri Jul 14, 2006 2:27 pm
Location: Ambergris
Contact:

Vista - Ctrl + Shift changes keys

Tue Dec 01, 2009 11:46 am

Hello all, I've run into a strange problem. Well it's not really a problem, but it's annoying.

In Vista, if the CTRL-SHIFT buttons are held down for 2-5 seconds, my ? turns into a É

ÉÉÉÉ

and to get it back to the question mark Ièd have to hold the Ctrl-Shift again.

Iève turned off.... wait... Apparently it effects the ' as well.

I've turned off the language bar completely as I thought that was the problem, but the CrtlShift still messes it up.

It doesnt bother me really, but our CEO is inadvertently going back and forth and he would like to find out how to turn this off completely. Any ideas would be appreciated.
"...and she says, 'That's not my expansion slot.' So my friend says, 'That's not my gold plated 22-pin connector!! Ah-hahahaHA!"
 
wibeasley
Gerbil Elite
Posts: 952
Joined: Sat Mar 29, 2008 3:19 pm
Location: Norman OK

Re: Vista - Ctrl + Shift changes keys

Tue Dec 01, 2009 11:49 am

Is this in Vista, or just in Office?
 
UberGerbil
Grand Admiral Gerbil
Posts: 10192
Joined: Thu Jun 19, 2003 3:11 pm

Re: Vista - Ctrl + Shift changes keys

Tue Dec 01, 2009 11:54 am

That sounds like you've got a multilingual keyboard installed -- I've seen something like this in Canadian setups where they have both the English and French keyboard layouts installed to make it easier to switch from one layout to the other. If you look in the Regional / Language settings in the control panel (not sure exactly what it's called in the Vista "for dummies" control panel) you'll probably see multiple keyboard layouts installed. If you remove everything but English this behavior should go away (there may be a less drastic way to disable it, I don't know).
 
roont
Graphmaster Gerbil
Topic Author
Posts: 1316
Joined: Fri Jul 14, 2006 2:27 pm
Location: Ambergris
Contact:

Re: Vista - Ctrl + Shift changes keys

Tue Dec 01, 2009 12:00 pm

It is in Vista, effecting all applications, not just office.

I think I figured it out though. There was another "International" keyboard installed. I hadn't seen it before because I was looking at the Language bar settings. Deleted this one and it doesn't seem to happen anymore. That's kinda stupid. I never installed a second keyboard. (I set up the CEO's PC myself) and I'm guessing just because I chose Canada as the country Vi$ta went ahead and assumed that I'm bilingual. That's assuming a lot, MS.

Thanks for the pointer, Uber.
"...and she says, 'That's not my expansion slot.' So my friend says, 'That's not my gold plated 22-pin connector!! Ah-hahahaHA!"
 
emorgoch
Gerbil Elite
Posts: 703
Joined: Tue Mar 27, 2007 11:26 am
Location: Toronto, ON

Re: Vista - Ctrl + Shift changes keys

Tue Dec 01, 2009 12:05 pm

Ya, Canadians get the french language keyboard installed by default. Every time I install the OS, first thing I do is go in and remove the secondary keyboard, or, if the user wants the keyboard available, I remove the shortcut to switch between them.
Intel i7 4790k @ stock, Asus Z97-PRO(Wi-Fi ac), 2x8GB Crucial DDR3 1600MHz, EVGA GTX 760
Samsung 950 Pro 512GB + 2TB Western Digital Black
Dell 2408WFP and Dell 2407WFP-HC for dual-24" goodness
Windows 10 64-bit
 
UberGerbil
Grand Admiral Gerbil
Posts: 10192
Joined: Thu Jun 19, 2003 3:11 pm

Re: Vista - Ctrl + Shift changes keys

Tue Dec 01, 2009 12:11 pm

roont wrote:
I'm guessing just because I chose Canada as the country Vi$ta went ahead and assumed that I'm bilingual. That's assuming a lot, MS.
You're assuming that isn't some requirement imposed by Canadian law or to qualify for Canadian government IT sales (not saying it is, but there are stranger things in Windows resulting from local sensibilities -- like the time zone "map" in the clock applet)
Thanks for the pointer, Uber.
cheers

Who is online

Users browsing this forum: No registered users and 3 guests