Personal computing discussed

Moderators: SecretSquirrel, notfred

Gerbil First Class
Topic Author
Posts: 128
Joined: Tue Aug 16, 2011 7:52 pm
Location: Florida

Android internal storage mount problem/question

Wed Aug 27, 2014 10:19 pm

Not sure if this is the right place for this, but also not sure where else to look. I had a post over at xda, but after 3 days and no replies I've given up on that.

I have 3 android tablets, all rooted, all the same model, all with CWM Recovery. I recently updated them to a new 4.4.2 ROM (all from the same prior ROM, and all from the same microSD and source files). Two upgrades went fine, while a third is giving me a headache.

Where I'm at now is that basically the problem tablet does not see its internal storage properly. When plugging in the tablet to a PC, the device is recognized, but the storage is just seen as a generic hierarchical volume with no properties, and no data. When attempting to browse the folder structure via the tablet itself "/storage/emulated/0" (where the 'internalSD' storage should be) says it cannot be found. When I turn on root view to browse, once I get to /root/mnt/sdcard (which should be an accessible folder) "sdcard" seems to be just an empty file of some sort. It's not accessible (like it is on the other two tabs). Likewise, if I navigate to "/root/storage/emulated/legacy" - what should be the "legacy" folder seems to be just another empty file that is not accessible.

All the while, if I go to settings>storage I'm told I have 12GB of free space. Also, if I reinstall an old stock version of 4.0.4 the folder structure and accessibility returns - but as soon as I flash any other ROM (and I've tried many, from different SD Cards, and even different downloads of the same file from different mirrors) - it's back to the same problem. I also tried backing up the PIT file from a good tab, and restoring it to the problem tab, and tried restoring a Nandroid backup from a good tablet - but none of that worked either. I'm not great with this stuff, and I'm all out of ideas. I have adb set up and working if anyone knows of some commands to try.

Thanks for any help
Minister of Gerbil Affairs
Posts: 2143
Joined: Mon Jan 28, 2002 7:00 pm
Location: South Pole

Re: Android internal storage mount problem/question

Sun Mar 22, 2015 1:37 pm

My answer is probably too late but for anyone with the same problem, boot in recovery and reformat the SD card partition. See if that helps.
"I think computer viruses should count as life. I think it says something about human nature that the only form of life we have created so far is purely destructive. We've created life in our own image." -- Stephen Hawking

Who is online

Users browsing this forum: No registered users and 2 guests