Personal computing discussed

Moderators: farmpuma, just brew it!

 
Chun¢
Gerbil XP
Topic Author
Posts: 454
Joined: Mon Oct 20, 2008 7:46 pm

Low PPD?

Sat Feb 26, 2011 12:38 pm

Okay, after i got some gaming out of my system, I've put it back on the fold.
I upgraded to the 6.3 client, set it to 100 %, low priority, and I'm only getting ~200 PPD, if that, and its running 24/7.
I've got a Phenom II 965 Black Edition at stock, (3.4), and my task manager says I'm only using ~25%. Should I expect more PPD? How can I get it to use all of the cpu?
Image
 
Ari Atari
Gerbil First Class
Posts: 132
Joined: Wed Jan 26, 2011 3:00 pm
Location: Earth

Re: Low PPD?

Sat Feb 26, 2011 2:01 pm

It looks like it's only folding on 1 core, which would explain the low points. Are you using the SMP client with the -smp flag activated?
 
farmpuma
Silver subscriber
Minister of Gerbil Affairs
Posts: 2412
Joined: Mon Mar 22, 2004 12:33 am
Location: Soybean field, IN, USA, Earth .. just a bit south of John .. err .... Fart Wayne, Indiana
Contact:

Re: Low PPD?

Sat Feb 26, 2011 2:21 pm

Yep, you need to add the -smp flag to your launch shortcut or the 6.3 .exe shortcut.

Also request a passkey and add it to your config file using a shortcut with the -configonly flag. (Note - Stop the client First.) The passkey will enable the early return bonus points (well worth the effort) after your tenth finished work unit.
Image Image
.* * M-51 * *. .The Whirlpool Galaxy.
 
Chun¢
Gerbil XP
Topic Author
Posts: 454
Joined: Mon Oct 20, 2008 7:46 pm

Re: Low PPD?

Sat Feb 26, 2011 3:32 pm

I've already got a passkey in it, and just added the -smp flag.
EDIT: CPU usage just shot up to 50%
Image
 
just brew it!
Gold subscriber
Administrator
Posts: 44202
Joined: Tue Aug 20, 2002 10:51 pm
Location: Somewhere, having a beer

Re: Low PPD?

Sat Feb 26, 2011 3:43 pm

If the SMP client is running properly, it really ought to be 100%.
The years just pass like trains. I wave, but they don't slow down.
-- Steven Wilson
 
Ari Atari
Gerbil First Class
Posts: 132
Joined: Wed Jan 26, 2011 3:00 pm
Location: Earth

Re: Low PPD?

Sat Feb 26, 2011 3:44 pm

Hmm... it should go to 100% if its using all four cores unless you only want it at 50%. Try using "-smp 4" without the quotes to manually set it to use all four cores.
 
Flying Fox
Gerbil God
Posts: 25100
Joined: Mon May 24, 2004 2:19 am
Contact:

Re: Low PPD?

Sat Feb 26, 2011 3:50 pm

If you use put -smp it shouldl use all the cores, unless you put something like -smp 2 that will limit it to use 2 cores. According to the docs CPU% does not work anymore so you can only control usage through how many cores it uses.
The Model M is not for the faint of heart. You either like them or hate them.

Gerbils unite! Fold for UnitedGerbilNation, team 2630.
 
Chun¢
Gerbil XP
Topic Author
Posts: 454
Joined: Mon Oct 20, 2008 7:46 pm

Re: Low PPD?

Sat Feb 26, 2011 4:10 pm

I gotta go to work right now, so i'll let it run over night. If my ppd isn't up, ill try -smp4.
Image
 
DancinJack
Gold subscriber
Minister of Gerbil Affairs
Posts: 2588
Joined: Sat Nov 25, 2006 3:21 pm
Location: Kansas

Re: Low PPD?

Sun Feb 27, 2011 2:07 pm

You shouldn't need -smp4. -smp should engage all cores.

Get it figured out?
i7 6700K - Z170 - 16GiB DDR4 - GTX 1080 - 512GB SSD - 256GB SSD - 500GB SSD - 3TB HDD- 27" IPS G-sync - Win10 Pro x64 - Ubuntu/Mint x64
2015 13" rMBP Sierra
Sony RX100
 
Chun¢
Gerbil XP
Topic Author
Posts: 454
Joined: Mon Oct 20, 2008 7:46 pm

Re: Low PPD?

Sun Feb 27, 2011 2:45 pm

Yeah, all 4 cores running at 100%. With this flag does Stanford send different WU's? I'd normally turned one in by now.
Image
 
DancinJack
Gold subscriber
Minister of Gerbil Affairs
Posts: 2588
Joined: Sat Nov 25, 2006 3:21 pm
Location: Kansas

Re: Low PPD?

Sun Feb 27, 2011 3:20 pm

Chun¢ wrote:
Yeah, all 4 cores running at 100%. With this flag does Stanford send different WU's? I'd normally turned one in by now.


Are you running any other flags?

You don't normally run that CPU with the -smp flag?
i7 6700K - Z170 - 16GiB DDR4 - GTX 1080 - 512GB SSD - 256GB SSD - 500GB SSD - 3TB HDD- 27" IPS G-sync - Win10 Pro x64 - Ubuntu/Mint x64
2015 13" rMBP Sierra
Sony RX100
 
Ari Atari
Gerbil First Class
Posts: 132
Joined: Wed Jan 26, 2011 3:00 pm
Location: Earth

Re: Low PPD?

Sun Feb 27, 2011 4:39 pm

Chun¢ wrote:
Yeah, all 4 cores running at 100%. With this flag does Stanford send different WU's? I'd normally turned one in by now.


Ya the smp work units are different than the single core wu. They take longer, and more processing power, but are worth a lot more.
 
Flying Fox
Gerbil God
Posts: 25100
Joined: Mon May 24, 2004 2:19 am
Contact:

Re: Low PPD?

Sun Feb 27, 2011 7:00 pm

DancinJack wrote:
You don't normally run that CPU with the -smp flag?
He did not know of the -smp switch, so his client had been processing single core WUs.

Ari Atari wrote:
Chun¢ wrote:
Yeah, all 4 cores running at 100%. With this flag does Stanford send different WU's? I'd normally turned one in by now.

Ya the smp work units are different than the single core wu. They take longer, and more processing power, but are worth a lot more.
For reference, I have the same CPU as the OP, and based on my observation of a few WUs (just switched to WinSMP) it takes anywhere between 16-26 hours depending on the exact project. However, with bonuses each WU is worth thousands of points. So you are still looking at 2-3K ppd in effect.

Welcome to the tasty world of SMP WUs! ;)
The Model M is not for the faint of heart. You either like them or hate them.

Gerbils unite! Fold for UnitedGerbilNation, team 2630.
 
Chun¢
Gerbil XP
Topic Author
Posts: 454
Joined: Mon Oct 20, 2008 7:46 pm

Re: Low PPD?

Sun Feb 27, 2011 7:17 pm

That's good news, Because I've been making ~200 PPD ever since I upgraded my graphics.
Any word on when the next AMD client is coming?
Image
 
Flying Fox
Gerbil God
Posts: 25100
Joined: Mon May 24, 2004 2:19 am
Contact:

Re: Low PPD?

Sun Feb 27, 2011 7:36 pm

Chun¢ wrote:
That's good news, Because I've been making ~200 PPD ever since I upgraded my graphics.
Any word on when the next AMD client is coming?

If you have never folded A3 SMP WUs with the passkey, you will need to bear with it for a while. Only after 10 WUs folded the early return bonus kicks in.
The Model M is not for the faint of heart. You either like them or hate them.

Gerbils unite! Fold for UnitedGerbilNation, team 2630.
 
Chun¢
Gerbil XP
Topic Author
Posts: 454
Joined: Mon Oct 20, 2008 7:46 pm

Re: Low PPD?

Sun Feb 27, 2011 7:56 pm

It's whatever, I'm probably going to switch over to UGN before too long.
Image
 
just brew it!
Gold subscriber
Administrator
Posts: 44202
Joined: Tue Aug 20, 2002 10:51 pm
Location: Somewhere, having a beer

Re: Low PPD?

Mon Feb 28, 2011 12:31 am

If you want some idea of the kind of production you will get from the SMP WUs, take a look at my stats. I've got the SMP client running on 6 AMD systems, ranging from an old Socket 939 dual-core to a Phenom II 955 quad. My two Phenom II quad systems (the other one is a 945) probably account for close to half of the total PPD. (There are a couple of old Socket 754 single-core systems in the mix too, but their PPD is pretty much lost in the noise...)
The years just pass like trains. I wave, but they don't slow down.
-- Steven Wilson
 
Flying Fox
Gerbil God
Posts: 25100
Joined: Mon May 24, 2004 2:19 am
Contact:

Re: Low PPD?

Mon Feb 28, 2011 8:27 am

Chun¢ wrote:
It's whatever, I'm probably going to switch over to UGN before too long.

PM any of the UGN members so we can send you the passkey for UGN to get the early return bonus. BTW thanks for joining UGN!

Perhaps you should enjoy a few more days of big points for yourself first before joining up. ;)
The Model M is not for the faint of heart. You either like them or hate them.

Gerbils unite! Fold for UnitedGerbilNation, team 2630.

Who is online

Users browsing this forum: No registered users and 1 guest