Home Darth Via revisited
News

Darth Via revisited

Ryu Connor
Disclosure
Disclosure
In our content, we occasionally include affiliate links. Should you click on these links, we may earn a commission, though this incurs no additional cost to you. Your use of this website signifies your acceptance of our terms and conditions as well as our privacy policy.

I know, I know. You’re all thinking, “Ryu and Darth Via again. Oh boy, here we go.”

Well, I am going to be good this time; I promise.

The last few days have seen Via issue some press releases about the existence of the 686B and SBLive! issue. Furthermore, certain websites have done some independent, broad-but-not-widespread testing. Before I jump too far, though, let’s take a look at some things.

The following quote was taken from this website. It is in German, but Kyle Bennett of the [H]ard|OCP has a translated copy:

In this case, there is a problem with the VIA southbridge 686B, which is used by plenty of mainboard manufacturers. VIA has tested the southbridge thoroughly and came to the following conclusion: Using certain system configurations there is a problem concerning heavy data traffic from a master ATA66/100 HDD to a slave ATA66/100 HDD. Only mainboards of manufacturers (not all) using the KT133 and KT133A chipset with the 686B southbridge are affected. Furthermore the problem occurs only while a Creative Live PCI soundcard is used. Using another soundcard we couldn’t reproduce the problem. We gave all our partners a bugfix as a solution. The manufacturers should be able to solve the problem with a BIOS update. For further information please contact the manufacturer/dealer of your mainboard.

Okay, so the issue exists with certain 686B and KT133(A) motherboard implementations, but not all of them. It only happens with the SBLive! sound card. It is only brought about by the movement of large amounts of data to and from ATA-66/100 hard drives on each channel. Okay, that’s pretty cut and dry. Now let’s look at what VIA Hardware received today:

During the past few weeks, problems were reported on several web sites stating that one of VIA’s chipset has compatibility issue with Creative SoundBlaster Live PCI Sound card. After debugging, verifying, and checking compatibility between our VT82C686B and other devices, we concluded that the problem is not totally related to our chipset. We found that the system problem will happen only under certain configurations and certain procedures, and only occur under Athlon processor based systems with VT82C686B chipset and Creative SB Live card. We also checked whether our chipset has any compatibility issues in other configurations, and the result was we did not find any such compatibility issues.

The configuration is described as follows: One IDE HDD ATA-100 or one ATA-66 HDD and enable default DMA mode; one IDE DVD-ROM and enable fault DMA mode; one Creative SB Live PCI sound card; one VGA card; and copy file, W2KSP2.exe (Win2K service pack2).

Consequently, we also developed a new IDE driver to resolve the compatibility issue with the Creative SoundBlaster sound card, and this IDE driver will be posted at our website for users who have Athlon based systems using this configuration.

Okay, so now it will only happen on Athlon 686B chipsets. Does this mean AMD 760 implementations? An ATA 66/100 HD on the primary, anything on the secondary, and a SBLive! card. And it is most definitely the fault of the SBLive!.

Well, the story isn’t identical, but its close enough I figure one doesn’t have room to call for a conspiracy. There is one thing that bothers me, though. This article at Real World Technologies describes some pretty thorough testing and comes to these conclusions:


  1. KT133(A) & 694X, 686(A & B), something other than SBLive!, no problem.


  2. KT133(A) & 694X, 686(A & B), and SBLive! exhibit error.


  3. AMD/VIA chipset combo, full Intel or ALi chipset, and SBLive! no issues.

  4. Via Apollo Pro 266, 8233, SBLive!, no errors.

Now, Via said the problem’s only with the 686B and KT133/KT133A. They also said that it only affects the Athlon. Then why is the 686A and the Apollo Pro Intel chipset suffering these issues? Is Darth Via just so big they got their right and left hands crossed? Did the limited test samples in the RWT test unfavorably bias the test? Or has VIA discovered a really big bug, but they’re not owning up to it?

Latest News

Cristiano Ronaldo, the highest paid athlete in 2023
Statistics

Top 20 Highest-Paid Athletes in 2023-24

Avast Slapped With A Fine of $16.5 Million For Selling User Data
News

Avast Slapped With A Fine of $16.5 Million For Storing & Selling User Data

Avast, the popular cybersecurity company that’s best known for its VPN and antivirus software (especially its class-leading free antivirus solution), is being fined for infringing upon its user’s privacy. The...

Google
News

Reddit Inks $60 Million AI Content Licensing Agreement with Google

Social media platform Reddit has finalized a landmark content licensing contract with Google. The deal is worth about $60 million per year and will supply the search and advertising giant...

Nationwide Cyber Attack Slows Down Prescription Processing
News

Nationwide Cyber Attack Slows Down Prescription Processing Across Pharmacies 

Google's AI Image Bot Too Woke, To Undergo A Fix
News

Google Promises To Fix Its AI Image Bot After It Was Accused Of Being Too Woke

Bitcoin
News

Bitcoin Advocate Tom Lee Defends Bitcoin Over Claims of Illegal Use

Bitcoin BTC Steady Above $51,000 Level Amidst Volatility, Expert Predicts Continued Price Growth
Crypto News

Bitcoin BTC Steady Above $51,000 Level Amidst Volatility, Expert Predicts Continued Price Growth